Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
DNS help PLEASE!!
Results 1 to 3 of 3

Thread: DNS help PLEASE!!

  1. #1

    DNS help PLEASE!!

    i have been struggling with this DNS setup on Red Hat 9 for about 3 days now and i just can seem to get things working. any advice would be a great help here. here is what i have as of now:

    (named.conf):


    Code:
    options { 
    directory "/var/named"; } 
    
    controls { 
    inet 127.0.0.1 allow { localhost; } keys { rndckey; }; 
    }; 
    
    zone "." IN { 
    type hint; 
    file "named.ca"; 
    } 
    
    zone "localhost" IN { 
    type master; 
    file "localhost.zone"; 
    allow-update { none; }; 
    }; 
    
    zone "mydomain.com" IN { 
    type master; 
    file "mydomain.zone"; 
    allow-update { none; }; 
    }; 
    
    zone "0.0.127.in-addr.arpa" IN { 
    type master; 
    file "named.local"; 
    allow-update { none; }; 
    }; 
    
    include "/etc/rndc.key";

    and here is the other file
    (mydomain.zone)


    Code:
    $TTL 86400 
    $ORIGIN localhost. 
    @   SOA  mydomain.com. root.mydomain.com. ( 
                     420012 
                3H 
                15M 
                1W 
                1D 
                                          ) 
                            NS      ns1.mydomain.com. 
              NS      ns2.mydomain.com. 
                            A       xxx.xxx.xxx.xxx 
    ftp                     CNAME   mydomain.com. 
    mail                    CNAME   mydomain.com. 
    ns                      CNAME   mydomain.com. 
    www                     CNAME   mydomain.com.
    if there is anything else i can supply to make it easier to find the problem let me know ill be happy to supply what i can.

  2. #2
    Administrator Moderator
    Member
    starfish's Avatar
    Join Date
    Apr 2004
    Posts
    141
    What's the problem? Can you resolve your DNS from the DNS server but not from the Web?

    What rerror messages do you get in the /var/log/messages file when you restart BIND named?

    My experience has been that RedHat 9's BIND doesn't restart properly with the "restart" option. It gives a "named: already running" message and doesn't read the config files at all. You have to use the pkill command, then the "service named start" command to get the files to be read correctly.

    [root@zippy tmp]# pkill named
    [root@zippy tmp]# service named start
    [root@zippy tmp]# OK ]


    The output should look like this, informational with no errors loading anything.

    Mar 5 09:48:34 zippy named[661]: shutting down: flushing changes
    Mar 5 09:48:34 zippy named[661]: stopping command channel on 127.0.0.1#953
    Mar 5 09:48:34 zippy named[661]: no longer listening on 127.0.0.1#53
    Mar 5 09:48:34 zippy named[661]: no longer listening on 216.10.119.243#53
    Mar 5 09:48:34 zippy named[661]: no longer listening on 192.168.1.200#53
    Mar 5 09:48:34 zippy named[661]: exiting
    Mar 5 09:48:41 zippy named[25386]: starting BIND 9.2.1 -u named
    Mar 5 09:48:41 zippy named[25386]: using 1 CPU
    Mar 5 09:48:41 zippy named: named startup succeeded
    Mar 5 09:48:41 zippy named[25386]: loading configuration from '/etc/named.conf'
    Mar 5 09:48:42 zippy named[25386]: no IPv6 interfaces found
    Mar 5 09:48:42 zippy named[25386]: listening on IPv4 interface lo, 127.0.0.1#53
    Mar 5 09:48:42 zippy named[25386]: listening on IPv4 interface wlan0, 216.10.119.243#53
    Mar 5 09:48:42 zippy named[25386]: listening on IPv4 interface eth0, 192.168.1.200#53
    Mar 5 09:48:42 zippy named[25386]: command channel listening on 127.0.0.1#953
    Mar 5 09:48:42 zippy named[25386]: zone 0.0.127.in-addr.arpa/IN: loaded serial 1997022700
    Mar 5 09:48:42 zippy named[25386]: zone 1.16.172.in-addr.arpa/IN: loaded serial 51
    Mar 5 09:48:42 zippy named[25386]: zone 1.168.192.in-addr.arpa/IN: loaded serial 51
    Mar 5 09:48:42 zippy named[25386]: zone site2.com/IN: loaded serial 2004050303
    Mar 5 09:48:42 zippy named[25386]: zone site1-int.com/IN: loaded serial 2004030801
    Mar 5 09:48:42 zippy named[25386]: zone localhost/IN: loaded serial 42
    Mar 5 09:48:42 zippy named[25386]: zone site2.com/IN: loaded serial 200405033
    Mar 5 09:48:42 zippy named[25386]: running

  3. #3
    thks ill give that a try and see what i get

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •