Warning: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in ..../includes/class_bbcode.php on line 2958
Imq not working
Results 1 to 4 of 4

Thread: Imq not working

  1. #1

    Imq not working

    I am trying to put tc - traffic control to work on a router I am developing.

    IMQ is used for ingress traffic, I am using openwrt libraries for that, libraries are all fine. Problem is with my kernel.

    As the openwrt script run this line -
    iptables -t mangle -A PREROUTING -i eth0 -j IMQ --todev 0
    All the outgoing and incoming traffic blocks, Openwrt provides some patches

    But problem is this patches are applied on 2.6.28 and my kernel(2.6.2 doesn't have even this files. I tried to find out file "net/ipv4/netfilter/ipt_IMQ.c" in many kernels including 2.6.30 but it was not found.

    Strange part is it is there in - and linux- But I want to make it work with 2.6.28.

    If anybody has patch solution or any other better solution, please do post.

  2. #2
    Any answers ???

  3. #3
    Administrator Advisor peter's Avatar
    Join Date
    Apr 2004
    Sahilmakkar, did you find a solution to this? I don't have much experience with Openwrt.

  4. #4
    redhead's Avatar
    Join Date
    Jun 2001
    Copenhagen, Denmark
    Have you tried the patches from the IMQ homepage before adding the openwrt patch of their work ?
    Don't worry Ma'am. We're university students, - We know what We're doing.
    'Ruiat coelum, fiat voluntas tua.'
    Datalogi - en livsstil; Intet liv, ingen stil.

Similar Threads

  1. Imq not working
    By sahilmakkar in forum Linux - General Topics
    Replies: 0
    Last Post: 11-09-2010, 12:45 PM
  2. init not working
    By JoeyJoeJoe in forum Linux - General Topics
    Replies: 5
    Last Post: 11-19-2006, 11:06 PM
  3. Pad not working
    By TeRG in forum Linux Distros
    Replies: 1
    Last Post: 03-16-2004, 03:52 AM
  4. PHP not working in RH8
    By Pleiades in forum Linux - Hardware, Networking & Security
    Replies: 5
    Last Post: 02-24-2003, 01:17 PM
  5. Almost got it working...
    By gmoreno in forum Linux - General Topics
    Replies: 6
    Last Post: 12-19-2001, 02:14 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts