I tried Sabayon Linux 5.2, first as a live distro, then when I was satisfied of it's perfomance, I thought that it was a keeper. So I decided to install it in my tower.

The tower has two hard drives and two DVD burners. One hard drive is reserved for Windows, and the other for Linux. Before installing the latest version of Sabayon Linux, I had an older version of that Linux OS in that SATA hard drive. I proceeded to perform the installation of Sabayon 5.2 in the tower. Everything was going okay. No visible problems showed up and no error messages presented itself. I just made sure that Sabayon was to install itself in the Linux hard drive, and not touch the Windows hard drive. At the end, I saw a message that it was installing GRUB boot manager. Then it offered me to continue using the live version for a while, or to reboot, to use my newly install version of Sabayon. I chose to reboot. When Grub was done with it's stage-5 of setting up the bootloader, it immediately dropped me down into the text mode of GRUB for troubleshooting. Tried it several times, but the results were always the same. I went to the web site, but couldn't seem to get direct help in solving this problem, so I created a bug report. When I came back to the Sabayon Forum, a SL female fan, reported that she also has had the same problem with that particular version of SL. I indicated that I would try the text mode of installation, and she said that she would try the 32-bit version to see if the results were the same. Well, the 64-bit text-mode installation produced the same errors. Went back on the forum, and found out that the female had indeed downloaded the 32-bit version, and installed. She reported that again, GRUB failed to produce a GUI menu to select the installed OS's. It dropped her into the text trouble shooting mode. After so many tries and not getting anywhere, that was it! I had it! I finally installed PCLinuxOS in the tower, and never got to get a full feel of the installed latest version of Sabayon Linux.