Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Webserver in Virtual Box
Results 1 to 5 of 5

Thread: Webserver in Virtual Box

Hybrid View

  1. #1

    Webserver in Virtual Box

    Good Day,

    I'm using Sun's Virtual Box to run Ubuntu Server 9.04.

    The host OS is Microsoft Vista Home Premium

    The machine is a dual core Compaq with 3gb with Netgear wireless adapter.

    Sun's Virtual Box - and - Ubuntu Server installed perfectly.

    I can use Ubuntu Firefox at the same time I use Vista Firefox to browse the web.

    I have Apache installed on Ubuntu server.

    On the Ubuntu virtual machine, I can browse 'localhost' and I get the Apache Web Server front page. No problem.

    ====================
    Here is the problem...

    When I go to Vista, I do *NOT* see the 'localhost' - the front page of the web server in the Ubuntu Server Virtual Machine.

    ====================
    Question...

    How do I get the Ubuntu Virtual Server to serve web-pages that the host can see?

    Much thanks.





    ==============
    Here is the question...

  2. #2
    Newbie
    Join Date
    Jul 2009
    Location
    Beijing - PRC
    Posts
    2
    hi,
    you mentioned that in your host OS (Vista) you can not access running webserver in your virtual OS trough localhost address,
    I think it is better to type your virtual server's IP address in your host OS (Vista) browser and it will work. Run ifconfig in your virtual OS command line to get your MAC IP address.
    have a nice time and excuse me for my poor English.

  3. #3
    Advisor beezlebubsbum's Avatar
    Join Date
    May 2004
    Location
    Australia
    Posts
    735
    i would have to agree with that reply, that should work

  4. #4
    Quote Originally Posted by beezlebubsbum View Post
    i would have to agree with that reply, that should work
    If I may suggest, put VirtualBox networking into "bridging" mode. That will give your Ubuntu a network address on your local net, and therefore be reachable that way.

    Just a thought.

  5. #5
    I will go with sikandarnoori.

Similar Threads

  1. Issues creating a VLans using virtual NICs (Virtual-hosts)
    By knight72 in forum Linux - Hardware, Networking & Security
    Replies: 0
    Last Post: 11-19-2005, 11:37 PM
  2. My Webserver
    By beezlebubsbum in forum Linux - Software, Applications & Programming
    Replies: 18
    Last Post: 08-23-2005, 06:19 AM
  3. back up virtual machines in Virtual Server 2005
    By regix in forum Windows - General Topics
    Replies: 0
    Last Post: 01-01-2005, 09:03 PM
  4. WebServer
    By vwgtiturbo in forum Linux - Software, Applications & Programming
    Replies: 16
    Last Post: 10-23-2003, 05:30 AM
  5. Webserver
    By trickster in forum Linux - Hardware, Networking & Security
    Replies: 7
    Last Post: 08-27-2002, 01:24 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •