Results 1 to 6 of 6

Thread: help with LS_COLORS

  1. #1

    help with LS_COLORS

    I would like to set my terminal window to display the various file types by color. However, I cannot seem to figure out how to set this. My system is RedHat Linux. Any help here would be greatly appreciated. Thanks.

  2. #2
    Administrator Moderator
    Member
    starfish's Avatar
    Join Date
    Apr 2004
    Posts
    141
    What does the output of this command give?

    # env | grep TERM

    Text terminal settings for color should be set to "vt100" or "xterm" (if on the console)

    This TERM variable is usually set automatically when you log in. Make sure your SSH or remote login client is set up correctly for VT100 emulation.

    If logging in from the console, the defaults should be OK.

  3. #3
    It shows TERM=vt100

  4. #4
    Administrator Moderator
    Member
    starfish's Avatar
    Join Date
    Apr 2004
    Posts
    141
    Is this from the VGA console or using a remote SSH or telnet client?

    What client are you using? You'll have to edit the preferences and set it not only to vt100, but to also support "ANSI color"

  5. #5
    I am guessing that it is from remote. I just call up xterm from the main menu. I am not sure what client I am using, but it runs in c shell if that helps.

  6. #6
    Administrator Moderator
    Member
    starfish's Avatar
    Join Date
    Apr 2004
    Posts
    141
    If it's X from the GUI inetrface then it is a local application.

    I generally use BASH under Fedora and it figures it out on its own. Try setting your environmental terminal type to "xterm".

    I think the command using the C shell is:

    # setenv TERM xterm

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •