Results 1 to 8 of 8

Thread: Can't print through my Win98SE PC

Hybrid View

  1. #1

    Unhappy Can't print through my Win98SE PC

    Just learning SuSE 9. Lots set up OK, and can read files via router on the old Win98SE PC.
    I can't get to be able to print on the Epson printer on the Win PC. The printer is set to share OK, and the Linux PC can see the Win one OK. I've set up the printer on the Linux PC, and it sends OK to the Printer Jobs file, which sticks at saying "processing". It all looks OK AFAIK in Samba.

    Now I am truly at a loss. I did wonder whether Zonealarm firewall on the Win PC might be something to do with the problem, but nothing gives me any diagnostics.

    Please help ! I've wasted tooooooo much valuable time!!

  2. #2
    Junior Member girlygeek's Avatar
    Join Date
    Jan 2006
    Posts
    54
    It could be ZoneAlarm. Have you tried it with ZA turned off?

    When trying to do this run the command "tail -f /var/log/messages" in a new terminal window on the Linux server and see if there are any interesting errors that show up. You could post them here or do a web search to see if anyone else has had a similar problem.

    Figuring out what the error is will make it a lot easier to solve.

  3. #3
    Ran the command three times from a command window, and absolutely nothing visible happened.

  4. #4
    Is you syslog deamon set to log at debug level to /var/log/messages? Check your /etc/syslog.conf file. Let it look like this:

    Code:
    replace
    
    *.info;mail.none;authpriv.none;cron.none               /var/log/messages
    
    with
    
    *.debug                                                 /var/log/messages
    restart syslog and try again.

    Code:
    service syslog restart
    Did it work with the FW turned off? Is your Linux server running iptables?

  5. #5
    Unable to save the edited file because it said I didn't have write permission.

    Also, BTW, what is FW ??

    I did notice that in the etc/services file there is a line

    swat 901/tcp # CONFLICT; not official assigned

    Is this relevant ??

    I'm also suspecting now that at l;east part of the problem might be that the Win98 side is still not fully set up correctly.

    Thanks for halp so far.

  6. #6
    Sorry, FW as in firewall.

    You'll have to do the syslog.conf edits as the root user.

    The /etc/services entry just looks informational, you shouldn't have to worry.

    BTW, do you have "File and Printer sharing" enabled on your Win98SE's interfaces?

    You may also have to enable "Client for Microsoft Networks" too... no, maybe not, the PC is the print server in this case.

Similar Threads

  1. Networking to Win98SE PC
    By toastrack in forum Linux - Hardware, Networking & Security
    Replies: 3
    Last Post: 10-02-2007, 03:43 PM
  2. DOS print Q for XP
    By CodeSculptor in forum Windows - General Topics
    Replies: 1
    Last Post: 06-21-2006, 03:52 PM
  3. Help! Soyo mobo users/Hpt366 vs. Win98se Drivers
    By NightSky in forum Windows - General Topics
    Replies: 0
    Last Post: 10-23-2005, 06:07 PM
  4. Help! I want to print!
    By Gommans in forum Linux - Software, Applications & Programming
    Replies: 4
    Last Post: 08-31-2002, 11:10 PM
  5. print server
    By agar in forum Linux - Hardware, Networking & Security
    Replies: 3
    Last Post: 12-03-2001, 06:25 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •