Results 1 to 10 of 10

Thread: Suse 9.0 Fried

  1. #1

    Suse 9.0 Fried

    After rebooting this morning, my Suse system suddenly became fried. Instead of booting into xwindows it booted to a different login menu then I'd seen before(not the usual Suse login with the drop down windows manager). When I log in I'm not given a choice to boot to KDE, Gnome, etc. It just boots to a weird black and white crossed screen. There's a Console window at the bottem that reads "linux kernel: mtrr: 0xf...,00... overlaps existing 0xf...,0x10...
    If I click on the desktop the window says TWM and gives me some options. It does have a terminal window option which gets me to an xterm. If I type startx I get an error that reads: "Fatal server error: server is already active for display 0....Xlib: Connection to ":0.0" refused by server. Xlib: Invalid MIT-MAGIC-COOKIE-1 key giving up. Xinit: Unable to connect to X server
    xinit: NO such process (errno 3): Server error.
    I booted into the Suse install disk and did a repair of installation. It reported an error in 2 spots and in the Resier system and said it repaired them, but same thing happened. Does anyone know what happened, or how to fix this? Thanks.

  2. #2

    Re:Suse 9.0 Fried

    Hrmm....try reinstalling gdm?

  3. #3

    Re:Suse 9.0 Fried

    Well as I'm sure you figured out that black and white crossed screen IS XWindows and it is using TWM as its window manager. I'm not exactly sure of the start commands for kde and gnome, but I think kde's command is 'startkde' and I have no idea for gnome. Try those in xterm window and see what happens, probably more errors but its worth a shot. Maybe your XFree86.config file became corrupt somehow.

  4. #4

    Re:Suse 9.0 Fried

    Sounds like the gdm sessions file b0rked itself. You might jump into GNOME (gnome-session is the startup executable), and check the login options. If the sessions are missing, there's your problem.

  5. #5

    Re:Suse 9.0 Fried

    When I try to start kde I get an errors as follows:

    xsetroot: unable to open display ''
    xset: unable to opn display ""
    ksplash cannot connect to X server
    kdeinit: aborting. $DISPLAY is not set
    Warning: connect() failed: : No such file or directory
    ksmserver: cannot connect to X server
    startkde: Shutting down...
    Warning: connect() failed: : No such file or directory
    Error: Can't Contact kdeinit!
    startkde: Running shutdown scripts

    Am I wrong here or is this indicating a problem with my display config? I was able to load YAST from the bash prompt and it showed the correct videocard and monitor, but it showed 3d acceleration as being on(which I didn't set it as). I tried to change it, but the system crashed when do that. I keep running the repair option from the install disk, and it keeps reporting an error, that it says it repairs, but returns every time. Is there anything I can do, or do I need to just reinstall?

  6. #6

    Re:Suse 9.0 Fried

    something similar happened to me with SuSE (8.1).
    Trying running sax2...
    After running sax2 and configuring X, everything seemed to work fine.

  7. #7

    Re:Suse 9.0 Fried

    crashes when I try to run sax2

  8. #8

    Re:Suse 9.0 Fried

    does it give you an error? if so, please post it...

  9. #9

    Re:Suse 9.0 Fried

    No error. I think I've traced the problem back to an online update. I'm just not sure which one. I've reinstalled 2 different times now. Each time it works fine, then I run the live update, reboot and it fries.

  10. #10

    Re:Suse 9.0 Fried

    yeah, my YaST never updated right either, i switched to slack and i like it much more

Similar Threads

  1. Suse 10 and mp3's
    By CP in forum Linux - General Topics
    Replies: 3
    Last Post: 10-18-2005, 11:00 PM
  2. yum and suse
    By elovkoff in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 04-27-2005, 11:35 PM
  3. SuSe 9.3
    By coltrane in forum Linux - General Topics
    Replies: 23
    Last Post: 04-27-2005, 03:25 PM
  4. Brain fried
    By phpgeek in forum General Chat
    Replies: 25
    Last Post: 01-31-2002, 04:32 AM
  5. SuSE 7.3 ..
    By x0xCRIZx0x in forum Suse
    Replies: 6
    Last Post: 12-11-2001, 10:50 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts