Results 1 to 2 of 2

Thread: Debian Problem

  1. #1

    Debian Problem

    Hey guys I think i'm stuck with gettting debian to get into a GUI it wont start the X server i'm sure I set it up right here is my xf86config

    Code:
    Section "Module"
    
    # This loads the DBE extension module.
    
        Load        "dbe"  ***# Double buffer extension
    
        SubSection  "extmod"
          Option    "omit xfree86-dga"   # don't initialise the DGA extension
        EndSubSection
    
    # This loads the Type1 and FreeType font modules
        Load        "type1"
        Load        "freetype"
    
    # This loads the GLX module
    #    Load       "glx"
    
    EndSection
    
    Section "Files"
    
        RgbPath***"/usr/X11R6/lib/X11/rgb"
    
    #    FontPath   "/usr/X11R6/lib/X11/fonts/local/"
          FontPath   "/usr/X11R6/lib/X11/fonts/misc/"
    #    FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    #    FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
          FontPath   "/usr/X11R6/lib/X11/fonts/Type1/"
    #    FontPath   "/usr/X11R6/lib/X11/fonts/Speedo/"
    #    FontPath   "/usr/X11R6/lib/X11/fonts/75dpi/"
    #    FontPath   "/usr/X11R6/lib/X11/fonts/100dpi/"
    
    # The module search path.  The default path is shown here.
    
    #    ModulePath "/usr/X11R6/lib/modules"
    
    EndSection
    
    Section "ServerFlags"
    
    #    Option "NoTrapSignals"
    
    #    Option "DontZap"
    
    #    Option "Dont Zoom"
    
    #    Option "DisableVidModeExtension"
    
    #    Option "AllowNonLocalXvidtune"
    
    #    Option "DisableModInDev"
    
    #    Option "AllowNonLocalModInDev"
    
    EndSection
    
    Section "InputDevice"
    
        Identifier***"Keyboard1"
        Driver***"Keyboard"
    #    Option     "Protocol"      "Xqueue"
        Option "AutoRepeat" "500 30"
    
    #    Option "XkbDisable"
    
        Option "XkbRules"***"xfree86"
        Option "XkbModel"***"pc101"
        Option "XkbLayout"***"us"
    
    EndSection
    
    
    Section "InputDevice"
    
    # Identifier and driver
    
        Identifier***"Mouse1"
        Driver***"mouse"
        Option "Protocol"    "PS/2"
        Option "Device"      "/dev/mouse"
    
    #    Option "Protocol"***"Xqueue"
    
    
    #    Option "BaudRate"***"9600"
    #    Option "SampleRate"***"150"
    #    Option "Emulate3Buttons"
    #    Option "Emulate3Timeout"    "50"
    
    # ChordMiddle is an option for some 3-button Logitech mice
    
    #    Option "ChordMiddle"
    
    EndSection
    
    Section "Monitor"
    
        Identifier  "My Monitor"
        HorizSync   31.5 - 57.0
    
        VertRefresh 50-70
    
    EndSection
    
    
    Section "Device"
        Identifier***"Standard VGA"
        VendorName***"Unknown"
        BoardName***"Unknown"
    
    
    
    #    Chipset***"generic"
        Driver     "vga"
    EndSection
    
    # Device configured by xf86config:
    
    Section "Device"
        Identifier  "NVIDIA GeForce"
        Driver      "nv"
        #VideoRam    1024
        # Insert Clocks lines here if appropriate
    EndSection
    
    # option.
    Section "Screen"
        Identifier  "Screen 1"
        Device      "NVIDIA GeForce"
        Monitor     "My Monitor"
        DefaultDepth 24
    
        Subsection "Display"
            Depth       8
            Modes       "640x480" "800x600" "1024x768"
            ViewPort    0 0
        EndSubsection
        Subsection "Display"
            Depth       16
            Modes       "640x480" "800x600"
            ViewPort    0 0
        EndSubsection
        Subsection "Display"
            Depth       24
            Modes       "640x480"
            ViewPort    0 0
        EndSubsection
    EndSection
    
    Section "ServerLayout"
    
    # The Identifier line must be present
        Identifier  "Simple Layout"
    
        Screen "Screen 1"
    
    
        InputDevice "Mouse1" "CorePointer"
        InputDevice "Keyboard1" "CoreKeyboard"
    
    EndSection
    EDIT: Removed most comments from the code for better readability.

  2. #2
    Moderator
    Kind Mastermind
    stryder144's Avatar
    Join Date
    Aug 2001
    Location
    Denver, CO
    Posts
    2,925

    Re:Debian Problem

    What is the error message you get? Type in startx. It will make your screen go black, then you'll see text again. Look at why it's barfing on you.

    Cheers

Similar Threads

  1. pent2 233 + 256 mb ram = problem for debian?
    By capybara in forum Linux - Hardware, Networking & Security
    Replies: 5
    Last Post: 06-03-2004, 03:58 AM
  2. Debian Mouse Problem
    By GhostDawg in forum Linux - General Topics
    Replies: 1
    Last Post: 01-31-2003, 04:31 AM
  3. Debian Idle Problem
    By GhostDawg in forum Linux - General Topics
    Replies: 4
    Last Post: 12-09-2002, 09:04 AM
  4. Sound problem with debian 3.0
    By Black666 in forum Linux - General Topics
    Replies: 1
    Last Post: 09-24-2002, 01:41 PM
  5. Debian 3.0 install problem
    By papanohair in forum Linux - General Topics
    Replies: 5
    Last Post: 09-09-2002, 01:29 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •