Hi Guys,

I just installed Slackware 9.1. Though it seems to work fine, I am getting no sound. Now, it seems Slackware moved to the Alsa sound architecture. I see modules loaded, but I get no sound, even as root. I am using KDE, and I tried playing mp3's and wav's with XMMS, and also going to the KDE ontrol center where it has the sound test button. No sound there either.

I am using a Soundblaster Live card, and it worked great yesterday with Red Hat.

This is the result of my lsmod:

Module Size Used by Tainted: P
snd-seq-oss 26112 0 (autoclean)
snd-seq-midi 3552 0 (autoclean) (unused)
snd-emu10k1-synth 3900 0 (autoclean) (unused)
snd-emux-synth 26364 0 (autoclean) [snd-emu10k1-synth]
snd-seq-midi-emul 4752 0 (autoclean) [snd-emux-synth]
snd-seq-virmidi 2952 0 (autoclean) [snd-emux-synth]
snd-seq-midi-event 3264 0 (autoclean) [snd-seq-oss snd-seq-midi snd-seq-virmidi]
snd-seq 33584 2 (autoclean) [snd-seq-oss snd-seq-midi snd-emux-synth snd-seq-midi-emul snd-seq-virmidi snd-seq-midi-event]
nvidia 1628576 11 (autoclean)
snd-pcm-oss 37252 1
snd-mixer-oss 11992 0 [snd-pcm-oss]
scanner 10488 0 (unused)
printer 7040 0 (unused)
keybdev 1952 0 (unused)
mousedev 4244 1
usbmouse 2008 0 (unused)
hid 21156 0 (unused)
usbkbd 3416 0 (unused)
input 3200 0 [keybdev mousedev usbmouse hid usbkbd]
i810_rng 2656 0 (unused)
uhci 24496 0 (unused)
usbcore 58400 1 [scanner printer usbmouse hid usbkbd uhci]
snd-emu10k1 60212 1 [snd-emu10k1-synth]
snd-pcm 55904 0 [snd-pcm-oss snd-emu10k1]
snd-timer 13252 0 [snd-seq snd-pcm]
snd-hwdep 4672 0 [snd-emu10k1]
snd-util-mem 1136 0 [snd-emux-synth snd-emu10k1]
snd-page-alloc 6004 0 [snd-emu10k1 snd-pcm]
snd-rawmidi 12512 0 [snd-seq-midi snd-seq-virmidi snd-emu10k1]
snd-seq-device 3920 0 [snd-seq-oss snd-seq-midi snd-emu10k1-synth snd-emux-synth snd-seq snd-emu10k1 snd-rawmidi]
snd-ac97-codec 37240 0 [snd-emu10k1]
snd 27460 0 [snd-seq-oss snd-seq-midi snd-emux-synth snd-seq-virmidi snd-seq-midi-event snd-seq snd-pcm-oss snd-mixer-oss snd-emu10k1 snd-pcm snd-timer snd-hwdep snd-util-mem snd-rawmidi snd-seq-device snd-ac97-codec]
soundcore 3332 10 [snd]
emu10k1-gp 1352 0 (unused)
gameport 1452 0 [emu10k1-gp]
3c59x 26832 1
pcmcia_core 40032 0
ide-scsi 9424 0
agpgart 39576 3
ntfs 51040 1 (autoclean)

This are the rights for the sound devices:

lrwxrwxrwx 1 root sound 4 Sep 28 07:12 /dev/dsp -> dsp0
crw-rw---- 1 root sound 14, 3 Aug 29 03:47 /dev/dsp0
crw-rw---- 1 root sound 14, 19 Aug 29 03:47 /dev/dsp1
crw-rw---- 1 root sound 14, 35 Aug 29 03:47 /dev/dsp2
crw-rw---- 1 root sound 14, 51 Aug 29 03:47 /dev/dsp3
lrwxrwxrwx 1 root sound 6 Sep 28 07:12 /dev/mixer -> mixer0
crw-rw---- 1 root sound 14, 0 Aug 29 03:47 /dev/mixer0
crw-rw---- 1 root sound 14, 16 Aug 29 03:47 /dev/mixer1
crw-rw---- 1 root sound 14, 32 Aug 29 03:47 /dev/mixer2
crw-rw---- 1 root sound 14, 48 Aug 29 03:47 /dev/mixer3

My regular user and my root account are both in the Sound group.

Can anyone see anything I may be missing?

I'm also getting this message on bootup:

Loading driver...
ALSA warning: No mixer settings found in /etc/asound.state.
Sound may be muted. Use 'alsamixer' to unmute your sound card,
and then 'alsactl store' to save the default ALSA mixer settings
to be loaded at boot.

But since I have never used Alsa, I'm kinda lost...


EDIT:

Allright. That was stupid of me. I just needed to follow the instructions. Is working now.