Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: No Sound in Slackware 9.1

  1. #11

    Re:No Sound in Slackware 9.1

    I don't know the difference with Slack 9.0 & 9.1 sound setup but using 9.0, and my VIA AC'97 onboard sound card, Slackware and Jamd linux were the only two distros that I've used that setup my sound without any intervention from me.

    All other distros I tried I had to manually download and install alsa drivers to get it working. And I've tried quite a few distros but not the latest RH or MDK.

    I'm not sure if Slack 9.0 come with alsa drivers or not but I was so happy that it worked out the box that I didn't look to find out! ;D

    I've finally got my 9.1 cd's and will be installing it this weekend.

  2. #12

    Re:No Sound in Slackware 9.1

    Funny, I just figured this out today.

    Since my last debian update, aumix is no longer set to unmute volume if using alsa drivers. Long story short, after noticing alsa related boot scripts installed as part of alsa packages, the program 'alsactl' is what is used to save and restore the state of the soundcard from /etc/asound.state, after of course having unmuted and adjusted the volume with some mixer program (like alsamixer).

    Should be fairly easy to add this command to any distro's bootup scripts.

  3. #13
    Associate
    Join Date
    Sep 2003
    Posts
    30

    Re:No Sound in Slackware 9.1

    Why not try linuxconf and then sndconfig, if that not work, let them do it for you?

  4. #14

    Re:No Sound in Slackware 9.1

    [quote author=Smegma link=board=1;threadid=7832;start=0#msg71716 date=1064913739]
    Why not try linuxconf and then sndconfig, if that not work, let them do it for you?
    [/quote]
    I don't think Slackware has those tools...

  5. #15
    Moderator
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Location
    Milwaukee, WI
    Posts
    5,760

    Re:No Sound in Slackware 9.1

    well, isnt linuxconf dead, and sndconfig is a redhat tool IIRC.

  6. #16

    Re:No Sound in Slackware 9.1

    If you want to change you settings, instead of editing /etc/asound.state, use alsamixer to unmute and set everything where you want it. su and run
    Code:
     # alsactl store
    this saves it to /etc/asound.state, which is used by rc.alsa

  7. #17

    Re:No Sound in Slackware 9.1

    Just a thought:

    You might add that line in your rc.6 (shut down script--I think, I'm not at a Slack box right now)

    That way it will save your mixer setting so that they stay the same after a reboot.


  8. #18

    Re:No Sound in Slackware 9.1

    I will try all that later. College and work are taking up all my time..

  9. #19
    Moderator
    Kind Mastermind
    stryder144's Avatar
    Join Date
    Aug 2001
    Location
    Denver, CO
    Posts
    2,926

    Re:No Sound in Slackware 9.1

    [quote author=trickster link=board=1;threadid=7832;start=0#msg72243 date=1065626758]
    I will try all that later. College and work are taking up all my time..
    [/quote]

    I am quite baffled, myself. When I run alsaconf, it saves my settings for me. I wonder why it doesn't do so for you. Weird.

Similar Threads

  1. Slackware 10 is out
    By in forum Linux - General Topics
    Replies: 53
    Last Post: 07-20-2004, 07:46 PM
  2. No sound Slackware 9.0 and RTCW
    By binary_boy in forum Linux - Software, Applications & Programming
    Replies: 3
    Last Post: 05-03-2003, 04:35 PM
  3. Slackware 8.1 & sound
    By KenHan in forum Linux Distros
    Replies: 3
    Last Post: 03-31-2003, 03:11 AM
  4. Slackware 8
    By in forum Linux - General Topics
    Replies: 12
    Last Post: 08-27-2002, 05:18 PM
  5. Slackware 8.1
    By jbstew32 in forum Linux - General Topics
    Replies: 13
    Last Post: 07-25-2002, 09:28 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •