Results 1 to 10 of 10

Thread: mozplugger on slack 9.1

  1. #1

    mozplugger on slack 9.1

    I just installed mozplugger 4.0 on slackware 9.1.
    make
    make install
    It shows up and works great as root but as normal user it does not even show up. I've tried to change permissions etc. no luck. maybe it is not in my path or? anyone have a clue ?
    Thanks

  2. #2

    Re:mozplugger on slack 9.1

    Hi,

    If you call it from the command line, does it work?

    Otherwise, you need to add the path to the program to /etc/profile. Open it with a text editor, and add the path to the section that has all other paths.

    After that, either log off and log on again, or do a source /etc/profile

    hth

  3. #3

    Re:mozplugger on slack 9.1

    Trickster could you please give me an example of the format that iI need to add
    Thanks

  4. #4

    Re:mozplugger on slack 9.1

    Sure.

    Use pico or your favorite text editor to open /etc/profile.

    Look for this line:

    # Set the default system $PATH:
    PATH="/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/usr/games"

    Then, add the path to the line. For example, If I had installed mozplugger to /usr/local/share, I'd do this:

    # Set the default system $PATH:
    PATH="/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin:/usr/games:/usr/local/share"

    Hope that helps.

  5. #5

    Re:mozplugger on slack 9.1

    Trickster Thanks for your help. Maybe I didn't provide enough information. I unpacked mozpluger.tar.gz in my home dir then I did
    make
    make install
    both as root
    I think thats why only root has permission / access
    it made a usr/lib/mozilla/plugins
    that is where the mozplugger.so is.
    then I copied that to
    usr/lib/mozilla-1.4/plugins
    and it works as root only
    there is also a /usr/bin/mozplugger
    maybe I should have ln -s instead of copying
    Any help ?

  6. #6

    Re:mozplugger on slack 9.1

    Try this, taken out of their README file:

    To install in your own directory: (for netscape)
    cp mozplugger.so ~/.netscape/plugins/mozplugger.so
    cp mozpluggerrc ~/.netscape/mozpluggerrc
    cp mozplugger ~/.netscape/

    You might want to replace "netscape" for "mozilla", if that is your default browser.

  7. #7

    Re:mozplugger on slack 9.1

    Thanks trickster I had tried that but no luck
    I did however start over this time ran make as user and makeinstall as root now I can see the plugin. As root all extensions work as user
    only some I`m getting closer
    Thank for your help

  8. #8

    Re:mozplugger on slack 9.1

    I just installed mozplugger, and it worked right away.

    This is what I did (everything as a regular user. You might want to remove what you did as root, to get rid of any rights issues:

    I. Download the source from here
    2. Untar it as a regular user. tar -zxvf mozplugger-1.3.2.tar.gz
    3. cd to the mozplugger-1.3.2 directory, and run make
    4. Copy mozplugger and mozpluggerrc to ~/.mozilla, and mozplugger.so to ~/.mozilla/plugins
    5. Restart the browser.

  9. #9

    Re:mozplugger on slack 9.1

    Worked just as you said
    Thanks

  10. #10

    Re:mozplugger on slack 9.1

    You're welcome.

Similar Threads

  1. Slack 10
    By vwgtiturbo in forum Linux Distros
    Replies: 7
    Last Post: 11-16-2004, 04:11 PM
  2. Slack 10 RC1
    By CP in forum Linux - General Topics
    Replies: 19
    Last Post: 06-21-2004, 07:40 PM
  3. X in Slack
    By jbstew32 in forum Linux - General Topics
    Replies: 7
    Last Post: 06-07-2002, 11:45 PM
  4. What I think about Slack....
    By paradox in forum Linux Distros
    Replies: 13
    Last Post: 02-27-2002, 03:51 AM
  5. Next Slack due when?
    By johnqpublic in forum Linux Distros
    Replies: 2
    Last Post: 10-26-2001, 11:52 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •