Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
vsftpd connection refused!!
Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: vsftpd connection refused!!

  1. #1

    vsftpd connection refused!!

    Hi gurus out there!

    Pls help me with this one...

    I installed vsftpd-1.20 from source on my RH 9.0 server with the following entries available on my vsftpd.conf:

    listen= YES
    max_client=200
    max_per_ip=2
    anonymous_enable=YES
    local_enable=YES
    anon_world_readable_only=YES
    connect_from_port_20=YES
    hide_ids=YES
    pasv_min_port=50000
    pasv_max_port=60000
    chown_uploads=YES
    chroot_username=ftp
    chroot_local_user=YES
    nopriv_user=vsftpd

    on my /etc/passwd
    vsftpd:x:21:101::/var/ftp

    my firewall provides the following entries:

    iptables -A OUTPUT -o $EXTERNAL_INTERFACE p tcp |
    -s $IPADDR --source-port $UNPRIVPORT \
    --destination-port 21 -j ACCEPT

    iptables -A INPUT -i $EXTERNAL_INTERFACE p tcp ! --syn
    --source-port 21 \
    -d $IPADDR --destination-port $UNPRIVPORTS -j ACCEPT

    iptables -A INPUT -i $EXTERNAL_INTERFACE p tcp ! --syn
    --source-port 20 \
    -d $IPADDR --destination-port $UNPRIVPORTS -j ACCEPT

    iptables -A OUTPUT -o $EXTERNAL_INTERFACE p tcp |
    -s $IPADDR --source-port $UNPRIVPORT \
    --destination-port 20 -j ACCEPT

    Also, #service xinetd status
    xinetd (pid 895) is running...

    With all these entries, everytime I invoked the command
    #ftp stationx
    I get a connection refused error.

    Running the service, resulted to [OK] however can't see the service running using nmap and netstat -tpan?

    What else should I check to fix this problem.

    Thanks.

  2. #2
    Mentor
    Join Date
    May 2001
    Location
    New Jersey
    Posts
    1,473

    Re:vsftpd connection refused!!

    I would start with the easiest thing first.

    shut down your firewall and then try to connect to the ftp server.

    That will let you know if it's a firewall problem or vsftpd's problem.

    I noticed listen=YES, you have this running in standalone? i would suggest to have it run out of xinetd

    netstat -a | grep ftp

    will show you if ftp is listening.

    give that a try and let me know what happens

  3. #3

    Re:vsftpd connection refused!!

    [quote author=boblucci link=board=4;threadid=7804;start=0#msg71318 date=1064509782]
    I would start with the easiest thing first.

    shut down your firewall and then try to connect to the ftp server.

    That will let you know if it's a firewall problem or vsftpd's problem.

    I noticed listen=YES, you have this running in standalone? i would suggest to have it run out of xinetd

    netstat -a | grep ftp

    will show you if ftp is listening.

    give that a try and let me know what happens
    [/quote]

    boblucci,

    As you suggest, I turned-off my firewall. But, nothing seems to be working. I ran vsftpd service, it says ok--however, nothing appears to be running on the background.
    I also restarted my system to be sure, and have checked xinetd to be running.

    After reboot, i started again vsftpd, it says ok. However, when I checked using #service vsftpd status--it says vsftpd stopped. Why? What can you suggest?

  4. #4

    Re:vsftpd connection refused!!

    hello,
    one thing - vsftp is not started from xinet - it is its own service. have you done the /etc/init.d/vsftpd start thingy? your config file does not look any different from mine - so i would think that is okay (mine does work).

  5. #5

    Re:vsftpd connection refused!!

    [quote author=pbharris link=board=4;threadid=7804;start=0#msg71373 date=1064543795]
    hello,
    one thing - vsftp is not started from xinet - it is its own service. have you done the /etc/init.d/vsftpd start thingy? your config file does not look any different from mine - so i would think that is okay (mine does work).
    [/quote]

    Yes, I already did this nonetheless, nothing happened. One thing bothered me, everytime I invoked service vsftpd restart it always appeared:
    Shutting down vsftpd .....[FAILED]
    Starting vsftpd.................[OK]

    #service vsftpd status
    vsftpd stopping.....

    what could be the problem. Pls let me post my config and pls comment if something went wrong:

    vsftpd.conf

    #Standalone mode instead of xinetd (daemonized)
    #listen=YES

    #Uncomment to bind to specific address
    #listen_address=192.168.0.1

    #Limits
    max_clients=200
    max_per_ip=2

    #Access Rights
    anonymous_enable=YES
    local_enable=YES

    #Uncomment next 2 lines to allow anonymous uploads
    #write_enable=YES
    #anon_upload_enable=YES
    anon_mkdir_write_enable=YES
    anon_other_write_enable=NO

    #Security
    anon_world_readable_only=YES
    connect_from_port_20=YES
    hide_ids=YES
    pasv_min_port=50000
    pasv_max_port=60000
    chown_uploads=YES
    chown_username=ftp
    chroot_local_user=YES
    nopriv_user=vsftpd

    #Features
    xferlog_enable=YES
    ls_recurse_enable=NO
    ascii_download_enable=NO
    async_abor_enable=YES
    ftpd_banner="Hack me!"
    dirmessage_enable=YES
    message_file=.message

    #Performance
    #Uncomment the next line if local_enable=YES above is commented out:
    #one_process_model=YES
    #
    idle_session_timeout=120
    data_connection_timeout=300
    accept_timeout=60
    connect_timeout=60
    anon_max_rate=50000


  6. #6

    Re:vsftpd connection refused!!

    here is my config: it is just the example provided
    Code:
    # Example config file /etc/vsftpd.conf
    #
    # The default compiled in settings are very paranoid. This sample file
    # loosens things up a bit, to make the ftp daemon more usable.
    #
    # Allow anonymous FTP?
    anonymous_enable=YES
    local_enable=YES
    write_enable=YES
    local_umask=022
    dirmessage_enable=YES
    #
    # Activate logging of uploads/downloads.
    xferlog_enable=YES
    #
    # Make sure PORT transfer connections originate from port 20 (ftp-data).
    connect_from_port_20=YES
    xferlog_std_format=YES
    pam_service_name=vsftpd
    userlist_enable=YES
    #enable for standalone mode
    listen=YES
    tcp_wrappers=YES

  7. #7

    Re:vsftpd connection refused!!

    [quote author=pbharris link=board=4;threadid=7804;start=0#msg71438 date=1064614269]
    here is my config: it is just the example provided
    Code:
    # Example config file /etc/vsftpd.conf
    #
    # The default compiled in settings are very paranoid. This sample file
    # loosens things up a bit, to make the ftp daemon more usable.
    #
    # Allow anonymous FTP?
    anonymous_enable=YES
    local_enable=YES
    write_enable=YES
    local_umask=022
    dirmessage_enable=YES
    #
    # Activate logging of uploads/downloads.
    xferlog_enable=YES
    #
    # Make sure PORT transfer connections originate from port 20 (ftp-data).
    connect_from_port_20=YES
    xferlog_std_format=YES
    pam_service_name=vsftpd
    userlist_enable=YES
    #enable for standalone mode
    listen=YES
    tcp_wrappers=YES
    [/quote]

    I also tried this one, however problem still exists. I tried to very, very careful in recompiling vsftp-1.20 but at no avail nothing works for me for the 3rd time. Hayyyy!!!! Everytime I invoke vsftpd sevice to start it says [OK] but, nothing in the background seem to be running. Restarting it produce a result :
    Stopping ........[FAILED]

    Was there any reason/or any service that may interfere with vsftpd service? Which prohibit my ftp service to run??? What I mean is just to START the service?

    I tried configuring ftp using xinetd, surprisingly, it STARTED! only, having some error 500 OOPS: missing value in config file for:.

    Pls help me....Plsssssssss.....

  8. #8

    Re:vsftpd connection refused!!

    is anytyhing attached to port 21 ? (or 20, whatever you are using) ? also les try it w/o iptables - flush the rules and see what happens

  9. #9

    Re:vsftpd connection refused!!

    [quote author=pbharris link=board=4;threadid=7804;start=0#msg71739 date=1064958037]
    is anytyhing attached to port 21 ? (or 20, whatever you are using) ? also les try it w/o iptables - flush the rules and see what happens
    [/quote]

    I'm quite sure it's not my iptables for i've tried several times flushing my firewall rules, I even stop it's service--none of it provide any changes whatsoever. The problem really is, the service never starts. Despite all configurations I made.

    Speaking of other services attached to ports 20 and 21 which ftp should be accommodating, nothing appears to running in this ports.

    Any help on the matter will be wholeheartedly appreciated.

    Thanks

  10. #10
    Mentor
    Join Date
    May 2001
    Location
    New Jersey
    Posts
    1,473

    Re:vsftpd connection refused!!

    [quote author=rhonneil link=board=4;threadid=7804;start=0#msg71369 date=1064541246]
    [quote author=boblucci link=board=4;threadid=7804;start=0#msg71318 date=1064509782]
    I would start with the easiest thing first.

    shut down your firewall and then try to connect to the ftp server.

    That will let you know if it's a firewall problem or vsftpd's problem.

    I noticed listen=YES, you have this running in standalone? i would suggest to have it run out of xinetd

    netstat -a | grep ftp

    will show you if ftp is listening.

    give that a try and let me know what happens
    [/quote]

    boblucci,

    As you suggest, I turned-off my firewall. But, nothing seems to be working. I ran vsftpd service, it says ok--however, nothing appears to be running on the background.
    I also restarted my system to be sure, and have checked xinetd to be running.

    After reboot, i started again vsftpd, it says ok. However, when I checked using #service vsftpd status--it says vsftpd stopped. Why? What can you suggest?
    [/quote]

    check to see if you have this file: /etc/xinetd.d/vsftpd
    make sure it is disable = no , if it is set to disable = yes
    vsftpd is running but it wont show up in the processes list ( ps -ax )
    mabe thats why you get the error.

    This is what i would do ( how i have it set up ) comment out the listen = yes and change the /etc/xinetd.d/vsftpd file to say disable = yes
    then killall -HUP xinetd
    then try to connect via ftp

    If you want it to start as a service, leave listen = YES in your vsftpd.conf file. You also need to put a file in the rc5.d directory( i think it is, i run my servers with no GUI so i'm used to run level 3 ) something like K57vsftpd with a symbolic link to /bin/vsftpd or where ever you have it installed.

    I hope i didnt confuse you but if you do one of those 2 things it will work.

Similar Threads

  1. Unable to configure the DNS in RHEL6-- Getting an error status - REFUSED
    By ranjithraj in forum Linux - General Topics
    Replies: 0
    Last Post: 08-28-2013, 02:11 PM
  2. Replies: 0
    Last Post: 12-06-2007, 04:52 PM
  3. The connection was refused when attempting to contact localh
    By budhead in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 01-04-2005, 08:02 PM
  4. SWAT Connection to 127.0.0.1:901 refused
    By boxers in forum Linux - Hardware, Networking & Security
    Replies: 56
    Last Post: 09-29-2002, 01:39 PM
  5. Connection refused to port 25
    By asaf in forum Linux - General Topics
    Replies: 6
    Last Post: 07-12-2002, 09:51 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •