Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Custom kernel problem
Results 1 to 3 of 3

Thread: Custom kernel problem

  1. #1

    Custom kernel problem

    Hello all:

    When I recompile the kernel(2.4.22).
    All looks fine. But when I reboot it. It said:

    I saw many articles. They said that because my SCSI controller has not been compiled in the kernel. But I do. I'm sure I do that.

    Who can help me. I have tried for 1 week.


    Thank every body

    ---------->>message <<--------------

    ramdisk: cramfs filesystem found at block 0
    ramdisk: loading 1432 blocks[1 disk] into ram disk ...done.
    Freeing initrd memory: 1432 freed
    cramfs: wrongg magic
    Kernel panic: VFS: Unable to mount root fs on 08:01

  2. #2

    Re:Custom kernel problem

    hello,
    1. welcome to linux junior.
    2. I take it the system booting off of a SCSI drive, did you include the chip type, etc into the kernel?

    can you post the config?


  3. #3

    Re:Custom kernel problem

    Hello pbharris:

    I have solved the problem already. There before I set the ext2 as a module, so I need to append the ramdisk. But now I include the ext2 into the kernel. So I don't need initrd file.

    But now, I have a big problem than that. All things looks fine After I rebuild the kernel. But when I reboot , it says the message. I done that it said, but nothing happen.

    I have no idea. Who can help me. Thanks

    -------------- ---->>message <<-------- ---------

    insmod /lib/modules/2.4.22/kernel/net/unix/unix.o: cannot create /var/log/ksymo
    ops/20030902.log Read-only file system
    Loading /etc/console/boottime.kmap.gz
    Activating swap.
    Checking root file system...
    fsck 2.27 (8-Mar-2002)
    fsck.ext2: No such file or directory while trying to open /dev/sda1
    /dev/sda1:
    The superblock could not be read or does not describe a correct ext2
    filesystem. If the device is vlaid and it really conrtains an ext2
    filesystem (and not swap or ufs or something else), then the superblock
    is corrupt, and you might try running e2fsck with an alternate superblock:
    e2fsck -b 8193 <device>


    fsck failed. Please repair manually and reboot. Please note
    that the root file system is currently mounted read-only. To
    remount it read-write:


    # mount -n -o remount,rw /

    CONTROL -D will exit from this shell and REBOOT the system.
    Give root password for maintenance
    (ortype Control-D fro normal startup):

Similar Threads

  1. Kernel 2.6.9 and problem(s) with less
    By chessforce in forum Linux - Software, Applications & Programming
    Replies: 0
    Last Post: 11-18-2004, 10:24 PM
  2. grub / kernel problem(s)
    By Pantheus in forum Linux - General Topics
    Replies: 7
    Last Post: 08-23-2004, 05:33 PM
  3. Another kernel problem
    By Gaenya in forum Linux - General Topics
    Replies: 2
    Last Post: 08-24-2002, 11:03 PM
  4. kernel config problem
    By LiNuts in forum Linux - General Topics
    Replies: 11
    Last Post: 03-11-2002, 05:56 PM
  5. Problems after building custom kernel
    By Digital_Froggy in forum Linux - General Topics
    Replies: 3
    Last Post: 12-19-2001, 12:03 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •