Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
I think I have a big problem???
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 31

Thread: I think I have a big problem???

  1. #1

    I think I have a big problem???

    Hi guys today I wanted to burn a cd so I followed the directions that k3b gave and told me to enter " append = "hdc=ide-scsi hdd=ide-scsi" ( from memory) at first I thought that was wrong because my harddrive is hdc and hdd I have no clue ??? I think my cdrom is /dev/cdroms/cdrom0. here is the last three lines of the error message

    VFS: Cannot open device "1606" or 16:06
    Please append a corrent "root=" option
    Kernel Panic:VFS: unable to mount root fs on 16:06

    TIA

  2. #2

    Re:I think I have a big problem???

    You need to run K3B with a sudo command or as 'su' or root. That might be your error. As for your cdrom, it might use the /dev/cdrom0, but the actual device should be hdx. Check your dmesg to find out exactly what the device is. As for appending them to more than one drive, you might just want to do it on the burner, unless you plan to do cd 2 cd copies with K3B.

  3. #3

    Re:I think I have a big problem???

    Hey I would love to try that suggestion but I cant. I would if I could get to the login screen. what I need to fix it lilo but when I change it I cant run /sbin/lilo from knoppix.

  4. #4

    Re:I think I have a big problem???

    To fix your LILO config file: give this a shot. Boot from a boot disk or recovery CD or other OS or something that will allow you to mount your root partition as a separate volume. Use the "mount /dev/hdcX /path/to/mountpoint" where hdcX is your root partition. Now become root user, and type "chroot /path/to/mountpoint /bin/bash". This will basically make the mountpoint your root directory. If you have an env-update script, now would be the time to run it. Otherwise, try editing your lilo.conf file and running /sbin/lilo (if you haven't updated your environment, you may have to actually type /sbin/lilo or /usr/sbin/lilo or whatever it is). Lemme know if that does it for ya.

    To find out what hdx your cd rom is on. First of all, is it an IDE cdrom? If it is, then what I have to tell you is valid. If it isn't, well I have no idea cause I've never done that before. Anyway, as any old user type "dmesg| grep hda". That will sort through all the boot messages and find any line containing "hda". Alternatively you could do "dmesg| more" to sort through all boot messages. Anyway, read the output as follows. Here's the result of dmesg| grep hda on my box.

    Code:
    [conor@localhost conor]$ dmesg| grep hda
        ide0: BM-DMA at 0xd800-0xd807, BIOS settings: hda:DMA, hdb:pio
    hda: WDC WD600BB-00CFC0, ATA DISK drive
    hda: host protected area => 1
    hda: 117231408 sectors (60022 MB) w/2048KiB Cache, CHS=7297/255/63, UDMA(33)
     hda: hda1 hda2 hda4 < hda5 hda6 hda7 >
    You can see lines that say that hda uses DMA for memory transfer, that it's a Western Digital ATA Disk drive (WDC is the name associated with it at boot), and a bunch of additional information following it like it size, cache size, and partition scheme. Look for the one that lists info on your cdrom, and that's what hdx to use instead of hdc.

    Also, make sure you have the proper drivers enabled in the kernel. I believe that scsi-emulation at least has to be enabled in the kernel, if not more. There's a good howto on setting up cd burning over at http://tldp.org.

    I'm not sure of your experience level, but if you need more info just reply to this thread and we'll see what we can't do to help out.

  5. #5

    Re:I think I have a big problem???

    Hi I was able to change lilo.conf but I still get the same error message ???

  6. #6
    Mentor Stuart's Avatar
    Join Date
    May 2002
    Location
    nb.ca
    Posts
    1,087

    Re:I think I have a big problem???

    Did you remember to run /sbin/lilo ?

  7. #7

    Re:I think I have a big problem???

    And remember to chroot before you run lilo. Otherwise I'm not sure if it'll work or not. Actually come to think of it, it might work if you can just run lilo. If you can edit lilo.conf, then you access your root filesystem and run /sbin/lilo or /usr/sbin/lilo and probably fix things.

  8. #8

    Re:I think I have a big problem???

    Hey I did remember to run /sbin/lilo but I get an error

    Fatal: open /dev/hdc: Permission denied

    and I am root I also used chroot

    If someone want to try it for themselves pm me or on msn spazattack101@hotmail.com

    this is really starting to piss me off > > >

  9. #9

    Re:I think I have a big problem???

    from the lilo prompt at boot type:

    IMAGENAME append=""

    IMAGENAME being the name of your image, hit tab to see your choices

  10. #10

    Re:I think I have a big problem???

    Hi it still doesnt work :'( could there be something else that could be the problem ???

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •