Results 1 to 8 of 8

Thread: Internet Sharing From OS X to RedHat 7.3

Hybrid View

  1. #1

    Internet Sharing From OS X to RedHat 7.3

    Ok well I just recently got a PC(two actually) and now am only using my Mac(G3 400MHz ) to share its internet connection to my other comps, since my PC's don't have modems(don't ask ... gonna get some on an order when I build a comp for a friend).

    My question is, how do I set up my Linux computer to use the connection that my Mac is sharing. I can just click on IE after a restart on XP and then I am on the net, but with linux I have seen it is different . I am using RH 7.3 and Mac OS X. Thanks for the help

  2. #2

    Re:Internet Sharing From OS X to RedHat 7.3

    What method are you using to share your internet through the mac?

    I'm assuming you might have some internet sharing software/thing running, giving out dhcp (private addresses). Did You need to configure your XP box in any way to make it see the connection?

    If not, it probably picked up an ip and gateway by dhcp. If that is the case, a simple dhcpcd eth0 should get you on your way.

  3. #3

    Re:Internet Sharing From OS X to RedHat 7.3

    Well I am just using something in the sys prefs that shares the internet. And I didn't do any setup for the windows... other then the "Network Setup" thing at which point I specfied that it connected through another computer. Don't know if that matters.

    Now my eth0 won't activate Guess I'll just fiddle around with it and try to get it workin.

    EDIT: Ok well now I looked at in says that the device isn't present. How can it have gone to being present and active yestarday to not working now? :-\

  4. #4

    Re:Internet Sharing From OS X to RedHat 7.3

    is probably not loaded. You have to make it load at bootup.

    To load the module manually, type insmod 3c2000.o. then check if eth0 is up by typing ifconfig eth0. If it is not up, then do ifconfig eth0 up. Then, do a dhcpcd eth0 (if it wasn't up already.)

    To load the module up at bootup, add the following line at the end of /etc/rc.modules or /etc/rc.local:

    /sbin/modprobe 3c2000


  5. #5

    Re:Internet Sharing From OS X to RedHat 7.3

    Ok well I had to go to /lib/modules/2.4.18-3smp/kernel/drivers/net to run insmod 3c2000.o properly. I added the line into /etc/rc.local and it loads up... or at least after startup. During startup it when it trys to make eth0 work it FAILS and then moves on, but then right in the begining, after i type in my name and pass it brings up what it normally would after I type insmod 3c2000.o.

    It works though. Now I can ping my iMac perfectly and from my imac to my PC.

    One other weird thing(besides the eth0 failing at startup and then working) is once I do startx I get a msg displaying this:
    Could not look up internet address for chrisp4(thats the comp name, or at least it was on XP). This will prevent GNOME from operating correctly. It may be possible to correct the problem by adding chrisp4 to the file /etc/hosts
    Then in the /etc/hosts file I see an ip address, localhost.localdomain , local host. All with spaces between them. If chrisp4 is the PC that RedHat is on, then what do I do for the ip address and the others. What am I supposed to add to the file?

    Thanks for the help and sorry for just the constant questions. I am trying to google almost all of it, but there are only so many sites a person can go through before they get fed up.

    EDIT: Didn't even think to try to connect to the internet... it works though I can finally see google

  6. #6

    Re:Internet Sharing From OS X to RedHat 7.3

    Asking is how we learn.

    I think the eth0 problem is that it is trying to bring up the network before the module is loaded. I took Red Hat off my box, so I will have to research this when I get home.

    On /etc/hosts, you need to set it this way:

    127.0.0.1 computername.domain computername

    where you can make up a domain anme if you don't have one.

    mine looks like this, where Orisha is my computer name, and Obatala my domain name:

    127.0.0.1 Orisha.Obatala Orisha


    Also, make sure you edit /etc/sysconfig/network, and put your hostname in the HOSTNAME= line.

  7. #7

    Re:Internet Sharing From OS X to RedHat 7.3

    You can also rename your rc.d/rc#.d/S##NICcard and rc.d/rc#.d/S##Netowrkscripts to make sure that the script that makes sure that the card is physically running starts before the script that initializes the network settings. Of course I have forgotten which scripts are which, so those are not the actual names of the scripts... maybe someone here knows what they are called.

    HTH,
    Ryan

  8. #8

    Re:Internet Sharing From OS X to RedHat 7.3

    Thanks.... now no more alerting me of the chrisp4 problems. Eveything seems to be nice now... not much of a problem, but don't worry, I'm sure I can find or make a few more for ya

Similar Threads

  1. internet connection sharing
    By smith19 in forum Ubuntu / Debian
    Replies: 1
    Last Post: 08-20-2007, 07:42 AM
  2. Internet Sharing In Fedora
    By saswata in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 05-01-2006, 11:00 AM
  3. sharing internet
    By mi in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 04-04-2005, 06:54 PM
  4. Internet Connection Sharing
    By regix in forum Windows - General Topics
    Replies: 0
    Last Post: 01-30-2005, 12:46 AM
  5. Internet sharing with Mandrake
    By CroTeam in forum Linux - Hardware, Networking & Security
    Replies: 7
    Last Post: 12-04-2002, 03:04 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •