Results 1 to 7 of 7

Thread: Wierd problems with sound

  1. #1

    Wierd problems with sound

    ???
    Ok peeps,
    MM and I spent most of this morning getting some of the more mundane Noob asskicking problems out of the way. He got my dvd player and cd burner up and running and we even got SOU installed on my linux box.
    Now, here is the problem. Everytime I log into my linux box I have to rerun sndconfig. Even though the modfile is there, I have to rerun it. Sometimes I even have to drop to runlevel 3 and run sndconfig to get it to initialize any ideas?
    Oh, and with x running in the background, I was able to push 50 fps in 800x600.


    10ded

  2. #2

    Re:Wierd problems with sound

    hello,
    are the sound modules loaded? if not you can have the loaded in /etc/rc.local.

  3. #3

    Re:Wierd problems with sound

    Im not sure but I will check.
    Update:
    Ok, no, there is nothing being loaded with rc.local.
    What do I need to do to enter the sound module startup into it? Im running RH 7.3 and the sound card is an ensoniq.

    10ded

    ps. thanks pb!!

  4. #4

    Re:Wierd problems with sound

    hi 10ded -
    this stuff should be loaded in /etc/modules.conf - my sound stuff looks like this in that file:


    Code:
    alias sound-slot-0 emu10k1
    post-install sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -L >/dev/null 2>&1 || :
    pre-remove sound-slot-0 /bin/aumix-minimal -f /etc/.aumixrc -S >/dev/null 2>&1 || :
    iir rh7.3 used the same sound setup as rh 9 (what i am posting from now) - so it should look similar - a modprobe emu10k1 in my rc.local would have it be loaded on startup - although i though modules.conf should do that to, but if not then a rc.local entry should be more convincing.

  5. #5

    Re:Wierd problems with sound

    Thanks PB.
    I modified my rc.local and added what you suggested. I then went to init 3 and back into init 5 and the sound was right there. I will continue to monitor it and will let you know something definite when I do.

    You da man,

    10ded

  6. #6

    Re:Wierd problems with sound

    Ok, PB. Sound was right there when I booted up last nite. Praise be to PB, for he is merciful and all knowing.

    10ded

  7. #7

    Re:Wierd problems with sound

    ha!! only in my own mind

    good to hear it works 10ded

Similar Threads

  1. getting online and sound problems
    By gtoman in forum Linux - General Topics
    Replies: 2
    Last Post: 06-08-2006, 10:03 PM
  2. Sound problems when rebooting.
    By chumley in forum Linux - General Topics
    Replies: 9
    Last Post: 01-27-2005, 10:33 AM
  3. wierd resolving problems
    By Rastar in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 08-22-2002, 04:50 PM
  4. Sound Problems
    By BDV in forum Linux - Hardware, Networking & Security
    Replies: 12
    Last Post: 07-19-2002, 02:09 PM
  5. sound problems
    By klrmar in forum Linux - General Topics
    Replies: 7
    Last Post: 04-14-2002, 03:32 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •