Results 1 to 5 of 5

Thread: TTY permissions problem

  1. #1

    TTY permissions problem

    Hey there folks,

    Well I finally got my other PC up and running... well kinda. I put RH9.0 on it and its ok, I need more RAM, but I tried to setup my folding to start automatically and it says that there are perm problems with the ttyXXs I first had it on tty12 and figured that maybe there was just somehting funky with putting it on such a high tty so I dropped it to tty6 same thing... Anyone have any ideas on what could be wrong? I would really like to have it pop over to a higher tty!


  2. #2
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Milwaukee, WI

    Re:TTY permissions problem

    how are you starting it exactly?

  3. #3

    Re:TTY permissions problem

    Sorry it took me so long to reply but I'm trying to start it by putting the script in /etc/init.d/ directory and then making it executable. Then I ran chkconfig -add folding and it added it to run in run levels 2,3,4 & 5. But it never seems to be running! >

    The script is as follows:
    #chkconfig: 345 99 99
    #description:  Start | Stop | Restart | (Check the) Status of the FAH Linux console client
    source /etc/rc.d/init.d/functions
    cd /home/mcdougrs/folding/ >/dev/tty6
    case "$1" in
                    echo -n "Starting Folding@Home client ... "
                    su mcdougrs -c "$FAH >/dev/tty6 &"
                    echo -n "Stopping Folding@Home's FAH3Console-Linux.exe ... "
                    killproc FAH3Console-Linux.exe
                    $0 stop
                    /usr/bin/sleep 1
                    $0 start
                    status FAH3Console-Linux.exe
                    echo "Usage: $0 {start|stop|restart|status}"
                    exit 1
    exit $RETVAL
    Thats it. All I get in the boot log is a permission denied error

  4. #4

    Re:TTY permissions problem

    i use crontab to run mine:

    [pbharris@bugs ~]crontab -l
    # DO NOT EDIT THIS FILE - edit the master and reinstall.
    # (/tmp/crontab.5016 installed on Sat Apr  5 21:30:35 2003)
    # (Cron version -- $Id: crontab.c,v 2.13 1994/01/17 03:20:37 vixie Exp $)
    0 * * * * cd /home/pbharris/seti; ./setiathome -nice 19 > /dev/null 2> /dev/null
    [pbharris@bugs ~]
    make one by doing a crontab -e and then entering soemthing like this.
    0 * * * * cd /home/ian/gah; ./gah.exe -nice 19 > /dev/null 2> /dev/null

  5. #5

    Re:TTY permissions problem

    Hey pb,

    I would but the problem would still remain that I want to have it show up on one of my TTY screens so that I can see the progress if I want to. Yours has it going to /dev/null I'm sure If I had mine doing the same it would ok.

    Thanx for the suggestion though,

Similar Threads

  1. file permissions
    By sentme_mail in forum Linux - General Topics
    Replies: 8
    Last Post: 11-20-2004, 04:39 AM
  2. Permissions
    By ASCI_Blue in forum Linux - General Topics
    Replies: 1
    Last Post: 11-09-2002, 07:36 PM
  3. cd permissions
    By deepfreeze in forum Linux - General Topics
    Replies: 6
    Last Post: 08-29-2002, 03:28 PM
  4. NFS permissions problem on Suse 7.1
    By malvina in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 04-18-2002, 08:50 AM
  5. Permissions and rights
    By chadm1967 in forum Linux - General Topics
    Replies: 4
    Last Post: 12-04-2001, 02:33 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts