We have a GUI based socketserver.sh service, This service must be run in GUI based only like in KDE, GNOME and X11 based only. I am sure about this service coudn't work on Linux Text based terminal. Only work on X-terminal windows. Because We had tried using Text-mode these service coudn't work. After that We have tried on KDE X-terminal it will work fine. (Just Double click on that .sh file it will be execute.)

We tested the Our GUI service which have try to start through Text Based Terminal (Run Level 3).
> It is throwing this exception - which means that the graphics
> environment is not available to it.

The exception -
> [ Class Name : BarChart_JPEG Method Name : creatingBufferedImageObj ]
> Log : Barcharts Server is not started through X11 enviornment. Can't
> connect to X11 window server using 'localhost:10.0' as the value of
> the DISPLAY variable.

Now we want to run these service duing linux boot process (like other linux service run in boot process eg. network, sendmail, smb, httpd etc.)

We have tried following option to run our .sh file during linux boot process.

1) In /etc/rc.d/rc.local
/root/SocketServer/./Socketserver.sh # (My .sh file path)
But it is not working.

2) In /etc/rc.d/rc3.d
ln -s /root/SocketServer/./Socketserver.sh S99socketserver
we create a symbolik link with our .sh file and run after all service running.
But it is not working.

In this case our Linux Server is in Onsite Location. We don't have GUI based access like VNC, Xserver etc. Right now we are accessing our machine Using SSH (22).

And even no human body is touch physically to enter username and password.

Additon Information :
1) We are accessing our Linux Server from our Onsite Location using SSH.
2) Currnetly My Linux server RunLevel is 5 (Default Graphcally Interface)

Required Solution :
1) Is there any way we can start our service during linux bootup process.

Hope you will get proper senario.

Thanks in Advance.

Pls. respond me as earlier as possible