Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
APT-GET PGP Error
Results 1 to 8 of 8

Thread: APT-GET PGP Error

  1. #1
    Associate
    Join Date
    Feb 2003
    Posts
    39

    APT-GET PGP Error



    Trying to run apt-get upgrade and keep getting pgp errors on the following packages:

    How do I get around this?

    Code:
     
    
    [root@phoenix conf]# apt-get upgrade
    Reading Package Lists... Done
    Building Dependency Tree... Done
    The following packages will be upgraded
      gnupg kdeaddons kdebase kdegames kdegraphics kdelibs qt synaptic tcpdump xinetd xmms
    The following packages have been kept back
      gaim id3lib kdemultimedia mplayer xchat
    11 packages upgraded, 0 newly installed, 0 removed and 5 not upgraded.
    Need to get 1973kB/57.7MB of archives.
    After unpacking 903kB of additional disk space will be used.
    Do you want to continue? [Y/n] Y
    Get:1 http://apt.freshrpms.net redhat/8.0/en/i386/updates tcpdump 14:3.6.3-17.8.0.3 [271kB]
    Get:2 http://ftp-stud.fht-esslingen.de redhat/8.0/en/i386/stable gnupg 0:1.2.2-1.fdr.1.rh80 [1558kB]
    Get:3 http://apt.freshrpms.net redhat/8.0/en/i386/updates xinetd 2:2.3.11-1.8.0 [144kB]
    Fetched 1973kB in 16s (123kB/s)
    Checking GPG signatures...
    error: qt_1%3a3.1.2-2.0.8.0_i386.rpm has invalid or unknown GPG key.
    error: kdelibs_6%3a3.1.1a-1.3.8.0_i386.rpm has invalid or unknown GPG key.
    error: kdebase_6%3a3.1.1a-1.3.8.0_i386.rpm has invalid or unknown GPG key.
    error: kdegames_6%3a3.1.1-1.2.8.0_i386.rpm has invalid or unknown GPG key.
    error: kdegraphics_7%3a3.1.1a-1.2.8.0_i386.rpm has invalid or unknown GPG key.
    error: xmms_1%3a1.2.7-21.2.8.0_i386.rpm has invalid or unknown GPG key.
    error: kdeaddons_3.1.1-1.2.8.0_i386.rpm has invalid or unknown GPG key.
    error: synaptic_0.32-1.3.8.0_i386.rpm has invalid or unknown GPG key.
    E: Sub-process /usr/bin/apt-sigchecker returned an error code (8)
    E: Failure running script /usr/bin/apt-sigchecker

  2. #2

    Re:APT-GET PGP Error

    hello,
    did you run apt-get update first?

  3. #3
    Associate
    Join Date
    Feb 2003
    Posts
    39

    Re:APT-GET PGP Error


    Yes I ran apt-get update and I have a script that does that nightly

    I ran it again, after running apt-get update and still got:

    Checking GPG signatures...
    error: qt_1%3a3.1.2-2.0.8.0_i386.rpm has invalid or unknown GPG key.
    error: kdelibs_6%3a3.1.1a-1.3.8.0_i386.rpm has invalid or unknown GPG key.
    error: kdebase_6%3a3.1.1a-1.3.8.0_i386.rpm has invalid or unknown GPG key.
    error: kdegames_6%3a3.1.1-1.2.8.0_i386.rpm has invalid or unknown GPG key.
    error: kdegraphics_7%3a3.1.1a-1.2.8.0_i386.rpm has invalid or unknown GPG key.
    error: xine-lib_1.0.0-0.beta10.0.0.8.0_i386.rpm has invalid or unknown GPG key.
    error: kdemultimedia_6%3a3.1.1-1.2.8.0_i386.rpm has invalid or unknown GPG key.
    error: xmms_1%3a1.2.7-21.2.8.0_i386.rpm has invalid or unknown GPG key.
    error: kdeaddons_3.1.1-1.2.8.0_i386.rpm has invalid or unknown GPG key.
    error: synaptic_0.32-1.3.8.0_i386.rpm has invalid or unknown GPG key.
    E: Sub-process /usr/bin/apt-sigchecker returned an error code (10)
    E: Failure running script /usr/bin/apt-sigchecker



    [quote author=pbharris link=board=1;threadid=7041;start=0#65336 date=1053202259]
    hello,
    did you run apt-get update first?
    [/quote]

  4. #4
    Moderator
    Good Guru
    Compunuts's Avatar
    Join Date
    May 2001
    Location
    California
    Posts
    3,935

    Re:APT-GET PGP Error

    Try apt-get dist-upgrade .

  5. #5
    Associate
    Join Date
    Feb 2003
    Posts
    39

    Re:APT-GET PGP Error


    I've tried that as well...same type of error

    [quote author=Compunuts link=board=1;threadid=7041;start=0#65345 date=1053218896]
    Try apt-get dist-upgrade .
    [/quote]

  6. #6
    Moderator
    Good Guru
    Compunuts's Avatar
    Join Date
    May 2001
    Location
    California
    Posts
    3,935

    Re:APT-GET PGP Error

    Which Debian are you using? I will check on my Debian testing box as well.

  7. #7
    Associate
    Join Date
    Feb 2003
    Posts
    39

    Re:APT-GET PGP Error


    My bad, this is one a RH 8.0 box.


    [quote author=Compunuts link=board=1;threadid=7041;start=0#65377 date=1053281550]
    Which Debian are you using? I will check on my Debian testing box as well.
    [/quote]

  8. #8
    Junior Member
    Join Date
    Nov 2002
    Posts
    92

    Re:APT-GET PGP Error

    Reinstall the apt rpm or use a different one. Or you could import the repository's pgp key using lynx.

Similar Threads

  1. IE Error.
    By Balaji_haridoss in forum Windows - General Topics
    Replies: 0
    Last Post: 03-12-2007, 05:29 AM
  2. Error in yum? Please help
    By jaipraveen in forum Linux - General Topics
    Replies: 2
    Last Post: 01-29-2007, 09:44 AM
  3. Internal Server Error - ASP error
    By Jason Lu in forum Windows - General Topics
    Replies: 2
    Last Post: 02-18-2005, 09:45 AM
  4. Has anyone seen this error before?
    By datamike in forum Linux - General Topics
    Replies: 13
    Last Post: 12-24-2003, 03:15 AM
  5. apt-get error
    By JockVSJock in forum Linux - General Topics
    Replies: 6
    Last Post: 05-07-2003, 07:04 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •