depmod -a took a while to complete, but reported no errors. Nevertheless, it didn't work.

I see devfs loading while booting up, and see it in the logs. What does it mean if I don't see /dev/dsp?

In terms of actually installing the module, I went ahead and retried it, and got the following:

# insmod -f au8830

Using /lib/modules/2.4.21-0.13mdk/misc/au8830.o
Warning: The module you are trying to load (/lib/modules/2.4.21-0.13mdk/misc/au8830.o) is compiled with a gcc
version 2 compiler, while the kernel you are running is compiled with
a gcc version 3 compiler. This is known to not work.
/lib/modules/2.4.21-0.13mdk/misc/au8830.o: unresolved symbol register_sound_midi_R82a43a6b
/lib/modules/2.4.21-0.13mdk/misc/au8830.o: unresolved symbol register_sound_dsp_R16aa6112
/lib/modules/2.4.21-0.13mdk/misc/au8830.o: unresolved symbol unregister_sound_mixer_R7afc9d8a
/lib/modules/2.4.21-0.13mdk/misc/au8830.o: unresolved symbol register_sound_mixer_R84905678
/lib/modules/2.4.21-0.13mdk/misc/au8830.o: unresolved symbol unregister_sound_dsp_Rcd083b10
/lib/modules/2.4.21-0.13mdk/misc/au8830.o: unresolved symbol unregister_sound_special_R99c95fa5
/lib/modules/2.4.21-0.13mdk/misc/au8830.o: unresolved symbol register_sound_special_R9a9cbba5
/lib/modules/2.4.21-0.13mdk/misc/au8830.o: unresolved symbol unregister_sound_midi_Rfdab6de3
/lib/modules/2.4.21-0.13mdk/misc/au8830.o:
Hint: You are trying to load a module without a GPL compatible license
and it has unresolved symbols. Contact the module supplier for
assistance, only they can help you.

I had read about hexediting the au8830.o file and changing the gcc2 part to gcc3 (it worked for someone).

I reran it, and *didn't* get the error about the gcc2 vs gcc3, but did get the remaining notices about unresolved symbols.

Still no /dev/dsp (there there's dvd, discs, and disc0 and disc1).