Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: CD-RW drive install

  1. #1

    CD-RW drive install

    Added a new cd-rw, followed the PET, but get this when I mount it:
    mount: /dev/cdrom is not a valid block device

    Now before this I accidently deleted the entire /dev/cdrom directory. So /dev/cdrom wasn't a block device - just a regular file. Now I tried making a new block device file (/dev/cdrom) with the mknod command. But when I link em:
    ln -s /dev/scd0 /dev/cdrom
    ln: `/dev/cdrom': File exists
    arggg this is frustrating. Ive done this before but now it's being a bitch because I deleted the original /dev/cdrom file (and I dont have a /dev/cdrom1). Need some help...

  2. #2

    Re:CD-RW drive install

    ln -fs, force symbolic link, though most of the time it is not a very good idea.

  3. #3

    Re:CD-RW drive install

    hey redhat - please post the output of
    ls -l /dev | grep cdro

    also please pot /etc/fstab entried for cdrom and the output of cdrecord -scanbus

  4. #4

    Re:CD-RW drive install

    alright after forcing the link (-f switch):

    [root@furio redhat]# ls -l /dev | grep cdro
    lrwxrwxrwx    1 root     root            9 May  6 18:59 cdrom -> /dev/scd0
    My fstab:

    /dev/cdrom /mnt/cdrom iso9660 noauto,owner,rw 0 0

    (only listed what was needed)

  5. #5

    Re:CD-RW drive install

    does cdrecord -scanbus return anything?

  6. #6

    Re:CD-RW drive install

    Oh my bad, I forgot you asked for that. Yes, scanbus does recognize the burner. I can burn CDs but not mount the cd-rw to read cd's. Did this fubar up because I deleted the original /dev/cdrom?

  7. #7

    Re:CD-RW drive install

    is this similar to what you get when you type ls -l /dev/scd0 ?
    [pbharris@bugs ~]ls -l /dev/scd0 
    brw-------    1 pbharris disk      11,   0 Jan 30 04:24 /dev/scd0
    [pbharris@bugs ~]
    one thing you may wish to ry is ejecting the CD, putting it back into the drive and then mounting it (if you haven't tried)

  8. #8

    Re:CD-RW drive install

    Yeah pbharris, that's what I get and I've tried ejecting a CD. I really think the problem is I deleted the block file /dev/cdrom, and you can't just create a new /dev/cdrom because it won't be a block file; it'll be just a regular file. You can use the mknod command but that didnt work too well; I still need to read up on that. I think what I need to do is get someone else's /dev/cdrom block file or find one that I may have in a backup. Agree with me?

  9. #9

    Re:CD-RW drive install

    pbharris, I did this:
    [root@furio root]# mknod /dev/cdrom b 10 16
    [root@furio root]# ls -l /dev/cdrom
    brw-r--r--    1 root     root      10,  16 May  6 20:42 /dev/cdrom
    [root@furio root]# ln -s /dev/scd1 /dev/cdrom
    ln: `/dev/cdrom': File exists
    Ok so umm why can't I link those two?

  10. #10

    Re:CD-RW drive install

    yes! i agree very much - in fact the one i posted up there is my block file for /dev/scd0 here is what i would do

    rm /dev/scd0
    rm /dev/cdrom
    mknod /dev/scd0 b 11 0
    ln -s /dev/scd0 /dev/cdrom

Similar Threads

  1. Install Windows XP Pro & Home on one drive
    By regix in forum Windows - General Topics
    Replies: 0
    Last Post: 12-31-2004, 11:18 PM
  2. How do i install a floppy drive??
    By in forum Linux - Hardware, Networking & Security
    Replies: 6
    Last Post: 01-23-2004, 08:19 PM
  3. Knoppix 3.1 Hard Drive install
    By creedon in forum Linux - General Topics
    Replies: 11
    Last Post: 12-15-2002, 02:43 PM
  4. Re-Install LILO after W2K Install
    By Pleiades in forum Linux - General Topics
    Replies: 12
    Last Post: 08-18-2002, 04:58 PM
  5. How install MDK 8.2 on 2nd Hard Drive?
    By papanohair in forum Linux - General Topics
    Replies: 5
    Last Post: 04-02-2002, 11:04 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts