Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
3 slackware questions
Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: 3 slackware questions

  1. #1

    3 slackware questions

    Q1: I ppl i'm wondering how I can install the nvidia drivers ??? because when I log out of X it says something about the kernel and it doesnt match??? I don't remember what it said exactly.

    Q2: How do I get k3b to notice my cd burner I told it to try /dev/cdrom but all it says is "could not find aditional device at /dev/cdrom"

    Q3: How do I update slackware???

    TIA
    a.lost.soul

  2. #2

    Re:3 slackware questions

    Q1 - 1.Download http://download.nvidia.com/XFree86/L...6-1.0-4363.run
    2.From the console, go to the directory where you downloaded the .run file, and type ./NVIDIA-Linux-x86-1.0-4363.run
    3.Follow the instructions, and when it says it can't find a precompiled kernel module, tell it to build one.
    4.Edit your XF86Config according to ftp://download.nvidia.com/XFree86/Linux-x86/1.0-4363/README.txt

    Q2 1.Try to tell it to use /dev/sr0 (You have SCSI support for IDE devices enaabled, right?) Make sure your account has rights to that device. Perhaps try it as root to see if it works?
    Q3 1.There are a few auto update tools out there, but none is official. http://freshmeat.net/search/?q=slack...ction=projects
    You can also go to the Slackware-Current folder in your favorite mirror, and grab the latest packages.

  3. #3

    Re:3 slackware questions

    Hey the nvidia driver still wont install it cant find the kernel header and k3b doesnt work as root I don't think I have SCSI support enabled how do I do that ???

    TIA
    a.lost.soul

  4. #4

    Re:3 slackware questions

    The default Slackware 9 cd doesn't have have the kernel sources, because they wouldn't fit on an iso-burnable (sic) image. Basically, you have to download and install the kernel sources. That should fix the "kernel headers" message.

    1.Download the kernel source. http://carroll.aset.psu.edu/pub/linu...0-noarch-5.tgz
    2.Change to the directory where you put the downloaded file, and do an installpkg kernel-source-2.4.20-noarch-5.tgz

    That should take care of the kernel headers. HOWEVER, if you install the Nvidia driver now, and later recompile your kernel, you will need to install the Nvidia driver again. So, you might want to leave the Nvidia thing for last.

    To check if your kernel has SCSI emulation support, do a modprobe ide-scsi and modprobe sg. If it is succesful, then you have support. If you do, then you need to load these at boot up. Add the following to /etc/lilo.conf: append="hdc=ide-scsi hdd=ide-scsi" . http://www.linuxjunior.org/cgi-bin/p...splay&id=8
    If not, you need to recompile your kernel to enable SCSI emulation and SCSI Generic support. There is a good PET here on recompiling kernel. http://www.linuxjunior.org/cgi-bin/p...splay&id=9

    Can you post the results of lsmod and the contents of your /etc/fstab ?

    Also, what error are you getting with k3b?

  5. #5

    Re:3 slackware questions

    As a side note,

    The newest nvidia drivers would not install untill I recompiled my kernel in slack9.

    Also if you want a very specific kernel compile walkthrough for slack try this one:
    http://www.linuxquestions.org/questi...threadid=49035

    Happy slacking

  6. #6

    Re:3 slackware questions

    Hey here is the result of lsmod

    Module Size Used by Not tainted
    emu10k1 61288 1
    ac97_codec 9512 0 [emu10k1]
    soundcore 3332 4 [emu10k1]
    emu10k1-gp 1352 0 (unused)
    gameport 1452 0 [emu10k1-gp]
    pcmcia_core 38112 0
    ide-scsi 8048 0
    8139too 15272 1
    mii 2240 0 [8139too]

    and the /etc/fstab

    /dev/hda5 swap swap defaults 0 0
    /dev/hda6 / reiserfs defaults 1 1
    /dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
    /dev/fd0 /mnt/floppy auto noauto,owner 0 0
    devpts /dev/pts devpts gid=5,mode=620 0 0
    proc /proc proc defaults 0 0
    /dev/hdc/mnt/cdromautoro,noauto,user,exec0 0


    and fc thanks for that link ;D

    a.lost.soul

  7. #7

    Re:3 slackware questions

    What is the current status of this? Is it still not working?

    It seems that you have ide-scsi support, but you don't have the sg (scsi generic.) Do you have the line I mentioned before, in your lilo.conf?

    On my slackware box, scsi generic is loaded at boot up by that line, and it makes my cd-rw /dev/sr0.

    If it does too for you, you may need to edit your fstab to mount /dev/sro at /mnt/cdrom.


  8. #8

    Re:3 slackware questions

    Hi it's still not working I even tried to recompile my kernel but that didn't work when I put "append="hdc=ide-scsi hdd=ide-scsi" in my /etc/lilo.conf it will no longer notice I have a cdrom ???

    a.lost.soul

  9. #9

    Re:3 slackware questions

    Why would you not have a cdrom after adding that line? I mean, did you got an error message after booting like that? Did you remembered to edit the fstab after booting with that option?

  10. #10

    Re:3 slackware questions

    ok now that I edited the /etc/fstab it noticed it as the reader again but not as the writer the error I get is "Could not find additional device at /dev/<device name>"

    a.lost.soul

Similar Threads

  1. Slackware 10 questions
    By Cody Mays in forum Linux - General Topics
    Replies: 7
    Last Post: 01-16-2005, 04:52 PM
  2. Installing Slackware 9.1 questions
    By SuperRobotic in forum Linux - General Topics
    Replies: 2
    Last Post: 03-06-2004, 02:39 PM
  3. CPU Questions
    By stryder144 in forum Linux - Hardware, Networking & Security
    Replies: 0
    Last Post: 06-27-2003, 08:31 PM
  4. 2 questions
    By linuxrookie in forum Linux - General Topics
    Replies: 7
    Last Post: 05-11-2002, 03:13 PM
  5. DNS questions
    By agar in forum Linux - Hardware, Networking & Security
    Replies: 3
    Last Post: 12-03-2001, 10:57 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •