Results 1 to 7 of 7

Thread: apt-get error

Hybrid View

  1. #1
    Associate
    Join Date
    Feb 2003
    Posts
    39

    apt-get error


    Everytime that I run apt-get upgrade, I keep getting the following error, which isn't allowing me to upgrade any packages at all:

    Code:
     
    
    Fetched 96.5MB in 1h20m57s (19.9kB/s)
    Executing RPM (-Uvh)...
    warning: /var/cache/apt/archives/rpm-python_4.1.1-1.8x.fdr.1_i386.rpm: V3 DSA signature: NOKEY, key ID 8df56d05
    Preparing...                ########################################### [100%]
            file /usr/lib/xmms/Input/libmpg123.so from install of xmms-1.2.7-21.1.8.0 conflicts with file from package xmms-mpg123-1.2.7-13
    E: Sub-process /bin/rpm returned an error code (90)

    Has anyone ran into this error before?

    thanks

  2. #2

    Re:apt-get error

    looks like you have a package conflict. you might want to remove libmpg123.so and give it another go.

  3. #3

    Re:apt-get error

    hello,
    did you run apt-get update first and are you using stable, testing or unstable?

  4. #4
    Moderator
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Location
    Milwaukee, WI
    Posts
    5,760

    Re:apt-get error

    you need to remove the dep conflict. Probably wouldnt hurt to upgrade your sources and try again first off. Then if that fails remove the dep conflict.

  5. #5
    Moderator
    Good Guru
    Compunuts's Avatar
    Join Date
    May 2001
    Location
    California
    Posts
    3,935

    Re:apt-get error

    What I also usually do is do " apt-get dist-upgrade " . Everytime you do " apt-get upgrade ", it will ONLY upgrade the packages but NOT the distro to its current updates ( which is mostly a lot in unstable and testing ).

    The conflicts and stuff usually goes away after doing dist-upgrade but YMMV.

    And also like PBHarris said, did you do " apt-get update " ?

  6. #6
    Associate
    Join Date
    Feb 2003
    Posts
    39

    Re:apt-get error



    Thanks everyone for the answers. Apt-get for RH 8.0 has been pretty good, but just this weird issue with XMMS, which I used apt-get to install.

    So I used apt-get to remove it and did apt-get distro-upgrade and all is fine know.

    thanks


  7. #7
    Moderator
    Good Guru
    Compunuts's Avatar
    Join Date
    May 2001
    Location
    California
    Posts
    3,935

    Re:apt-get error

    [quote author=JockVSJock link=board=1;threadid=6929;start=0#64671 date=1052155769]
    Apt-get for RH 8.0 has been pretty good,
    [/quote]
    OUCH !!


    ;D

Similar Threads

  1. IE Error.
    By Balaji_haridoss in forum Windows - General Topics
    Replies: 0
    Last Post: 03-12-2007, 05:29 AM
  2. Error in yum? Please help
    By jaipraveen in forum Linux - General Topics
    Replies: 2
    Last Post: 01-29-2007, 09:44 AM
  3. Internal Server Error - ASP error
    By Jason Lu in forum Windows - General Topics
    Replies: 2
    Last Post: 02-18-2005, 09:45 AM
  4. Has anyone seen this error before?
    By datamike in forum Linux - General Topics
    Replies: 13
    Last Post: 12-24-2003, 03:15 AM
  5. APT-GET PGP Error
    By JockVSJock in forum Linux - General Topics
    Replies: 7
    Last Post: 05-19-2003, 01:19 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •