Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: RTCW menus

  1. #1

    RTCW menus

    Hello, all of you seem to know what you are talking about for the most part. I need a little help with my RTCW. Everything looks fine for the most part, except the menus. They keep overlaying on top of eachother and I can't change the settings. That and the text won't show up when I go to refresh the servers. Other than that everything runs fine. I havn't been able to test it yet because of the menus but if you could all suggest a few things I would be most appreciative.

    Computer info:
    Athlon 1500+
    384mb of ram
    GeFroce 4 ti4200
    Mandrake 9.1

    If you need anymore info just let me know. Thanks, in advance for any help.

  2. #2

    Re:RTCW menus

    what resolution are you running it at?

  3. #3

    Re:RTCW menus

    1024x768 in 32bit colour. However after reinstalling I was able to play singleplayer just fine with the occasional lockup when I exit. However I have to reinitialize X to enable open GL or else it won't work. Then when I try to run wolfMP it just comes up with a black screen at 1024 and then I have to scroll to see the rest of my screen and the black part of the screen stays black and above all other windows. That and I get invalid pk3 file errors whenever I try to join a server, that is only if wolfMP comes up (which it rarely does). Any suggestions would help. If you need anymore info I am glad to send it.

  4. #4

    Re:RTCW menus

    Quote Originally Posted by Swerve
    I have to scroll to see the rest of my screen
    Sounds like a res problem....
    is the 1024x768 the rtcw res, or the desktop res or both?

  5. #5

    Re:RTCW menus

    Do you think his pk3 files could be corrupted? Maybe the wine extraction didn't work so well for him?

    Also are you using the latest Nvidia drivers? If so make sure hardware acceleration is enabled.
    AMD Athlon 2200+ 1.8Ghz
    1280MB PC-3200 CAS2.5 RAM
    ATI Radeon 9600 Pro 128MB AGP
    Western Digital WDC WD2500JB-00FUA0 250GB 7200 rpm ATA/133
    Seagate ST3200822A 200GB 7200 rpm ATA/133
    Western Digital WDC WD1200BB-00CAA1 120GB 7200 rpm ATA/133
    Western Digital WDC WD800BB-00CAA1 80GB 7200 rpm ATA/133
    Maxtor OneTouch 2HA43R32 1TB 7200 rpm USB 2.0
    D-Link DFE-530TX+ 10/100 NIC
    D-Link DWL-G520 Rev.A
    Debian 5.0r1 Lenny

  6. #6

    Re:RTCW menus

    Desktop res is set at 1280x1024 and the wolf is set at 1024x768, I am using the Linux IA32 1.0-4349 drivers. I just guessed that those were the right ones. It is possible that the pk3 files are corrupt, I extracted them from my windows xp install. However that wouldn't explain the reason that X won't initialize openGL on first boot; I have to reinitialize X after I get into KDE.

  7. #7

    Re:RTCW menus

    Check /etc/XF86config, in the modules section for:

    Load "glx"


    Load "GLcore"

    Those should both be there in order for OpenGL to be started. Hopefully that helps you out a bit.

  8. #8

    Re:RTCW menus

    I had removed the load GLcore from the XF86Config-4 file upone request of the driver readme file. Apparently it didn't need to be there. Plus when I add it back in OpenGL still won't load upon startup. The way I get it to load is by after getting into X, I run Xsession and it restarts X for me with OpenGL initialized. And if I run wolf once I can't run it again if I exit the game. Or at least not until I restart. Oh yeah, I also have X log me in automatically seeing as I am the only one that uses linux on this computer. Hmmmm this is starting to get more and more confusing. I do appreciate the help very much, the only part that sucks is that this problem is confusing the hell out of me and I really want to get back to playing wolf. :'(

  9. #9

    Re:RTCW menus

    yeah, do what the nvidia readme says... i think their drivers have their own versions.
    what does glsinfo show?
    the 4th-ish line should say Direct Rendering: [yes/no]

  10. #10

    Re:RTCW menus

    what does glsinfo show?
    He means glxinfo ;D ;D :

Similar Threads

  1. Menus closing, sound driver
    By Cubie in forum Linux Distros
    Replies: 3
    Last Post: 08-31-2003, 09:27 PM
  2. editing fluxbox menus
    By S_D_Willie in forum Linux - Software, Applications & Programming
    Replies: 8
    Last Post: 04-09-2002, 04:17 AM
  3. IceWM and changing menus
    By papanohair in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 04-02-2002, 10:56 PM
  4. Netscape 6.2 and disappearing menus
    By papanohair in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 12-08-2001, 01:12 AM
  5. kde menus
    By agar in forum Linux - Software, Applications & Programming
    Replies: 0
    Last Post: 11-28-2001, 05:22 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts