Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Quake 3 no sound with alsa
Results 1 to 7 of 7

Thread: Quake 3 no sound with alsa

  1. #1
    BizKiT
    Guest

    Quake 3 no sound with alsa

    i have a sound blaster audigy gamer, and had to use alsa to get it working, but now when i start quake 3 with alsa enabled it crashes X. When i disable alsa quake 3 works fine, i just dont have sound. Does anyone have an idea of how to have sound while playing q3 with alsa.

  2. #2

    Re:Quake 3 no sound with alsa

    Maybe you should give OSS a shot, it is commercial, maybe it will work with more stuff. BTW, is there an error it gives you when this crash happens? fyi, i used oss with HL when i played

  3. #3
    BizKiT
    Guest

    Re:Quake 3 no sound with alsa

    no errors, when i start Quake 3 it just freezes linux completly. Im not sure how to do the OSS, but if you can help i would like to try

  4. #4

    Re:Quake 3 no sound with alsa

    well are you sure that it is the sound that it is alsa that is the issue? or is it that wine is locking up? where did you check for your errors? have you checked /var/log/messages

  5. #5
    mos19k
    Guest

    Re:Quake 3 no sound with alsa

    Quote Originally Posted by BizKiT
    no errors, when i start Quake 3 it just freezes linux completly. Im not sure how to do the OSS, but if you can help i would like to try
    I'm still working on this problem as I've switched to the gentoo distro and I defaulted to alsa. On thing I recommend now. When you start quake do it from a console. You should then be able to use [CONTROL-C] to exit the game when the sound locks up.

    If that doesn't work you can try switching to one of the virtual terminals [Control-F1 through Control-F6] and logging in and using the kill command to kill the quake. Much better to kill a frozen process then to risk corrupting data.

    If I find a solution to this problem I will post it here.


  6. #6
    mos19k
    Guest

    Re:Quake 3 no sound with alsa

    Sorry if this is more information than everyone needed but I want to give a thorough explanation about how I got this fixed. ;D

    Disto: Gentoo Linux Latest RC
    Soundcard: Turtle Beach Santa Cruz (cs64xx)
    Alsa Version: 0.9.1
    Desktop: KDE 3.1.1
    ARTSD Enabled, full duplex mode

    Games: Quake3 and Return to Castle Wolfenstein (RtCW)
    ERROR: Misc mmap errors or "No Sound"

    Solution:
    Found in the artsdsp script the option to enable mmap emulation.

    To run either of these games with sound

    artsdsp -m /path/to/game

    Example:

    artsdsp -m /usr/local/games/quake3/quake3

    Alternate Solutions:
    Don't use alsa or OSS. Prior to gentoo I was running redhat 7 something and I was using the kernel based sound drivers without a problem.

    Other games Tested:
    Tribes2 (doesn't need artsdsp)

    Soon to be tested
    Neverwinter Nights

  7. #7

    Re:Quake 3 no sound with alsa

    tight, and your using Gentoo, which is no easy task.

    *babbing dumps style points on mos19k

Similar Threads

  1. Sound Driver Alsa
    By rprakash65 in forum Linux - General Topics
    Replies: 2
    Last Post: 01-01-2009, 08:14 PM
  2. Fedora 8-- Sound Driver Alsa
    By rprakash65 in forum Linux - Software, Applications & Programming
    Replies: 0
    Last Post: 12-21-2008, 04:15 PM
  3. Alsa devices
    By CP in forum Linux - Software, Applications & Programming
    Replies: 5
    Last Post: 07-13-2004, 06:53 AM
  4. alsa troubles
    By BurntAsh in forum Linux - General Topics
    Replies: 11
    Last Post: 04-20-2004, 10:24 PM
  5. ALSA
    By in forum Linux - General Topics
    Replies: 3
    Last Post: 04-20-2002, 06:23 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •