Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: Erorr Message: HDC: Lost Interrupt

  1. #11

    Re:Erorr Message: HDC: Lost Interrupt

    hello,
    the in etc is a link to the one in boot - anywho add it to both!! this should be it below:

    Code:
    default=1
    timeout=10
    splashimage=(hd0,0)/grub/splash.xpm.gz
    title Red Hat Linux (2.4.18-26.8.0)
       root (hd0,0)
       kernel /vmlinuz-2.4.18-26.8.0 ro root=LABEL=/ ide1=0x170,0x376,15
       initrd /initrd-2.4.18-26.8.0.img
    title Red Hat Linux (2.4.18-14)
       root (hd0,0)
       kernel /vmlinuz-2.4.18-14 ro root=LABEL=/ ide1=0x170,0x376,15
       initrd /initrd-2.4.18-14.img

  2. #12
    Associate
    Join Date
    Feb 2003
    Posts
    39

    Re:Erorr Message: HDC: Lost Interrupt



    PBHarris, thanks for all of your help, I am greatful.

    I added that to my grub.conf, rebooted, and played an ogg from a mounted cdrom. It worked for about 3 minutes and then locked up again.

    I guess I'll just have to move those files then to my /hda6 and play them there in order to prevent this.

    thanks


  3. #13

    Re:Erorr Message: HDC: Lost Interrupt

    hummsss....
    well lets try this - if you wanna - edit the file /etc/sysconfig/hardisks and remove the # in front of the item that says dma=1 (or something similar...) i am not at my linux puter at this instant so i am going by memory.

  4. #14
    Associate
    Join Date
    Feb 2003
    Posts
    39

    Re:Erorr Message: HDC: Lost Interrupt



    Hey!!!

    I uncommented the following from /etc/harddisk/

    Code:
    USA_DMA = 1
    So far it is working pretty well...

    thanks for the help


  5. #15

    Re:Erorr Message: HDC: Lost Interrupt

    groovy!!

  6. #16
    Associate
    Join Date
    Feb 2003
    Posts
    39

    Re:Erorr Message: HDC: Lost Interrupt



    Celebrated too early...

    I been playing oggs from a mounted cdrom, and started having the same problems again...

    Someone from my lug, http://www.olug said to do the following:

    Put these lines at the end of you /etc/rc.d/rc.local file:

    hdparm -c 1 /dev/hda
    hdparm -d 1 /dev/hda

    The first one turns on 32bit io, the second turns on dma.

    Verify with:
    hdparm /dev/hda

    Repeat for each hard drive.
    I did this and tried it but still keep getting this

    Code:
     
    
    dmesg | grep hdc: lost interrupt 
    
        ide1: BM-DMA at 0x4008-0x400f, BIOS settings: hdc:DMA, hdd:pio
    hdc: SAMSUNG CD-ROM SC-148F, ATAPI CD/DVD-ROM drive
    hdc: ATAPI 48X CD-ROM drive, 128kB Cache
    hdc: command error: status=0x59 { DriveReady SeekComplete DataRequest 
    Error }
    hdc: command error: error=0x54
    hdc: status error: status=0x59 { DriveReady SeekComplete DataRequest 
    Error }
    hdc: status error: error=0x54
    hdc: drive not ready for command
    hdc: status timeout: status=0xd1 { Busy }
    hdc: drive not ready for command
    hdc: ATAPI reset complete
    hdc: command error: status=0x59 { DriveReady SeekComplete DataRequest 
    Error }
    hdc: command error: error=0x54
    hdc: status error: status=0x59 { DriveReady SeekComplete DataRequest 
    Error }
    hdc: status error: error=0x54
    hdc: drive not ready for command
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt
    hdc: lost interrupt

    I then commented out what I put in for /etc/sysconfig/harddisk and so far it was worked ok...

  7. #17
    Moderator
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Location
    Milwaukee, WI
    Posts
    5,760

    Re:Erorr Message: HDC: Lost Interrupt

    If you are using a (I think this is the lower limit, may be 33) UDMA 66 compatible drive on a UDMA 66 or better IDE controller, you will want to use an 80 pin ide cable. I used to get that all the time on three of my systems that had similar circumstances as what I described, and all were using older 40 pin cables. After replacing them all, everything shutup.

    HTH.

Similar Threads

  1. lost interrupt during install
    By S_D_Willie in forum Linux - Hardware, Networking & Security
    Replies: 11
    Last Post: 03-27-2003, 02:38 PM
  2. Lost Interrupt
    By Ashcrow in forum Linux - Hardware, Networking & Security
    Replies: 26
    Last Post: 08-25-2002, 01:47 PM
  3. checking partitions, hdb: lost interrupt (zip100 drive)
    By HuFlungDung in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 08-04-2002, 11:59 PM
  4. Lost interrupt?
    By johnqpublic in forum Linux - General Topics
    Replies: 6
    Last Post: 11-07-2001, 02:25 AM
  5. VIA2 slot interrupt stuck
    By HKFranz in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 08-15-2001, 09:43 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •