Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Gtk-Perl problems
Results 1 to 6 of 6

Thread: Gtk-Perl problems

  1. #1
    Mentor
    Join Date
    Jul 2001
    Posts
    1,666

    Gtk-Perl problems

    I'm trying to install some new software that requires Gtk-Perl. I first tried to download it via CPAN, and I got the error that gnome-config and imlib-config can't be found. I thought this could be because I'm using Gnome-2.2 so I downloaded the source via CVS, and I still get the same error. Gnome works without a problem but I don't have the files gnome-config or imlib-config. This is running on slack 9.0. Anyone have any suggestions?
    Cheers
    CP

  2. #2

    Re:Gtk-Perl problems

    I *think* you need GConf and GConf-devel installed for gnome-config. Make sure they are installed. Also, if you still can't find them make sure they are in your path and/or try passing a configure option (like ./configure --enable-gconf=/path/to/gnome-conf)

    Check http://www.gtkperl.org/ as well.

  3. #3
    Mentor
    Join Date
    Jul 2001
    Posts
    1,666

    Re:Gtk-Perl problems

    I have gconf installed, and there is no slack package for gconf-devel. I looked at the gnome ftp site, and they only have a gconf package as well. I went into my installed packages list, which contains the file list and did a grep gnome-config ./* and the only results I get are
    /var/log/packages/libgnome-2.2.0.1-i386-1:usr/include/libgnome-2.0/libgnome/gnome-config.h
    /var/log/packages/libgnome-2.2.0.1-i386-1:usr/share/gtk-doc/html/libgnome/libgnome-gnome-config.html
    Any other ideas?

  4. #4
    Guest

    Re:Gtk-Perl problems

    gtk-perl requires gnome 1.4 packages if you only have gnome2 then you are out of luck. there exists a gtk2-perl package now but it will not work with things like dvd::rip

    fyi gtk-perl ceased development nearly two years ago so i would imagine soon anything that requires it will have to change over soon. So to encourage developers to make the change start filing bugs or making requests because it is rediculous to use an actively developed package that requires old depreciated software.

    just my 2 cents

  5. #5
    Mentor
    Join Date
    Jul 2001
    Posts
    1,666

    Re:Gtk-Perl problems

    Thanks for that. I liked the look of the app, but I guess if it require gnome 1.4 then I'm not going to use it.
    CP

  6. #6
    Guest

    Re:Gtk-Perl problems

    yeah i keep meaning to take them to task for not modernizing the dependencies of dvd::rip. I would like to try it too but i am not about to build several gnome 1.4 and about four other dependencies to get one app working --- that is just plain silly

    in all i think you would require about 15-20 gnome 1.4 and related packages just to compile gtk-perl

Similar Threads

  1. php/ perl
    By ajay197947 in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 01-22-2006, 03:26 AM
  2. Know Perl?
    By Fatal Error in forum General Chat
    Replies: 2
    Last Post: 12-06-2004, 08:02 AM
  3. PHP & Perl??
    By SwampDonkey in forum Linux - Software, Applications & Programming
    Replies: 8
    Last Post: 07-25-2004, 04:12 PM
  4. perl question from a perl newb
    By tolstoy in forum Linux - Software, Applications & Programming
    Replies: 4
    Last Post: 09-06-2002, 01:16 AM
  5. PERL Problems
    By marce_sadico in forum Redhat / Fedora
    Replies: 0
    Last Post: 08-26-2002, 05:23 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •