Results 1 to 5 of 5

Thread: KVIrc 3.0.0 beta 1 segfault

  1. #1

    KVIrc 3.0.0 beta 1 segfault

    Recompiled KVirc source from various gentoo portage trees, tried in KDE 3.0.5 and now 3.1 and I consistantly get segfaults. This is with a normal emerge.

    Code:
     
    _KDE_IceTransmkdir: Owner of /tmp/.ICE-unix should be set to root
    sh: iceauth: command not found
    ICE Connection rejected!
    
    DCOPClient::attachInternal. Attach failed Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
    ICE Connection rejected!
    
    DCOPClient::attachInternal. Attach failed Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
    DCOPServer self-test failed.
    sh: iceauth: command not found
    kdeinit: DCOPServer could not be started, aborting.
    X Error: 179 179
      Major opcode:  155
      Minor opcode:  6
      Resource id:  0x620061
    X Error: 179 179
      Major opcode:  155
      Minor opcode:  6
      Resource id:  0x620061
    X Error: 179 179
      Major opcode:  155
      Minor opcode:  6
      Resource id:  0x620061
    X Error: 179 179
      Major opcode:  155
      Minor opcode:  6
      Resource id:  0x620061
    X Error: 179 179
      Major opcode:  155
      Minor opcode:  6
      Resource id:  0x620061
    X Error: 179 179
      Major opcode:  155
      Minor opcode:  5
      Resource id:  0x620061
    WARNING: KDE detected X Error: 179 \xb3
      Major opcode:  \x9b
    As root I get the above in console, as user I use backtrace and get:

    Code:
    0x412b36e9 in wait4 () from /lib/libc.so.6
    #0  0x412b36e9 in wait4 () from /lib/libc.so.6
    #1  0x41330214 in __DTOR_END__ () from /lib/libc.so.6
    #2  0x4105faa3 in waitpid () from /lib/libpthread.so.0
    #3  0x406a189d in KCrash::defaultCrashHandler(int) ()
       from /usr/kde/3.1/lib/libkdecore.so.4
    #4  <signal handler called>
    #5  0x40fa7042 in XTextExtents16 () from /usr/X11R6/lib/libX11.so.6
    #6  0x41421934 in XftCoreGlyphExists () from /usr/X11R6/lib/libXft.so.1
    #7  0x41424766 in XftGlyphExists () from /usr/X11R6/lib/libXft.so.1
    #8  0x40b17421 in QFontPrivate::loadUnicode(QFont::Script, QChar const&) ()
       from /usr/qt/3/./lib/libqt-mt.so.3
    #9  0x40b17535 in QFontPrivate::load(QFont::Script, bool) ()
       from /usr/qt/3/./lib/libqt-mt.so.3
    #10 0x40b0f500 in QFontMetrics::QFontMetrics(QFont const&) ()
       from /usr/qt/3/./lib/libqt-mt.so.3
    #11 0x40bff59f in QLabel::sizeForWidth(int) const ()
       from /usr/qt/3/./lib/libqt-mt.so.3
    #12 0x40bffc80 in QLabel::minimumSizeHint() const ()
       from /usr/qt/3/./lib/libqt-mt.so.3
    #13 0x40bffc01 in QLabel::sizeHint() const ()
       from /usr/qt/3/./lib/libqt-mt.so.3
    #14 0x40bff119 in QLabel::setPixmap(QPixmap const&) ()
       from /usr/qt/3/./lib/libqt-mt.so.3
    #15 0x45e4953b in KviSetupPage::KviSetupPage(KviSetupWizard*) ()
       from /usr/share/kvirc/3.0.0-beta1/modules/libkvisetup.so
    #16 0x45e4aa33 in KviSetupWizard::KviSetupWizard() ()
       from /usr/share/kvirc/3.0.0-beta1/modules/libkvisetup.so
    #17 0x45e49046 in setup_wizard ()
       from /usr/share/kvirc/3.0.0-beta1/modules/libkvisetup.so
    #18 0x080b66e0 in KviApp::loadDirectories() ()
    #19 0x080ad0fa in KviApp::setup() ()
    #20 0x080bf122 in main ()
    #21 0x4121ae54 in __libc_start_main () from /lib/libc.so.6
    How can ASCI makee all better? ??? ???

  2. #2
    Guest

    Re:KVIrc 3.0.0 beta 1 segfault

    well looks like it is not playing well with xft1 libraries. could it be that youy have the new x installed and it does not jibe well with it?

    i would look further into the ebuilds and see what can be done there to make is swim with the rest of the school. sorry i can't help more but just so hate kde so i never run it.

  3. #3

    Re:KVIrc 3.0.0 beta 1 segfault

    I'm using Xfree86 4.2.1, and until I unmerged it kvirc worked fine. I wonder if some other files might have gotten corrupted since after reinstalling KDE everything worked fine again.

  4. #4
    Guest

    Re:KVIrc 3.0.0 beta 1 segfault

    its possible have you consulted with the gentoo people at all?

    is possible that somehow it depends on kvirc or some of it's depends?

    actually looking again there are glibc errors too i wonder if glibic might not have some problems of some sort

  5. #5

    Re:KVIrc 3.0.0 beta 1 segfault

    I did try the Gentoo boards, left my post up for a week which got a lot of views but no replies. Everything that KVirc depends on is installed, so it leads back to file corruption somewhere.

Similar Threads

  1. Segfault on all system commands (rpm, ps, top)
    By Schotty in forum Linux - General Topics
    Replies: 6
    Last Post: 04-15-2004, 05:46 PM
  2. Anyone tried KVIrc?
    By Black666 in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 05-28-2002, 04:05 PM
  3. segfault/airhead
    By stryder144 in forum General Chat
    Replies: 5
    Last Post: 05-24-2002, 09:34 PM
  4. Slack 8.1 beta 2
    By ph34r in forum Linux - General Topics
    Replies: 19
    Last Post: 05-19-2002, 03:49 PM
  5. New Red Hat beta?
    By JimH in forum Redhat / Fedora
    Replies: 17
    Last Post: 04-12-2002, 05:37 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •