Results 1 to 6 of 6

Thread: Packages in RH8

  1. #1

    Packages in RH8

    Hi, i'm back again!

    I used the package updater in RH8 for the first time today when i discovered that loads of programming stuff (like gcc!) hadn't been installed at setup. It all went fine and installed stuff off the CDs but now it won't run again!

    whenever i click on in it starts up, displays the progress bar telling me it's searching for packages and checking system status, and when the bar has completed the whole application just closes!

    Anyone have any ideas on this one?

  2. #2

    Re:Packages in RH8

    perhaps RPM is borked. what happen when you try to install an rpm from the command line?

  3. #3
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Milwaukee, WI

    Re:Packages in RH8

    Hmm this is just a longshot, but perhaps (like mine has done a dozen times on me) your rpm db has gone south. Its easy to fix, and even if it isnt the case its REALLY easy.

    As root do the following commands

    cd /var/lib/rpm
    rm __db.*
    rpm --rebuilddb

    See if that helps by following it up with a :

    rpm -qa | grep mozilla

    That should display any packages with the name mozilla in it. Change it to something else if you never installed mozilla. Again, do that command as root. I have setup sudo already and prefer that.

    info sudo

    Thosecommands will show you what is needed. Basically sudo <command> will grant you adminstrator priveledges if you ahve sudo access setup for your user. Handy, and saves your ass from staying logged in as root, or via su.

  4. #4

    Re:Packages in RH8

    I can still use RPM from the command line - i was wondering if there might be an RPM for the package updater program lurking on one of the RH8 cds so that i could reinstall the program - or is it not as simple as that??

    will go and try that list of instructions - thanks very much!

  5. #5

    Re:Packages in RH8

    you want to update the program up2date with the one on the disk? sure - it is on disk one - i would remove the one thats on there first. i.e. rpm -e up2date then do a rpm -ivh up2date-3.0.7-1.i386.rpm , if you have the front end you will need to do the same thing with up2date-gnome

  6. #6

    Re:Packages in RH8

    I've tried the list of things that schotty suggested, and although the rpm query worked ok, the packages program still won't run.

    will go and try to update up2date....

Similar Threads

  1. packages instalation
    By aman_andromeda in forum Linux - General Topics
    Replies: 1
    Last Post: 12-26-2006, 07:28 AM
  2. packages instalation
    By aman_andromeda in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 12-21-2006, 05:39 AM
  3. Installing rpm and tgz packages
    By coladrikkeren in forum Linux - General Topics
    Replies: 2
    Last Post: 07-31-2004, 02:45 PM
  4. Installing Packages (RPM's etc)
    By aviceda in forum Windows - General Topics
    Replies: 6
    Last Post: 12-07-2003, 09:54 AM
  5. New Packages
    By stodgel in forum Mandriva
    Replies: 1
    Last Post: 04-19-2003, 04:56 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts