Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
Superblock error, lilo prob, all hell
Results 1 to 9 of 9

Thread: Superblock error, lilo prob, all hell

  1. #1

    Superblock error, lilo prob, all hell

    Yea thats right, all hell has broken loose on my box. I ran mandrake update and for some stupid reason decided what the hell and installed the kernel update (2.4.19-24). I rebooted, selected my old kernel, 2.4.19-19 and it booted fine. But X wouldnt start, error about NVdriver.

    Im thinkin no big deal, just recompile the nvidia drivers, but no luck there. It gives me an error trying to modprobe the NVdriver saying it has unresolved symbols and wont install. So I decide a reboot needed into this new mandrake kernel, 2.4.19-24. Same error with NVdriver. Now after this next reboot, HELL breaks lose.............


    Now for one, when I installed this new mandrake kernel, it obviously changed my lilo.conf. It also made it a graphical boot instead of text I had before. Im thinking no big deal, but now Im seeing error about mounting my raid partition (/dev/md1) saying it has bad superblock. From there it drops me to a terminal type thing (graphical terminal) and only my / (/dev/hda5) is mounted. I was able to mount my /usr (/dev/hdc5) but not my swap or my xp partiton(/mnt/windows) or my raid (/dev/md1).

    Ok so I try editing lilo.conf to take out the new kernel entry and the graphical boot as well. But to my surprise I cant run lilo afterwards. I get an error sayign cant write to logical boot partition??? I tried removing all this new kernel stuff, the kernel rpm and the source rpm, but the kernel its tryign to boot is still the kernel that is no longer even existant on my box. Runnign a cat /proc/version display 2.4.19-24 which isnt even on my box......

    Please tell me my box isnt ruined, I have aroudn 60 gigs of crap on here i need badly and cant lose. Any help would be excellent.........

  2. #2

    Re:Superblock error, lilo prob, all hell

    hi rick,
    i am sure you ahve tried a rescue disk and edited the boot label. have you run a fsck.ext3, or what ever file system you use?


  3. #3

    Re:Superblock error, lilo prob, all hell

    I have no boot disk I tried running the e2fsck -b 8193 /dev/md1 but i get same bad superblock number error. But why would not being able to mount a raid drive that is only storage stop the box from booting anyways? The answer is because of this mandrake kernel i installed/uninstalled....Its still looking for 2.4.19-24 shit that isnt there. I think if i could just get lilo edited and taken effect, it would boot my regular kernel and all would be good (hopefully) ........Any idea how i can make my lilo take effect and boot the proper kernel????

  4. #4

    Re:Superblock error, lilo prob, all hell

    i think lilo -R is a option to boot a one time config... please don't quote me on that

  5. #5

    Re:Superblock error, lilo prob, all hell

    been reading and readin, people seem to suggest Knoppix? My question is how would this help me change my lilo, i really think this is my biggest problem...

  6. #6

    Re:Superblock error, lilo prob, all hell

    **UPDATE** Its fixed! All I needed was to simply insert Mandrake CD1, select Expert Upgrade, choose no new packages, and let it rewrite the lilo for me =)

  7. #7
    Moderator
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Location
    Milwaukee, WI
    Posts
    5,760

    Re:Superblock error, lilo prob, all hell

    [me=Schotty]takes note[/me]

    thanks rick!

    and glad to see ya fixed it

  8. #8

    Re:Superblock error, lilo prob, all hell

    Hey schotty! Come stop by the channel sometime man, people been coming in alot more lately =)

  9. #9
    Moderator
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Location
    Milwaukee, WI
    Posts
    5,760

    Re:Superblock error, lilo prob, all hell

    Hehe, I have noticed. My buddy smu is in there now and then and he keeps asking about these dudes I never talked to.

Similar Threads

  1. MBR or Superblock of Root Partition??
    By vwgtiturbo in forum Linux - Hardware, Networking & Security
    Replies: 4
    Last Post: 12-11-2004, 11:40 PM
  2. Are You Going To Hell?
    By cloverm in forum General Chat
    Replies: 11
    Last Post: 05-18-2003, 03:56 PM
  3. Error installing LILO color patch
    By Stuart in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 11-04-2002, 05:23 AM
  4. Tid-Bits #5- LILO error code
    By babbing in forum Linux - General Topics
    Replies: 0
    Last Post: 09-09-2002, 04:24 AM
  5. Is my superblock corrupt?
    By anacron in forum Linux - General Topics
    Replies: 6
    Last Post: 06-07-2002, 04:00 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •