Results 1 to 8 of 8

Thread: Redhat DSL

  1. #1

    Redhat DSL

    I can't get Redhat to recognizemy nic card It's ethernet card for dsl, what is the problem, I have xp on a partition on my harddrive and thats how I access the net for now, please help

  2. #2

    Re:Redhat DSL

    open a terminal and type /sbin/ifconfig - does it show anything besides the entry? also - what kind of NIC is this?

  3. #3

    Re:Redhat DSL

    I had this problem back a few month with SuSE 7.3 you will need to find out what sort ethernet card you have than load the appropriate module likes so:

    insmod yourcard
    after that you can simply bring up the ethernet card by doing something like so:

    ifconfig eth0 up
    Where eth0 is the device name for your card usually 0 but if you have more than one substitue the zero with which ever one you want to use.

  4. #4

    Re:Redhat DSL

    It's a kingston card, I am very new to linux, but the box says kingston on the card, and the floppy disk that I have is kingston

  5. #5

    Re:Redhat DSL

    From what I've read the Kingston EtherRX seems to be ne2000 compatible try that out I believe it is called ne2kpci:

    insmod ne2kpci
    If that does not work check what kind of chipset kingston uses then view through /lib/modules/( your kernel )/kernel/drivers/net/ to find the appropriate driver for your ethernet cards chipset.

  6. #6

    Re:Redhat DSL

    Where do I put the ismod commands in, you gotta help me I am very new to linux

  7. #7

    Re:Redhat DSL

    i would do a modprobe ne2k-pci as user root, to do this open a terminal window and type su -. There are GUI tools that work pretty well, have you tried going to the menu and -> system settings -> network and tried setting it up there? the command is indespensible but i ahve found redhat's GUI tools work pretty good.

    to open a terminal right clcik on the desktop and selct new terminal or run command and type xterm

  8. #8
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Milwaukee, WI

    Re:Redhat DSL

    RedHat eh? What version?

    If it is more recent (like 7.3 or 8.0 or 8.0.93) it should be as simple as opening up a terminal and typing :

    su -

    Please note the minus, it is important. That gets you to a root login, and reads all of the root's login configuration files. Without the minus some small grief will popup later on.

    Now first type :


    That will run the harware detection tool. If that doesnt have a screen popup that asks to configure the NIC, then we have a bit of work. Before going the "hard" route (hacking a few files and rerunning kudzu) lets try this.

    Apparently kudzu isnt seeing any new or unconfigured hardware. So what we need to do is this : If you are using RedHat 8 or later, there is a really handy graphical log viewer. Found in Gnome2 at Applications -> System Tools -> System Logs.

    Run that, pick "System Log" from the list, and scroll allllll the way down. If you are like me, and rarely boot, it shouldnt be that long, else -- LONG ;D Anyway, what I need is for you to scroll from the bottom towards the top scanning for the network card to be seen.

    Here is a copy of my last syslog session which references my NIC (the full message is wayy to big for in here (this info can also can be found in the file /var/log/messages) :

    Jan 31 15:09:26 leinenkugel kernel: tulip0:  MII transceiver #1 config 3100 status 7829 advertising 01e1.
    Jan 31 15:09:26 leinenkugel kernel: eth0: Lite-On 82c168 PNIC rev 32 at 0xe08bd000, 00:A0:CC:28:A0:F9, IRQ 11.
    Jan 31 15:09:26 leinenkugel kernel: eth0: Setting full-duplex based on MII#1 link partner capability of 41e1.
    Note the IRQ 11 shit. That can be a clue as to what driver your system is trying to use, just from looking at that system log file. Now if you see nothing, I want you to take a look at the output of the following command from the terminal that you (hopfully) kept open from the "su -" command. Type:


    And list what you see there. That is all of your modules (or drivers) that are loaded.

    Please post that info. Chances are that you have an odd NIC, that the modules are not getting loaded for it. If you have an exact part number (like a kingston 2122) I can find out what module to use reallly quickly for ya.

Similar Threads

  1. redhat 9
    By pinehead in forum Linux - General Topics
    Replies: 7
    Last Post: 06-12-2003, 11:23 AM
  2. Redhat 9.0 is out
    By babbing in forum Redhat / Fedora
    Replies: 9
    Last Post: 04-03-2003, 03:02 PM
  3. new guy needs help with Redhat 8.0
    By bdmst16 in forum Linux - General Topics
    Replies: 15
    Last Post: 11-08-2002, 12:01 AM
  4. ip in redhat
    By pinehead in forum Linux - General Topics
    Replies: 2
    Last Post: 12-16-2001, 02:35 PM
  5. redhat and a 133
    By agar in forum Linux - General Topics
    Replies: 7
    Last Post: 12-08-2001, 02:49 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts