Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Redhat problems

  1. #1

    Redhat problems

    I've decided to give Linux another try after a few months by installing RedHat 8.0, but ran into some problems right away. First off, if I change my resolution to anything above 800x600 (or color depth higher than 16 bit, not too sure) I can't log on to the desktop anymore. I have a chaintech gf4200 and it's being recognized as a generic geforce4. (I'm assuming once I get online I can download drivers from nvidia to fix this)

    Secondly, my internet doesn't work at all. I have a cable modem, and when I use the Internet Configuration Wizard (after selecting my ethernet card and selecting to automatically obtain IP addresses) I am unable to activate the card.
    I also don't have any sound, last time this happened all I had to do was to add myself to a group in User Manager, because when I logged on as Root I did have sound. This time around however theres nothing. I have a Turtle Beach Santa Cruz.

    I am also wondering what groups I should add myself to in the user manager when I'm logged on as Root.

    Thank you!
    Dswissmiss

  2. #2

    Re:Redhat problems

    By "can't log on to the desktop", what exactly happens? Does your X11 (graphical display) just die upon entrance, or does it give you a message? If so, what's the message? It might also help if you post the "Screens" section of your /etc/X11/XF86Config file. Looks something like this;
    Section "Screen"
    Identifier "Screen0"
    Device "NVIDIA GeForce 2 MX (generic)"
    Monitor "Monitor0"
    DefaultDepth 16

    Subsection "Display"
    Depth 16
    Modes "1024x768" "800x600" "640x480"
    EndSubsection

    EndSection

    That's mine and it works quite well for me. As for the nvidia drivers, yes you are correct. You can get them from nvidia.com as well as installation instructions (there's a section in the huge README about installation instructions for the impatient. Follow those, edit your XF86Config file accordingly (we'll help if you need it), and you'll be styling). A word of advice though...don't get the latest drivers. I've tried them, and so have a LOT of other people. Apparently they give you incredible performance, but they're buggy as hell. I swear to God they basically said "Welp...it compiles. Ship it!" Get the second-latest drivers, which have been nothing but good to me on my RH8 system.

    RE: Your internet. You have a cable modem you say? You wouldn't happen to know whether it's pppoe or not, would you (ie. do you have to connect to the internet or are you always connected)? One easy way to find out. Open up a term, become root user (command "su&quot, and type "dhcpcd." If it waits a second or two and then dumps you back to the command prompt, try opening up a browser. Might work. If you do use pppoe, try Roaring Penguin (http://www.roaringpenguin.com/). If dhcpcd isn't present on your system (it's not on mine), I belive it's downloadable. You clearly have internet access as you've posted to a msg board, so do a google on dhcpcd. Copy the util to a floppy or cd, and grab it from linux. If you copy it to a floppy, you can access the floppy by typing "mount /mnt/floppy" in linux and treating the /mnt/floppy directory just like another part of your file system. Hope this works for you, as internet really is key to learning linux.
    As for your sound, well I really suck big floppy donkey dick at troubleshooting sound so I'll leave that up to someone else. A few questions to get them started. If you put a cd in the drive, your desktop cd player probably pops up. Any sound? Is there any mention of anything to do with your soundcard when you become root user and type "/sbin/lsmod"? In fact, try typing "/sbin/modprobe/snd-cs46xx" as root. See if that doesn't help a bit.

    Anyway, good luck getting these things solved. Hope this helped a bit.

  3. #3

    Re:Redhat problems

    took a snapshot of my desktop...how do i post it in this forum?

  4. #4

    Re:Redhat problems

    hello, use tags
    [xxx]URL [/xxx]

    replace the xxx with img

  5. #5

    Re:Redhat problems

    excuse my ignorance but does the screenshot have to be on a website, or can i attach it from my hard drive?

  6. #6

    Re:Redhat problems

    I believe it has to be on the 'net...otherwise we'd have people storing huge images on LJO, and unfortunately we just don't have the resources to host that kind of material. What's in the screenshot, might I ask?

  7. #7

    Re:Redhat problems

    Makes sense forget it then...

    anyways, I ran the XF86config thing:

    Section "Device"
    # no known options
    #Bus ID
    Identifier "NVIDIA GeForce4 (generic)"
    DRIVER "vesa"
    Vendor Name "NVIDIA GeForce4 (generic)"
    BoardName "NVIDIA GeForce4 (generic)"
    End Section




    Section "Screen"
    Identifier "Screen 0"
    Device "NVIDIA GeForce4 (generic)"
    Monitor "Monitor0"
    DefaultDepth 16
    SubSection "Display"
    Depth 8
    Modes "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "800x600" "640x480"
    EndSubSection
    EndSection


    I then checked for my internet connection by opening a term, but it told me that dhcpcd: command not found (i beleive that i'm always online though, at least in XP i am)

    as for the soundcard, i get this message everytime i log on:

    Sound server informational message:
    Error while initializing the sound driver:
    device /dev/dsp can't be opened (No such device)
    The sound server will continue, using the null output device.

    thanx again

  8. #8

    Re:Redhat problems

    I've checked redhat and mandrake sites for hardware compatibility (mostly mandrake) and found out that almost no hardware I have is even compatible with these distros.
    I have a Asus P4S533 mobo
    Turtle Beach Santa Cruz sound card
    and a Chaintech GeForce4200 video card

    Is it even possible or worth it to go ahead with all of this? I also have a 4 speaker setup and I know that my sound card doesn't support this setup in any linux distro.

    Just a bit frustrated I guess...

  9. #9

    Re:Redhat problems

    hello,
    I second Tyr_7BE's opion on the dirvers, get the second latest!!

    as for the NIC, if it is set up by DHCP bu your modem just set it up in redhat-config-network and selct eth0.

    for the sound card try modprobe msnd_pinnacle to amke it work..


  10. #10

    Re:Redhat problems

    I am unable to activate eth0 in the redhad config network, and not quite sure what you meant by trying modprobe msnd_pinnacle to amke for my sound card (newbie)

    I'm thinking of installing mandrake tomorrow if nothing works, I had a better experience with it last time around.

Similar Threads

  1. Problems Setting up RedHat 9 Box as Router
    By midraga in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 04-04-2005, 06:42 PM
  2. RedHat 8.0 kernel 2.4.19 problems
    By Tuzinor in forum Redhat / Fedora
    Replies: 3
    Last Post: 11-25-2002, 01:20 AM
  3. Qmail problems (redhat 8)
    By ladams in forum Redhat / Fedora
    Replies: 1
    Last Post: 11-20-2002, 02:36 AM
  4. Redhat Update Agent problems
    By Rastar in forum Linux - General Topics
    Replies: 8
    Last Post: 09-11-2002, 02:19 PM
  5. Problems with Graphics Card on RedHat 7.3
    By shaun680 in forum Linux - Hardware, Networking & Security
    Replies: 17
    Last Post: 09-07-2002, 12:44 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •