Results 1 to 10 of 10

Thread: I think I killed root

  1. #1

    I think I killed root

    :-[ ahem

    I had a bit of an accident whilst trying to set up the sb live platinum remote control for my gentoo box

    I was just about there (button pushes were sending events to /dev/midi) but the rcenter binary in /usr/local still only had root permissions so I typed chown -R jester.wheel /usr/local/ * thinking as a user I would want to use everything in there anyway so might as well do it now...

    ...and I think that reset permissions right the way through the system

    now when I try to boot

    1. /proc throws up an 'oops' when the system tries to mount it (it does get mounted, except I think it's the user -jester- who mounts

    2. my usb printer spits out errors saying it doesn't want the number it's been allocated (probably by me, not root)

    3. then I am asked to ctrl+d or enter root password to fix things - I enter root password and that's ok - I get a bash prompt and I can login in as user, but I can't su, can't startx, and can't login in as root (password incorrect) - as user I can connect to the net with wget, but that's it as I don't have X up

    I've googled around but I'm not having any luck

    any suggestions?

    (hey pbharris - I finally posted over here - too bad it's with an ailing penguin)

  2. #2

    Re:I think I killed root

    Sounds like root's name got changed. What distro are you using? You can probably recover root without having to mess up your config.

    Just to see, try using Kuser if you have it, and since the system took your root password, it will also so you will be able to get into user config. See if root is infact still called "root". If you can get into Kuser that way, you should be able to get into a "Super User Console" to try to fix what you broke.

  3. #3
    Guest

    Re:I think I killed root

    he's using Gentoo (read first sentence again KK)

  4. #4

    Re:I think I killed root

    doh!

    Ok. It's on to you LC. :P

  5. #5
    Moderator
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Location
    Milwaukee, WI
    Posts
    5,760

    Re:I think I killed root

    chown -R wheel.jester /usr/local/ *

    shouldnt that do it?

  6. #6

    Re:I think I killed root

    I think I see - you are saying you left an accidental space before "*". ie you changed ownership of /usr/local and everything below your current directory at the time.
    I am guessing you did this from "/". In which case it might be easier to issue the command (from "/&quot
    Code:
    chown -R root *
    ... then deal with the exceptions (eg stuff under /home).

  7. #7

    Re:I think I killed root

    hi all - thanks for your replies - I finally got round to following pbharris' advice (posted over at http://www.techimo.com/forum/showthr...746#post531746

    the box is alive - guess now I'll have to go through and clean up my mess :

    many thanks again pb

  8. #8

    Re:I think I killed root

    np jester - glad it worked - thanks for letting us know

  9. #9

    Re:I think I killed root

    ???spoke too soon

    I was in as root with kde up and running for for most of saturday and today - even tried the loki demo thing (still works BTW) while I emerged kde 3.1

    one of the loki demos reset my X resolution to something like 3x3 so I rebooted the box and then...

    root's password incorrect
    user logs in ok but su gives set gid errors

    tried doing what I did earlier but no dice - now using the mandrake 9.0 cd with rescue throws up "can't find root device " when mounting partitions under /mnt

    I'm just wiping a cdrw to start a reinstall - as it's a 4xspeed I still have time for heroic suggestions ;

  10. #10

    Re:I think I killed root

    root's password is lost?

    try this answer guy

Similar Threads

  1. wine locks up can't be killed in Mandrake 10
    By OilyFish in forum Linux - General Topics
    Replies: 9
    Last Post: 05-04-2004, 08:50 PM
  2. Saddams Sons Killed
    By BJ250 in forum General Chat
    Replies: 58
    Last Post: 07-26-2003, 03:51 PM
  3. HELP! I may have killed my system
    By gbarrier in forum Linux - General Topics
    Replies: 5
    Last Post: 02-01-2003, 02:20 PM
  4. X is automatically killed for user or root login
    By Sathya in forum Redhat / Fedora
    Replies: 2
    Last Post: 01-10-2003, 02:19 AM
  5. Gates will be killed
    By airhead in forum General Chat
    Replies: 4
    Last Post: 01-06-2002, 12:50 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •