Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: DHCP

  1. #1


    Im back at my univ from christmas break and i have my system on dual boot between win2k and slackware 8.1, and when im in windows it connects to the network fine with dhcp.
    but when im in linux i get this error on bootup and it doesnt connect.

    dhcpcd[60] broadcasting dhcp_discover

    eth0 Media link on 100mbps full_duplex
    dhcpcd[60]: timed out waitinf for a valid DHCP response
    what could be the problem?

    my nic is onboard and using the sis900.o module btw

  2. #2
    Senior Member
    Join Date
    Sep 2002


    I take it you copied and pasted these lines from dmesg or something. As they appear in that order I'd think that the dhcp broadcast is sent before the ethernet interface is brought up.

    To see if that really is the problem you could try to login and restart the dhcp client (/etc/init.d/dhcp restart on my system but I seem to recall that slackware keeps the init scripts somewhere else). Then a new broadcast should be sent out but this time the ethernet interface is actually up. If this works you should move the starting of the dhcp client to the end of the init procedure after eth0 is up and running.

    Hope thie helps.

  3. #3


    i typed 'dhcpcd' to start it while logged in as root and it ran and returned to the prompt and i typed ping just to see if id get a response and i didnt get anything, couldnt search sites either.

  4. #4
    Good Guru
    Compunuts's Avatar
    Join Date
    May 2001


    You should first killed dhcpcd and then start it if you are just starting it instead of restarting it. You can use "ps aux" to see which PID it uses.

    To see if you actually get IP addy, "ping" is not a really tool to use. You can use "ifconfig" to see if your NIC actually get IP addy or not. Between getting an IP and reaching a server box that you pinged, a lot of things needs to happen.

  5. #5


    i did ps aux and tried finding the dhcp service and it wasnt even listed as running, so i ran it, and i still didnt grab an ip so i looked again and it still wasnt listed as a process under ps aux ???

  6. #6
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Milwaukee, WI


    Now, I have no idea what distro you are using, but look at whatever configuration file there is and see what parameters are getting passed to ifconfig. ifconfig can also be (as root) run to configure a downed interface. I did that alot when setting up my OpenBSD gateway.

    Try this command out for size, and see if you get an IP address:

    dhcpcd eth0
    /sbin/dhclient eth0
    for redhat, or
    locate the pump command. It is similar to dhcpcd.


  7. #7


    im using slackware 8.1, i tried dhcpcd eth0, and still didnt grab an ip, is there a config file where i enter in the dhcp server, or some kind of a config file at all to edit?

  8. #8
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Milwaukee, WI


    Hmm, its been a while since I have used Slackware..... I would presume taking a look in your /etc folder would be a goode start. In RedHat there is a sysconfig subdirectory that holds ALOT of system hardware configurations.

    I am sure that someone else here is absolute in where to EXACTLY look.

    Now I feel bad I forgot. And I GREW up on Slackware ...

  9. #9


    It's been a while since I've used Slack myself, and I never messed around with dhcp there since I never had a problem with it, but I ran into a problem similar to one you are describing when running Arch Linux (which I'm running right now). dhcpcd would fail to get an IP during bootup, and when I tried to run it after bootup, I would get this message.

    [root@protium deepfreeze]# dhcpcd
    **** dhcpcd: already running
    **** dhcpcd: if not then delete /etc/dhcpc/ file
    I don't know if Slack has this same setup, or if so, that the file would be located in the same spot, but all I needed to do was remove that file, run dhcpcd again and I would be up and running.

    hope that helps...

  10. #10


    thanks guys, i did look in /etc/ and found the dhcpd.conf and did a manpage on it to see what needed to be added and i added it. i still timeout on bootup but then all i gotta do is login and type dhcpcd and it connects now if i could just get my ntfs partition to mount correctly. its acting like a little biatch :P

Similar Threads

  1. Dhcp help
    By soccer05 in forum Linux - Software, Applications & Programming
    Replies: 6
    Last Post: 12-26-2012, 02:42 PM
  2. Dhcp Dns
    By natishkc in forum Redhat / Fedora
    Replies: 4
    Last Post: 04-01-2008, 09:13 AM
  3. please help with DHCP
    By mujtba in forum Linux - General Topics
    Replies: 2
    Last Post: 02-14-2005, 01:31 PM
  4. Disable Wireless Router DHCP and Use Linux DHCP Server?
    By omnivore in forum Linux - General Topics
    Replies: 0
    Last Post: 01-19-2005, 04:18 PM
  5. DHCP
    By mugs in forum Linux - Hardware, Networking & Security
    Replies: 14
    Last Post: 11-20-2002, 04:46 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts