Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: tuxracer sound?

  1. #1

    tuxracer sound?

    Hi All,

    I recently set up a Red Hat 8 box, a huge upgrade from my old RH 6.2 box. Tuxracer comes with RH 8 and although the game runs fine, I have no sounds. The /usr/share/tuxracer directory has both music and sounds subdirectories, so it is evident that the game should have sound. There is a README file which does not address this issue and "tuxracer --help" gives no help.

    I do have sound for most things and many of the games that come packaged with this version of Red Hat. Just silence for Tuxracer and chromium. I did look at the tuxracer_init.tcl file which looked promising, but didn't find anything there that seemed to be commenting out sounds.

    I did a brief Google search and this seems to be a relatively common problem, but I didn't find any solutions posted.

    Any thoughts?


  2. #2
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Milwaukee, WI

    Re:tuxracer sound?

    [schotty@leinenkugel schotty]$ sudo rpm -q SDL_mixer
    [schotty@leinenkugel schotty]$
    Is that installed?

  3. #3

    Re:tuxracer sound?

    from the tuxracer forums

    To get the sound working in tuxracer...

    First, make sure your sound works by doing a play <an au file> or whatever. You can also do a cat <au file> >/dev/dsp

    The sources are on the Redhat 8.0 cds. Disk 3 to be precise. They are in the SRPMS directory.

    1. Do an rpm -Uvh on the tuxracer-0.61-16.src.rpm.
    2. cd /usr/src/SOURCES
    3. bunzip2 tuxracer-0.61.tar
    4. tar -xvf tuxracer-0.61.tar
    5. cd tuxracer-0.61
    6. configure --prefix=/usr --mandir=/usr/share/man
    7. make
    8. make install

    There is no need to mess with tuxracer-data files if you have tuxracer installed already via the Redhat RPMS. This will replace the tuxracer with the new one and your sound should work.

    Good Luck

  4. #4

    Re:tuxracer sound?

    i tried this and found all i needed to do was install smpeg, smpeg-devel and then rebuild tuxracer which is on the third disk in the SRPM directory and i have sound now.

  5. #5

    Re:tuxracer sound?

    Thanks Schotty and pbharris,

    Holiday obligations have severely limited the time I'va had available to do much of anything with my computers, but I just logged on and found your suggestions.


    Running the rpm -q SDL_mixer shows that I do have the same version installed. So that's not the problem.


    I'll poke around and see if I can find the .rpm's for smpeg and smpeg-devel and take it from there.

    Thanks for your input and suggestions. I will post my success (or lack of it) after I get a chance to try these things.

  6. #6

    Re:tuxracer sound?


    Another stupid question. No, two of them. I know that these may seem to be stupid, but I've only been playing with Linux since September and am still very green with the OS.

    1) I ran rpm -q tuxracer and got "tuxracer-0.61-16" the same version you're recommending installing. Should I still have to reinstall? By "rebuilding" tuxracer, do you mean going back to the RH .src.rpm and doing the "configure, make and make install" or is there an RPM command similar to the "rpm --rebuilddb" that will rebuild an existing install?

    Sorry for the really stupid questions, but your help and patience is appreciated.

  7. #7

    Re:tuxracer sound?

    just rebuild the RPM,
    rpmbuild --rebuild --target <processor> tuxracer.src.rpm will rebuild it, where <processor> should be replacesd with you procssor type, or omit this.

  8. #8

    Re:tuxracer sound?

    Hi All,

    I finally got around to trying to get tuxracer sounds up. I downloaded and installed the recommended smpeg and smpeg-devel .rpms. Then I got the tuxracer .src.rpm file off my RH8 install disk, copied that to my hard drive. I did the rpmbuild --rebuild thing. That looked like it was going well. The output was very verbose and was looking good. But, in the end... still no sound for Tux as he slides down the hills slamming into trees, going off course and etc. :-)

    Thanks all for your help and suggestions. This is certainly no major problem and nothing worth spending more time on.

    Thanks again!


  9. #9

    Re:tuxracer sound?

    if ya want i can make a build for your processor and put it in a place you can down load it from.

  10. #10

    Re:tuxracer sound?

    Hi pbharris,

    Thanks for the offer. I really do appreciate it, but what I really want to do is learn from this. I'm an old fart and not heavily into games like this, but WOULD like to learn about Linux and how to make it work myself. Not so much for making the game work, but to learn HOW to make it work. If that makes any sense at all to you.

    I am new to Linux and want to learn how to get around in it. I kind of enjoyed downloading and installing the suggested files and learning about how to to a "rpmbuild" command. I'd never done one of those before.

    I am serious about learning Linux and sincerely appreciate all the assistance I've gotten here. But I want to learn how to do things for myself so I don't have to impose on good folks like you forever to get things done.

    If you have any other suggestions or can explain to me how to make this build myself, I would be very appreciative.

    Thanks again!

    Jim (the Red Hat Newbie)

Similar Threads

  1. No CD sound
    By ripleyscat in forum Linux - General Topics
    Replies: 12
    Last Post: 01-27-2005, 04:50 PM
  2. no more sound
    By mojo jojo in forum Linux - Hardware, Networking & Security
    Replies: 7
    Last Post: 11-12-2003, 05:57 AM
  3. Sound is....gone!
    By Tyr_7BE in forum Linux - General Topics
    Replies: 12
    Last Post: 10-19-2003, 04:29 PM
  4. tuxracer is very slow
    By Jubei in forum Linux - Software, Applications & Programming
    Replies: 5
    Last Post: 11-28-2002, 03:20 AM
  5. Tuxracer blues
    By gmoreno in forum Linux - General Topics
    Replies: 6
    Last Post: 01-28-2002, 03:36 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts