Results 1 to 6 of 6

Thread: Problems with Distros

  1. #1

    Problems with Distros

    Lately I've been having boot problems with some distros, such as RedHat 8.0, Mandrake 9.0, Lycoris, Archlinux, YOS and LRs Linux.

    After installing them, and try to boot from hard drive, i get kernel panic error message, mostly about make sure init=root or something similar to that. I check & double checked and the root is set up correctly from what I can see.

    I have a 40gb Maxtor IDE drive and I already have Win98, WinXP on the first two partitions. I have Slackware 8.0 and Debian 3.0 installed into the extended partitions and they boot without any problems from HD or floppy disk.

    I have repartition the drive to add a small boot partition at the beginning of drive and still have the kernel panic with the above mention distros. LRs and YOS will boot if I use Slack's boot disk to mount their partitions.

    Can anybody give me some insight into what may be the problem? Why does Slack & Debian boot without problems, are they just that good?

    I've checked the cd discs, which were burned, and they seem to be okay. I even bought MDK 9.0 cd from and it still doing same error.

  2. #2

    Re:Problems with Distros

    well i will take a stab at this. if you have a separate boot partition on the drive say partition one. then your lilo.conf would have to have reference to the boot image being in this partition. so you should first make sure that the boot image is being put there and then you should make sure that lilo knows that your /boot and / are on separate partitions. personally i don't know how to do this. perhaps look at the distros which use lilo that you have got to work with this setup.

    edit it could also be a problem with your root= string

  3. #3
    Join Date
    Apr 2002

    Re:Problems with Distros

    I would also think it could be the boot loader. If you are using (the superior) grub, then you're menu.lst should have something like:
    kernel (hd0,3)/boot/vmlinuz ro root=/dev/hda7
    that would work if you kernel was on hda4, and you're root partition was hda7.

    Note: if you don't put the "ro" it will work, but the kernel will complain on boot about the filesystem being mounted read-write already.

  4. #4

    Re:Problems with Distros

    Thanks for the replies. What you mention I have already done. Slack & Debian I have the /boot & /root in each /root partitions.

    RedHat, I did put the /boot in the boot partition and checked to make sure everything was pointing to the correct partitions. RH also uses Grub by default and with the same error messages.

    I reinstalled the other OSes and put the /boot in the separate boot partition and in the root partitions and still get the same messages.

    I just don't understand it. It's no major deal but I did want to try other distros without removing Slack and Debian.

  5. #5
    Senior Member
    Join Date
    May 2001

    Re:Problems with Distros

    I use a combination of ntldr (win2k) and loadlin to do my multiboot madness. Boot floppies (and known good ones for the distros you don't wanna mess with) are pretty handy to have too.

  6. #6

    Re:Problems with Distros

    That's what I'm basically doing is using the floppy boot disk. But I guess I could use XP bootloader to load one.

Similar Threads

  1. 64-bit Distros
    By chessforce in forum Linux - General Topics
    Replies: 3
    Last Post: 09-10-2004, 11:56 PM
  2. Proprietary Distros
    By BurntAsh in forum Linux - General Topics
    Replies: 7
    Last Post: 02-20-2004, 04:27 AM
  3. New Distros?
    By mcdougrs in forum Linux - General Topics
    Replies: 0
    Last Post: 03-22-2003, 04:04 PM
  4. CD Distros and Knoppix
    By xbob in forum Linux - General Topics
    Replies: 1
    Last Post: 06-26-2002, 09:21 AM
  5. Live in UK? get your distros here.
    By popcorn in forum General Chat
    Replies: 7
    Last Post: 01-10-2002, 06:35 AM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts