do you have imlib (or imllib2). or is this symlink definitely provided by fnlib? i think imlib is needed for E. Did you check out the Enlightenment homepage? they should have install instructions.

edit the gdk error makes me think you may also need gdk-pixbuf.