This might be a crazy question, but do you have the correct sound settings in ~/.tuxracer/options? For instance, the following options should all be set:

set no_audio false
set sound_enabled true
set music_enabled true

...along with acceptable settings for the sound and music volume, frequency, audio buffer and format mode.