Results 1 to 2 of 2

Thread: I was trying to install nvdia drivers on a rh8...

  1. #1

    I was trying to install nvdia drivers on a rh8...

    So someone redirected me to osnews.com's article on how to install nvidia drivers on a rh8 system so i'm going step by step until i got a point where it said rpmbuild -bb *nvidia* and in my terminal it said "rpmbuild -command not found" now what?

  2. #2

    Re:I was trying to install nvdia drivers on a rh8...

    hi mantis,
    you probably did not install the package rpm-build, amke sure you have gcc and make installed too.

    here is psot from nv forums on how:
    nstructions for the impatient : Please read the note completely before doing this. Remeber to back up your config files. - just in case.

    Instruction are true for a fresh install of RH 8.0 a frsh install is always good folks so please consider doing one if you can - however if you upgraded fom a previous version you just need to do minor modifications and take a little extra care. Read the thread

    Also my XF86Config file which I have posted down in the thread was default generated by anaconda. Some of you may not be that lucky :-) so take a little care there too ... read the thread for tips.

    Step 1> Download the following from NVidia's site. (Note that the NVIDIA_kernel is the **src.rpm** rpm file and the NVIDIA_GLX is a **rpm**):
    NVIDIA_kernel-1.0-3123.src.rpm
    and
    NVIDIA_GLX-1.0-3123.i386.rpm

    Step 2> Make sure you have the kernel headers installed along with all other dev tools - these are needed along with other dependencies. The best way to ensure that you have all dependencies is to just go start menu > system settings > packages > and in the development section choose the Kernel development packge and install the whole thing.

    Step 3> In a gnome terminal window do a "rpmbuild --rebuild NVIDIA_kernel-1.0-3123.src.rpm" to create drivers for the RH 8.0 kernel. (This will create the binary RPM in "/usr/src/redhat/RPMS/i386/NVIDIA_kernel-1.0-3123.i386.rpm&quot

    Confirm this.

    Note: "rpm --rebuild" does not work with newer versions of rpm so use "rpmbuild --rebuild".
    Also do the rebuild in "X" in a gnome terminal. I dont know why but I had problems doing the rebuild and especially installing the kernel on command line. when I did this in a Gnome terminal in a runing Xserver it works fine. So do it in a gnome terminal.

    STEP 4> Installed this new (NVIDIA_kernel-1.0-3123.i386.rpm)
    "rpm -ivh /usr/src/redhat/RPMS/i386/NVIDIA_kernel-1.0-3123.i386.rpm"

    Note: It is important that you do this step also in a gnome terminal in a xserver session and not on command line. When doing through a command line the rpm install hanged and did not complete, I had to restart my computer. (I dont know why). But it works great in a terminal window in gnome and completes fine.
    The rpm after installation may complain that the nvidia_kernel is export tainted. This is OK ignore it. To read more on export tained and what it means:
    http://www.tux.org/lkml/#export-tainted

    Step 5>Now log out of gnome and go to the command line. Install the GLX (NVIDIA_GLX-1.0-3123.i386.rpm)
    "rpm -ivh NVIDIA_GLX-1.0-3123.i386.rpm"

    Note: I did this on the command line outside of gnome and it works so just do it guys the same way :-)

    Step 6> Edit the /etc/X11/XF86Config file and make a backup copy of the original:

    - Remove the Load "dri" line.
    - Change the Driver line from "nv" to "nvidia"


    Happy UT2003 playing.......
    I am so so happy. Hope this helps you guys. Its working yeah !!!

    ---------update for new kernel-2.4.18-17.8.0 ------------
    this message is also posted in the thread later....
    If you have never loaded the "nvidia" driver before. Use the instructions below to get going directly on the new kernel.

    Redhat auto updater will update your kernel to kernel-2.4.18-17.8.0
    This will stop XServer since we compiled it using the older version of the kernel kernel-2.4.18-14


    Instructions to get XServer working again for linux newbies or anyone else who cares:

    Step 1> To get Xserver working again we have to recompile the NVIDIA_kernel-1.0-3123 on Linux kernel kernel-2.4.18-17.8.0.
    Download the following files from NVidia's site if you deleted your initial file you downloaded before. (Note that the NVIDIA_kernel is the **src.rpm** rpm file and the NVIDIA_GLX is a **rpm**):
    NVIDIA_kernel-1.0-3123.src.rpm
    and
    NVIDIA_GLX-1.0-3123.i386.rpm

    Step 2> Open /etc/inittab file and change the following line. be carefull while changing this line. This will allow linux to reboot in text multiuser mode.
    Change :
    id:5:initdefault: to id:3:initdefault:

    Step 3> rename the previosly compiled kernel to make a backup copy. In a terminal window.
    "cd /usr/src/redhat/RPMS/i386"
    "mv NVIDIA_kernel-1.0-3123.i386.rpm NVIDIA_kernel-1.0-3123.i386.rpm.old"

    Step 4> upgrade your kernel to kernel-2.4.18-17.8.0 and kernel-source-2.4.18-17.8.0 and hwdata using the redhat downloader. Hope you still have other dependencies installed. The best way to ensure that you have all dependencies is to just go start menu > system settings > packages > and in the development section choose the Kernel development packge and install the whole thing.

    Step 5> Reboot and run linux in the new kernel. It will start in the command line mode. Login as root.

    Step 6> remove the previously loaded GLX and kernel files in the right order as below.

    rpm -e NVIDIA_GLX-1.0-3123
    rpm -e NVIDIA_kernel-1.0-3123

    Step 5> on command line do a "rpmbuild --rebuild NVIDIA_kernel-1.0-3123.src.rpm" to create drivers for the RH new kernel that we have now booted the system in. (This will again create the new binary RPM for the new kernel in "/usr/src/redhat/RPMS/i386/NVIDIA_kernel-1.0-3123.i386.rpm&quot

    Step 6> Installed this new (NVIDIA_kernel-1.0-3123.i386.rpm)
    "rpm -ivh /usr/src/redhat/RPMS/i386/NVIDIA_kernel-1.0-3123.i386.rpm"

    Step 7> Install the GLX (NVIDIA_GLX-1.0-3123.i386.rpm)
    "rpm -ivh NVIDIA_GLX-1.0-3123.i386.rpm"

    Step 8> your Xconfig file should work from before and you dont have to change anything in there.
    bnow do "startx" to start XServer.

    Step 9> once XServer works fine Open /etc/inittab file and change the following line again. This will allow linux to reboot in GUI mode again.
    Change :
    id:3:initdefault: to id:5:initdefault:

    Step 10> reboot agin to make sure everything is fine and have fun

Similar Threads

  1. New ATI drivers
    By Fatal Error in forum Linux - Software, Applications & Programming
    Replies: 1
    Last Post: 06-12-2005, 12:41 PM
  2. How Do I Install Drivers???
    By beezlebubsbum in forum Linux - General Topics
    Replies: 5
    Last Post: 07-12-2004, 09:46 PM
  3. ATI Drivers
    By gmoreno in forum Linux - General Topics
    Replies: 6
    Last Post: 01-07-2003, 07:15 PM
  4. Nvidia drivers (rpm) install problem
    By lewis in forum Linux - Software, Applications & Programming
    Replies: 0
    Last Post: 09-27-2002, 05:25 AM
  5. Drivers
    By mikeee in forum Linux - Software, Applications & Programming
    Replies: 10
    Last Post: 06-14-2002, 05:00 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •