Results 1 to 3 of 3

Thread: Where to find emerge?

  1. #1

    Where to find emerge?

    The Background:

    The situation is strange to begin with. A while back I was RARing a whole bunch of media for my roommate, watching a video, making 2 apps, compiling my project for school, and surfing a good 5 sites at once. Needless to say, my machine was occupied. Suddenly everything was black. Crap. Power outage. When it got back on I tried to boot into linux and was met with a bunch of errors when XFS auto self-checked. It couldn't mount as a result and I got a kernel panic. Ah well...fixable with the right tools. So I booted into windows to finish my project and resume my work. I was busy in a bad way that week so I didn't get around to fixing it. About half way through the week I tried starting linux to see the exact errors I was getting, and the same problem was still there. Then Saturday comes. I wake up around 10:30 feeling like whatever the hell was on my shirt from the night before, and figure it's a good time to fix linux. So I get all the XFS fixing utilities ready, have my bootdisk, and figure I'd better give it one last startup to see if I can't pinpoint exactly what's wrong. Linux starts up. Apparently the filesystem healed itself. Goes through the check without issue. Strange, no? Ah well..far be it for me to complain.

    The Problem:

    Yes, the filesystem healed itself, but apparently not without scar tissue. I'm running Gentoo, and every single time I try to emerge it installing, pretending, upgrading....I get this:

    root@boxeroo conor # emerge --update kde
    Calculating dependencies   !!! Name error in : category or package part missing.
    Traceback (most recent call last):
      File "/usr/bin/emerge", line 1220, in ?
      File "/usr/lib/python2.2/site-packages/", line 2094, in dep_bestmatch
      File "/usr/lib/python2.2/site-packages/", line 2077, in dep_pkgcat
        if self.hasnode(cat+"/"+mypkgdep_packagename):
      File "/usr/lib/python2.2/site-packages/", line 1893, in hasnode
      File "/usr/lib/python2.2/site-packages/", line 1842, in resolve_key
      File "/usr/lib/python2.2/site-packages/", line 1801, in load
      File "/usr/lib/python2.2/site-packages/", line 2498, in populate
      File "/usr/lib/python2.2/site-packages/", line 2506, in domask
      File "/usr/lib/python2.2/site-packages/", line 1813, in zap
    TypeError: unsubscriptable object
    root@boxeroo conor #
    So unless anyone can provide some insight as to what's wrong, it's my belief that emerge, or perhaps portage itself, is hosed. No problem. I'll just replace it. If only I could find it. Does anyone know where I can find it? I REALLY hope it's not built into gentoo, cause I don't want to have to reinstall just for portage, but if it comes to that I will. I like my portage
    So can anyone point me in the right direction here?

  2. #2

    Re:Where to find emerge?

    boot the liveCD and use that recover your system, and for Gods sack don't use XFS it's prone to killing your system like that (In my experience). If you need something that's fast and stable for desktop usage, ReiserFS with speedup patches (in 2.4.20 or various patchesets).
    There are some guides to recovering your system using the LiveCD on the gentoo forums.

  3. #3

    Re:Where to find emerge?

    Live CD you say? I'll have to check it out. Thanks muchly. And I also have not been very happy with XFS thus far. Like you said, very quirky and prone to serious errors. Reiser was good enough for me, although I've been wanting to see what ext3 is all about. I just tried XFS because the gentoo install seemed to think it walked on water. Anyway, Lovechild you've helped a lot with a lot of gentoo issues. You definitely get a karma point. Thanks a lot

Similar Threads

  1. Strange blocks emerge'ing xorg
    By Stuart in forum Linux - General Topics
    Replies: 5
    Last Post: 05-13-2005, 01:00 PM
    By imported_redhatgeek in forum Linux - Software, Applications & Programming
    Replies: 3
    Last Post: 07-29-2004, 06:59 AM
  3. Problems with emerge
    By gmoreno in forum Linux - General Topics
    Replies: 6
    Last Post: 10-13-2003, 03:49 PM
  4. emerge and libxml
    By mojo jojo in forum Linux - Software, Applications & Programming
    Replies: 3
    Last Post: 08-28-2003, 05:12 AM
  5. Gentoo users: emerge help
    By Tyr_7BE in forum Linux - General Topics
    Replies: 6
    Last Post: 02-24-2003, 05:54 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts