Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 24

Thread: error installing packages "krb5-libs" ; AND NVIDIA troubles

  1. #11

    Re:error installing packages "krb5-libs" ; AND NVIDIA troubles

    ah hah! herein lies the problem.... i was trying to install dev tools and such because of the Nvidia crap that is going on... but then... everytime i try to load anything from the disk, i would get that error above... so i was trying to figure that out at the same time.

    let me re-cap on what happened, cuz i was pretty disoriented trying to figure some of this out, and process everything, it is a foriegn land to me after all ... i really, REALLY appreciate everyones help i have gotten here! great community!

    i am picking up alot reading thru the information here, M$ Winblows, is really pissing me off, pardon the french, i am trying to get away, (i'm an admin at Indiana University, supporting Windows) and i have dabbled in Linux/Unix a little-little bit in the past, and really liked RH, it was the first real GUI based platform other than winderz that i have used.

    so, now that you know the story on with wtf happened...

    a) install RH8.0 dual boot on my system
    a.1) run upo2date (kerberos update included in kernel update and other things)
    b) love it
    c) play around with a lot of stuff
    d) love it even more ;D
    e) try to play Tux Racer.... whoa... ive got a 32mb NVIDIA GeForce 2 and its running like CRAP! it should'nt be running that slow... even on an NVIDIA
    f) checked the Nvidia messageboards for drivers (the drivers that are installed currently have generic at the end, and i cant check the "enable hardware accelleration" box = something is missing, read instructions for drivers
    g) open terminal, become root, try to execute the RPM's, get the "Warning:blah blah using root" errors
    h) on the message boards, i read to grep|blah to check for certain packages installed
    I) so i check my system and i do not have these installed
    j) try to install dev tools and other things from the RH install cd's
    k) BOINK!! error whenever i try to install any package from the install cd's

    and here i am

    wow, that was alot to type, sorry to ramble on :-[



    oh, and i WILL still try what you suggested, but, i have to wait till i get back to work tomorrow, its sleepy time now!

    -rob

  2. #12

    Re:error installing packages "krb5-libs" ; AND NVIDIA troubles

    more trouble in RPM land....

    the GLX file worked fine, but i am getting this with the NVIDIA_Kernel file when i do an rpmbuild (i got it installed directly from the rpm section on the cd rather than going thru the add/remove packages program):

    [root@IN-CFS-CRNLV01 relawson]# rpmbuild --rebuild --target i686 NVIDIA_kernel-1.0-3123.src.rpm
    Installing NVIDIA_kernel-1.0-3123.src.rpm
    warning: user buildmeister does not exist - using root
    warning: group buildmeister does not exist - using root
    warning: user buildmeister does not exist - using root
    warning: group buildmeister does not exist - using root
    Building target platforms: i686
    Building for target i686
    Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.53751
    + umask 022
    + cd /usr/src/redhat/BUILD
    + cd /usr/src/redhat/BUILD
    + rm -rf NVIDIA_kernel-1.0-3123
    + /usr/bin/gzip -dc /usr/src/redhat/SOURCES/NVIDIA_kernel-1.0-3123.tar.gz
    + tar -xf -
    + STATUS=0
    + '[' 0 -ne 0 ']'
    + cd NVIDIA_kernel-1.0-3123
    ++ /usr/bin/id -u
    + '[' 0 = 0 ']'
    + /bin/chown -Rhf root .
    ++ /usr/bin/id -u
    + '[' 0 = 0 ']'
    + /bin/chgrp -Rhf root .
    + /bin/chmod -Rf a+rX,g-w,o-w .
    + exit 0
    Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.22499
    + umask 022
    + cd /usr/src/redhat/BUILD
    + cd NVIDIA_kernel-1.0-3123
    + set +e
    ++ rpm -q --queryformat '%{VERSION}' rpm



    and it just hangs right there with a flashing cursor

  3. #13

    Re:error installing packages "krb5-libs" ; AND NVIDIA troubles

    ya know... I would swear that your rpm database is messed up some how... lets try this:

    rm -f /var/lib/rpm/__db*
    rpm --rebuilddb

    apparently this new version of rpm is somewhat.... buggy.

    here is a good read on it -
    http://www.rpm.org/hintskinks/repairdb/

    and i must say you are quite tenacious in dealing with your linux probs

  4. #14

    Re:error installing packages "krb5-libs" ; AND NVIDIA troubles

    i see... i will try that

    tenacious? well... years of being ****ed by billy gates will do that to you i guess

    and, im having a boat load of fun! i love learning new things and exploring and experimenting ;D

  5. #15

    Re:error installing packages "krb5-libs" ; AND NVIDIA troubles

    hey! it went all the way thru! BUT.... this is the very end of the verrrry long output... :

    RPM build errors:
    user buildmeister does not exist - using root
    group buildmeister does not exist - using root
    user buildmeister does not exist - using root
    group buildmeister does not exist - using root
    Bad exit status from /var/tmp/rpm-tmp.20062 (%install)
    [root@IN-CFS-CRNLV01 relawson]#


    i guess i dont have that kernel-source:

    [root@IN-CFS-CRNLV01 relawson]# ls /usr/src
    redhat
    [root@IN-CFS-CRNLV01 relawson]#

    so it should be there right? but i cant for the life of me find it! its NOT on the redhat install disks anyone know where i can dl it? and how do i know which one to install? ive seen a lot of "kernel" rpm's with different version #'s

  6. #16

    Re:error installing packages "krb5-libs" ; AND NVIDIA troubles

    this is the package named kernel-source - it is not an src.rom

  7. #17

    Re:error installing packages "krb5-libs" ; AND NVIDIA troubles

    if it were a snake it would have bit me!!

    kernel-source was on DISK 2!!!!!!!!! : : smack : : so i installed it, then up2date yelled at me, so i am updating it now, and for some reason its AWFULLY slow downloading, hmm... i will try rebuilding again when its finished updating....

    thanks for sticking it out with me!

  8. #18

    Re:error installing packages "krb5-libs" ; AND NVIDIA troubles

    SUCCESSSSSSSS!!!!!!!!!!!!!

    but with warnings....... not errors tho!

    [root@IN-CFS-CRNLV01 i686]# rpm -ivh NVIDIA_kernel-1.0-3123.i686.rpm
    Preparing... ########################################### [100%]
    1:NVIDIA_kernel ########################################### [100%]
    Warning: loading /lib/modules/2.4.18-17.8.0/kernel/drivers/video/NVdriver will taint the kernel: non-GPL license - NVIDIA
    See http://www.tux.org/lkml/#export-tainted for information about tainted modules
    Module NVdriver loaded, with warnings

    NVdriver installed successfully

    [root@IN-CFS-CRNLV01 i686]# rpm -ivh NVIDIA_GLX-1.0-3123.i686.rpm
    Preparing... ########################################### [100%]
    --- WARNING!!
    libglx.a
    libGLcore.a
    libGL.so.1.2
    --- The above file(s) possibly belong to a conflicting MESA rpm,
    --- or to a previous stale NVIDIA distribution.
    --- They have been renamed to xxx.<originalFile>.RPMSAVE to
    --- avoid conflicting with the files contained within this
    --- package.
    --- Please see the FREQUENTLY ASKED QUESTIONS section of
    --- /usr/share/doc/NVIDIA_GLX-1.0/README for more details.
    1:NVIDIA_GLX ########################################### [100%]
    [root@IN-CFS-CRNLV01 i686]#


    now to edit the XF86Config file

  9. #19

    Re:error installing packages "krb5-libs" ; AND NVIDIA troubles

    awww yea! Tux slides down that hill sooo smoooth now! ;D ;D

    BUT... (ahh you knew that was coming)





    i still cant check the Hardware Accelleration box? can you check yours?

    i mean, it seems to be on because everything is FLYING now

    what do you think about that?? i will do some searching on this also...

    and i owe you a beer and dinner or something pbharris!


    btw... dunno if you knew this already or not.... CTRL + ALT + Backspace restarts X real quick! i found that too hehe

  10. #20

    Re:error installing packages "krb5-libs" ; AND NVIDIA troubles

    hello,
    the warning is because NVidia does not wish to release thier drivers under GPL, and I suspect that is why you can not hit the 'enable 3d acceleration' also. there is some useful info in /proc/nv (I think...) that will tell you more that ya wanna.

    oh yea! i know all about the ctrl+alt+bkspc

Similar Threads

  1. Error for wireless request "Set Frequency" (8B04)
    By titanas in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 05-12-2006, 02:36 PM
  2. "invalid system disk" error message
    By icylife in forum Windows - General Topics
    Replies: 1
    Last Post: 04-05-2006, 09:30 PM
  3. Ubuntu ?? - Should I include "Universe" packages?
    By Compunuts in forum Linux - General Topics
    Replies: 1
    Last Post: 04-09-2005, 07:40 PM
  4. Getting an error while "Looking up internet address" Ethernet card issue?
    By Luxamar in forum Linux - Hardware, Networking & Security
    Replies: 11
    Last Post: 10-05-2002, 03:59 AM
  5. Xlib:  extension "GLX" missing on display ":0.0".
    By ph34r in forum Linux - Software, Applications & Programming
    Replies: 5
    Last Post: 12-06-2001, 04:52 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •