Results 1 to 9 of 9

Thread: XMMS fails to start

Hybrid View

  1. #1

    XMMS fails to start

    XMMS won't start from the menu (MDK 9.0) so I tried to run it from CLI, when I do (either as a user or root) it get this error message:

    ** WARNING ** snd_mixer_attach: No such file or derectory

    I can't find anything on the XMMS site or the MDK site.

    Does anyone know what this file is, or should be, or what I should do to egt this working.

    Dizzy

  2. #2

    Re:XMMS fails to start

    hello,
    if there is not anything thing you need in the driectory ~/.xmms try deleting that - it may be configured to use a outplut pluggin that you do not use anymore.

  3. #3

    Re:XMMS fails to start

    No luck there unfortunately. I deleted ~.xmms and ran xmms again. I got the same error and ~.xmms was recreated.

    Are you saying that if I have output plug ins installed that I don't need it might be causing it to fail?

    If so how do I know which one I need? I installed all the xmms plug ins from the MDK disks so this could be it.

  4. #4

    Re:XMMS fails to start

    i am guessing xmms is looking for a lib associted with a sound server , e.g. arts or esd - since this is mandrake i am guessing arts. is sound working at all? if you type mpg321 name.mp3 do you get sound? xmms is configured to use sound servers most of the time.

  5. #5

    Re:XMMS fails to start

    mpg321 isn't installed. I just get command not found. I tried to find it on the instal disks but couldn't.

    I have had sound from other apps though. Flash games running in Galeon have had sound with them.

    Thanks for your help so far though.

    Dizzy

  6. #6

    Re:XMMS fails to start

    hum... well if flash sounds are workking then i have to assume the rest are working.
    at this point i would grab off the rpms from there -> http://www.xmms.org/download.html
    tthe redhat rpm should be okay for you.

  7. #7
    Moderator
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Location
    Milwaukee, WI
    Posts
    5,760

    Re:XMMS fails to start

    wasnt that mpg123 ??

  8. #8

    Re:XMMS fails to start

    no sir! under redhat and debian it it called mpg321 and mpg123 is a link to it.
    On RedHat
    Code:
    [pbharris@bugs ~]which mpg123
    /usr/bin/mpg123
    [pbharris@bugs ~]ll /usr/bin/mpg123 
    lrwxrwxrwx    1 root     root            6 Oct 13 16:57 /usr/bin/mpg123 -> mpg321
    [pbharris@bugs ~]
    On Debian
    Code:
    [pbharris@pookie ~]which mpg123
    /usr/bin/mpg123
    [pbharris@pookie ~]ll /usr/bin/mpg123 
    lrwxrwxrwx    1 root     root           24 Nov  1 09:09 /usr/bin/mpg123 -> /etc/alternatives/mpg123
    [pbharris@pookie ~]

  9. #9
    Moderator
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Location
    Milwaukee, WI
    Posts
    5,760

    Re:XMMS fails to start

    Oh ... okay ....

    I fail to see the logic in that ... Oh well ...

    [me=Schotty]stands corrected.[/me]

Similar Threads

  1. dhcpd fails to start
    By JoeW in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 06-01-2012, 10:27 PM
  2. Class Wizard Fails
    By davidwp in forum Windows - General Topics
    Replies: 0
    Last Post: 10-26-2006, 03:58 PM
  3. Network error, eth fails
    By shajith in forum Linux - Hardware, Networking & Security
    Replies: 1
    Last Post: 06-12-2005, 07:45 PM
  4. Windows Messenger fails with SP2
    By regix in forum Windows - General Topics
    Replies: 0
    Last Post: 12-31-2004, 11:27 PM
  5. USB: insmod input.o fails, HID fails
    By x in forum Linux - General Topics
    Replies: 2
    Last Post: 02-18-2003, 08:15 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •