Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Network Mystery Blank

  1. #1

    Network Mystery Blank

    I'm setting up a server for a school project using Slackware 8.1. It's almost done, except for one thing.... it won't connect to the network.

    When I try to ping somebody, it says:

    PING ( 56 octets data.

    And then it just sits there. No 'network is unreachable', nothing. It doesn't say if the pings have made it, it doesn't say if they've failed. When I crtl-c it, it says:

    -- Ping Statistics--
    80 packets sent, 0 packets recieved, 100% packet loss.

    Whenever somebody else tries to ping me, the same thing happens to them. I can ping localhost,, and (the assigned IP number for my server) fine. I've checked the gateway, netmask, and name server several times: they're the right numbers.

    My ethernet card is an 3com Etherlink II. What's really strange is that it's worked before under Slackware 8.1.

    And yes, the cable is plugged into the wall.

    If anyone can figure out this mystery, they'll be my hero.

  2. #2
    Join Date
    Jun 2001

    Re:Network Mystery Blank

    Hello and welcome to the board.

    Could you post the output you get when type in: /sbin/ifconfig

  3. #3

    Re:Network Mystery Blank

    I typed in "cat /sbin/ifconfig"...

    And pages of gibberish came out on the screen. Boxes, intersecting lines, and the word 'GNU'. Now my command line is gibberish too.


  4. #4
    Join Date
    Jun 2001

    Re:Network Mystery Blank

    No, no! Not "cat /sbin/ifconfig" just "/sbin/ifconfig"!

  5. #5

    Re:Network Mystery Blank

    Oh.... I thought it was a config file.

    (Yeah, I'm a bit slow.)

    Here's the output:

    eth0 Link encap:Ethernet HWadd 00:A0:24:7F:E1:6E
    inet addr: Bcast: Mask:
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:100
    RX bytes: 0 (0.0 b) TX bytes: 0 (0.0 b)
    Interrupt:10 Base address:0x300

    lo Link encap: Local Loopback
    inet addr: Mask:
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

  6. #6
    Senior Member
    Join Date
    Apr 2002

    Re:Network Mystery Blank

    are you sure the subnet mask is

    and not


    ping loop back - check

    ping your own IP - check

    ping router - ?

    check firewall(try disabling it completely first) - ?

    link light on NIC - ?

    check physical connection(again) - ?

    can other machines ping router - ?
    (remote possibility whole network down)

    ## Now were getting desperate

    Not using Cross-over cable are you?

    Replace your machine w/ another using the same IP config and run
    the steps above.

  7. #7
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Milwaukee, WI

    Re:Network Mystery Blank

    And broadcast too -- see the .254 -- shouldnt the broadcast be .255 ?

  8. #8

    Re:Network Mystery Blank

    I'm pretty sure that the subnet mask should be See, my school has control over the 142.231.8.* and 142.231.9.* IP addresses.

    The link light on the NIC is on. Green constantly, no flickering or anything.

    I checked the cable eariler: it's not a cross-over one, it's just a regular ethernet cable.

    The computer next to me, having the same settings (except for the IP number) is able to get onto the network. It's running Linux From Scratch with support put into the kernel, though.

    As for the other suggestions, I'll check it tomorrow. Thanks for the help, everyone. ;D

  9. #9
    Join Date
    Jun 2001

    Re:Network Mystery Blank

    Are you getting the IP settings automatically from a DHCP server are they manually entered? If they are manually entered, you might be dealing with a bad NIC (I've seen this before). Any chance you could test your computer with a known good NIC or test this one in another computer?

  10. #10

    Re:Network Mystery Blank

    Check your netmask, as everyone has already pointed out. You have it listed as .254, and in a later post, claim it to be .224. Both netmasks are valid for a class B network. The correct one just depends on how your network is segmented.

    With the .254 netmask, your network will have hosts ranging from to Your network address will be and your broadcast address will be Right now, your 'ifconfig' output shows an illegal broadcast address.

    Keep this in mind, you will still be able to ping yourself at both and at, even if your netcard is malfunctioning (and even if ifconfig shows it as having an ip address). Just because your card has an ip address and claims to be up, and can ping itself, does not mean that the packets are actually being transmitted to the wire. I ran into that illusion on RH 6.2.

    Do an lsmod to see if the modules for the card are in fact loaded.

Similar Threads

  1. blank screen
    By svar in forum Windows - General Topics
    Replies: 1
    Last Post: 04-14-2009, 08:05 AM
  2. ZEN mystery
    By toastrack in forum Suse
    Replies: 2
    Last Post: 01-07-2008, 09:28 AM
  3. Visio 2003 Pro Templates are all blank
    By showtime in forum Windows - General Topics
    Replies: 0
    Last Post: 08-04-2005, 05:05 PM
  4. screensaver goes blank
    By doggiebone in forum Redhat / Fedora
    Replies: 6
    Last Post: 11-25-2002, 02:19 AM
  5. An original mystery
    By ndogg in forum General Chat
    Replies: 21
    Last Post: 11-25-2001, 06:41 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts