Results 1 to 10 of 10

Thread: Red Hat 8.0 and Kernel Panic

  1. #1

    Red Hat 8.0 and Kernel Panic

    I just installed RH 8.0 as dual boot setup with Win XP Pro on a Maxtor 40gb hd. XP is on /dev/hda1 and then I have /dev/hda2 as extended. A FAT32 partition on /dev/hda5.

    RH layout is this:
    /dev/hda6 = /boot
    /dev/hda7 = /root
    /dev/hda8 = /home
    /dev/hda9 = /swap

    Everything installed fine till time to do first real dual boot using Grub as bootloader. If i choose XP it loads without any problems, but when I choose RH, I get this error:

    Kernel panic: No init found. Try passing init = option to kernel

    I also get this error message if I try to use the boot floppy disk.

    What does this mean? When I look at how Grub is setup, I see it show root (hd0,5). Shouldn't root be (hd0,6)? This is the first time I've used grub so, I'm not familar with it.


  2. #2
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Milwaukee, WI

    Re:Red Hat 8.0 and Kernel Panic

    Hmm, correct me if I am wrong, but doesnt almost every OS require you to have the bootable partitions on a primary partition? I see that you are using 6-9, and I do know that 1-4 is primary and 5 on is extended partitions. That could be the problem right there.

    But as to your detective work -- try changing it to 6, it may help. I would presume that it is referencing hda5, since that is the extended partition (6-9 are partitions within it). PErhaps that will do the trick.

  3. #3

    Re:Red Hat 8.0 and Kernel Panic

    hd0,5 is the same a /dev/hda6 - it starts numbering from zero. as i recall this mean that grub can not find the initrd image file...

  4. #4

    Re:Red Hat 8.0 and Kernel Panic

    I"m beginning to think the same thing, Schotty, that I should put RH on a primary partition. And that's exactly what i'm going to try later today and I hope that will solve my problem.

    I thought the root situation was wrong, so hopefully putting linux on a primary partition will solve it.

    I am having the same error msg problems trying to install MDK 9.0 also.

    Thnx for all your help.

  5. #5
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Milwaukee, WI

    Re:Red Hat 8.0 and Kernel Panic

    Well, here is a trick that I like to do.

    Make a windows partition, big enough for getting the OS, you can use antother for data. Make a /boot partition next. Then continue on with your partitioning scheme.



    That works nice because the first two partitions will load each os

  6. #6

    Re:Red Hat 8.0 and Kernel Panic

    you should be fine on hda6, i mahve my root on a hda8 for one of my work computers, also redhat 8

  7. #7

    Re:Red Hat 8.0 and Kernel Panic

    Here's the deal. I re-partition my drive to see if moving RH closer to the front would help but it didn't seem to, since I get the same error message as above.

    Now my linux partition is set as:

    /dev/hda1 = winxp
    /dev/hda2 = /root
    /dev/hda3 = /home
    /dev/hda4 = extended partition
    /dev/hda5 = /swap

    I wasn't having any luck with RH using rescue mode either, but, when I used Slackware's 8.0 cd to boot and then typed mount root=/dev/hda2, I was able to get into RH and choose Failsafe mode to tinker around with RH's partitions.

    I noticed my fstab file didn't display / and /home partitions the way I think they should be. Instead of showing root as (/dev/hda2) it showed as LABEL=/ and /home showed the same way, LABEL=/home.

    I don't think that is correct so I changed them to be /dev/hda2 & /dev/hda3. But I'm still getting the same kernel panic error.

    Also I noticed when I edited Grub, it is showing this:

    kernel /vmlinuz-2.4.18-14 ro root=LABEL=/

    The same for the initrid file also has the LABEL=/ at the end of the linke.

    Why is it showing this and what should it be?


    PS. Why is Slackware 8.0 letting me get into RH but RH cd will not?

    I guess slackware is going to make me a true blue Slacker...I can't wait till 9.0 comes out, I'm going to buy the full cd set!

  8. #8

    Re:Red Hat 8.0 and Kernel Panic

    i had the same thing happen to me, i needed to pass into grub my root partition was not label=/ but /dev/hdb1, for you this would hda2

  9. #9

    Re:Red Hat 8.0 and Kernel Panic

    Thats what I was beginning to wonder. I will give it a shot and let you all know what happen.

  10. #10

    Re:Red Hat 8.0 and Kernel Panic

    Well I've come to the conclusion that RH 8.0, MDK 9.0 and Lycoris will not install for some reason on my system. I reformatted the HD clean and started from scratch, even with Win XP.

    And turns out, the only Linux that installs without any problems is Slack 8.0, the version I've had all along. I guess I'm just a slacker deep down. ;D

    I can't wait for Slack 9.0 to come out and install it.

    Thnx for everybody's help. I'm go stick with Slack for now.

Similar Threads

  1. Upgrade: FC2->FC5 then kernel panic!
    By axxis in forum Redhat / Fedora
    Replies: 3
    Last Post: 05-16-2006, 12:07 PM
  2. kernel panic
    By ps_biju in forum Linux - General Topics
    Replies: 3
    Last Post: 02-06-2006, 04:09 PM
  3. Kernel panic - CPU text corrupted
    By hawkcl in forum Linux - Hardware, Networking & Security
    Replies: 8
    Last Post: 09-21-2005, 04:53 PM
  4. Zipslack - Kernel Panic: No Init found.
    By Noxious in forum Linux Distros
    Replies: 3
    Last Post: 11-11-2004, 10:20 AM
  5. kernel panic
    By lyons_grant in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 04-08-2002, 04:52 PM


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts