When I boot RH7.2 lately I have been seeing a [FAILED] in mount /dev/fd0 "is not a valid block device"

Hasn't bothered me as whenever I wanted to use the floppy I did: mount /dev/fd0 and it came to the party just fine and wrote/read

Here is the /etc/fstab and ls -l

Code:
[root@localhost root]# ls -l /dev/fd0
brw-rw----    1 ken      floppy     2,   0 Aug 30  2001 /dev/fd0
/etc/fstab
Code:
/dev/cdrom               /mnt/cdrom               iso9660 noauto,owner,kudzu,ro 0 0
/dev/cdrom1             /mnt/cdrom1             iso9660 noauto,owner,kudzu,ro 0 0
/dev/fd0                    /mnt/floppy               vfat   auto,owner,kudzu 0 0
owner vs. users makes no difference in fd0

Why it's NOW a huge problem is that I just got my RH8.0 and tried to upgrade and that falls apart with:

Error mounting device fd0 as /mnt/floppy No such device or address OK to reboot? and that goes on for as long as I want to play the game.
I've googled for an answer, and found lots but none was the 'right' one, I've tried PETS and nothing jumped out that was clearly the problem

As root (not su) I tried depmod -a and it returned nothing (but completed)

Anyone have a clue what to try next?