Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
kde3 - dependencies question
Results 1 to 5 of 5

Thread: kde3 - dependencies question

  1. #1
    Associate
    Join Date
    Aug 2002
    Posts
    14

    kde3 - dependencies question

    So, I read about the security issue with KDE's Konqueror, and naturally, I want to plug the hole. Right, so off I go to KDE's website, and I download a bunch of rpm's. Of course, installing the rpm's didn't work!

    The rpm is telling me about dependency problems with lots of files (like libartsflow...). So, I check and these files are indeed on my system. I check /etc/ld.so.conf, and added the directory where the files are, ran ldconfig, and still the same error. Sheesh. What's going on here, and why? Did I leave out a crucial step?

    Should I go with compiling the source files instead? I am tempted to do so, but have a couple of concerns.... First, KDE's website recommends against installation of parallel copies of KDE, and I don't know if using the source files is going to leave the original KDE files intact and screw up my system or not. And, it is just a hack, not really solving the problem of the missing dependencies.

    My system is Red Hat 7.3, could that have anything to do with it? I've read about Red Hat not being "kind" to KDE, but couldn't find any specifics about it.

    Any ideas or input?

  2. #2

    Re:kde3 - dependencies question

    hello,
    for some reason redhaty has not included these in the up2date stuff, i usually like redhat, but this is bull....


    anywho - have you tried doing a rpm -Uvh *.rpm in the directroy where the RPMs are?

  3. #3
    Associate
    Join Date
    Aug 2002
    Posts
    14

    Re:kde3 - dependencies question

    Thanks for the input.

    Rpm -Uvh doesn't work, it involves failed dependencies (no matter where I copy the rpm to - I tried that :-( )

    There were about 10 or so files that were required, but most of them were required by KDE3.0.0 apps/libraries, so I figured I could safely ignore those dependencies, since I was going to install new versions of them anyway. That left me with 4 unresolved dependencies (files), and for the life of me I couldn't figure out how to get these files recognized by the rpm - the files were there on the hard drive, and the path to them was in ld.so.conf.

    Well then, I started to read as much as I could about failed dependencies on the web, and there are a LOT of these problems out there. Unfortunately, I couldn't find a case exactly like mine.

    The happy ending to my problem was that I used the --nodeps flag, crossed my fingers, and hit the Enter key. Everything works, my settings remained, and no random crashes, so I guess those files weren't needed after all. (They were all files needed by arts3.0.3, and I did copy them somewhere first just in case, before I tried the rpm w/ the --nodeps flag. Actually, those files are still there on my hard drive, the upgrade didn't remove them, but I'm not sure if my arts server is FULLY functional or not - however, I do have sound, so I'm not complaining)


    Thanks for the tip though, I'll remember to always try that if I run into the same problem with some other rpm.

  4. #4

    Re:kde3 - dependencies question

    hmmm.

    I wonder if maybe the rpmz you're using are just assuming that everything it needs will be in the path, waiting to be found. If you have just installed a whole s*** load of stuff, you might wanna consider running 'updatedb' on your system, in addition to 'ldconfig', which is good, too - if there are libraries involved.

    updatedb updates the database used by the 'locate' command, and I've seen it fix problems like this before. Sounds like all is working for you now, but maybe this tip will help in the future.

    Also, you might've been helped by a couple of good RPM one-liners. I myself can't stand navigating the RPM man page, so I put up a little cheat sheet for RPM right here. Hope cloverm won't mind the 1/2 shameless plug -

    Hope this helps.


  5. #5
    Associate
    Join Date
    Aug 2002
    Posts
    14

    Re:kde3 - dependencies question

    Brian,


    Thanks for the tips and the link. One can never have too many sources of good information.

    (Sorry for the late reply, I've been in "school" lately. Sadly, it doesn't leave me with time for much else).

    KDE 3.0.3 is (as far as I can tell) doing just fine. In fact, the upgrade fixed some problems I was having with some of its components - either the 3.0.0 release had some problems, or else RedHat's implementation leaves something to be desired.

    Thanks for your input,

    Mike

Similar Threads

  1. Linux Dependencies
    By comtux in forum General Chat
    Replies: 27
    Last Post: 12-14-2004, 05:03 PM
  2. dependencies
    By elovkoff in forum Linux - General Topics
    Replies: 3
    Last Post: 03-19-2003, 01:02 AM
  3. failed dependencies
    By ohnoitselton in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 02-04-2003, 01:33 AM
  4. compiler dependencies
    By trickster in forum Linux - Software, Applications & Programming
    Replies: 4
    Last Post: 10-06-2002, 10:37 PM
  5. Solving dependencies
    By rreed in forum Linux - Software, Applications & Programming
    Replies: 2
    Last Post: 09-21-2002, 02:40 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •