Results 1 to 5 of 5

Thread: Problems with Iptables

  1. #1

    Problems with Iptables

    Hi forum users!

    All of the sudden, whenever i tried to start Iptables with the command lines (services iptables start or /etc/init.d/iptables start)
    it was going back to the prompt without giving the OK messages stating that it was started properly. A couple of weeks ago i uninstalled Iptables and left that problem unsolved.

    Now, the thing is that, when i uninstalled Iptables, i do remember that there was a service using it that was causing the uninstallation not being possible. I had to uninstall that service before. But i totally forgot it's name :cry:

    I tried to reinstall Iptables anyways but there's still the "back at the prompt without saying nothing" problem.
    When running a "status" on it, it says "firewall stopped"

    I know that if a service needs an other one to work properly but i install it anyways: it won't work!
    What may have caused the problem in the first place?

    Iptables was working fine before!

    Any ideas?
    And any ideas about the name of the second service so i can try to reinstall it as well?

    Tanx!

  2. #2
    Which Linux and version do you use?

    Maybe key word is "ipchains" ok?

  3. #3
    Sorry about that, i forgot to mention it.

    Red Hat 9.0

  4. #4
    Administrator Moderator
    Member
    starfish's Avatar
    Join Date
    Apr 2004
    Posts
    141
    You really need to look at the errors in your /var/log/messages file to get a better idea about what is going wrong.

    For a home / SOHO server, I'd suggest you set your logging level to "debug" before doing this. Try this link for more details on how to do this.
    http://www.linuxhomenetworking.com/linux-hn/logging.htm

    Once you have setup syslog, use the "tail -f /var/log/messages" command in one window to see the live error messages while restarting iptables in the other.

    Do a search for the error message you get to determine what's wrong.

  5. #5
    Thanks for the reply Starfish!

    Now I'll know what to do next time. Actually, since it was a linux box only used for testing, it wasn't really a big deal, if it was fixed or not, but i spoke with someone about it, and he said that whenever you try to start an application and nothing appears i.e. saying that its properly started, it probably means that there's some problems with the configuration file.
    With the 'debug' that you mentioned, i would have probably witnessed that!

    See ya!

Similar Threads

  1. Replies: 1
    Last Post: 09-11-2009, 03:54 PM
  2. iptables
    By digitalspy99 in forum Linux - General Topics
    Replies: 1
    Last Post: 08-05-2008, 03:42 AM
  3. iptables
    By laci in forum Security
    Replies: 1
    Last Post: 04-24-2005, 02:26 AM
  4. NAT and Iptables
    By balajianand in forum Linux - Software, Applications & Programming
    Replies: 4
    Last Post: 01-28-2003, 09:01 PM
  5. iptables
    By elovkoff in forum Security
    Replies: 9
    Last Post: 03-19-2002, 02:23 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •