Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: kscd problem suse8.1

  1. #1

    kscd problem suse8.1

    Total newbie in linux.I have sound.The problem is I can't figure out kscd.I found out through "dmesg" that my dvd is hdc and my cd writer is hdd.When I try to configure kscd I have tried /dev/dvd...... /dev/hdc....../dev/dvd/hdc.The same with my cdwriter using hdd.
    The message I get when I try a music cd is cd rom read or access error or no audio disc in drive.make sure you have permission to /dev/cdrom/hdc
    I have gone into user's in root and given myself access to cdrom,disc etc.What am I doing wrong?

  2. #2

    Re:kscd problem suse8.1

    hello,
    have you tried putting an data disk in the drive to make sure that part is working okay? also, how did you give yourslef permisions? e.g. chmod 766 /dev/cdrom/hdc ...

  3. #3

    Re:kscd problem suse8.1

    My suse disk works if I want to add something to linux.I gave myself permission using the user/group.I don't know what you call it but it's where I add a check mark to add myself to a group.
    I'm not sure about the chmod command.I tried logging in as root by typing su.(yhis is in the konsole)It asks me for the root password but when I type nothing happens.Again,I know that I'm doing something wrong,but I don't know what.
    Thanks for the reply.

  4. #4

    Re:kscd problem suse8.1

    hello,
    open konsole again - type su - to become root, then type ls -l /dev/cdrom/ and let us know what it looks like - it should look something like this:


    Code:
    [pbharris@bugs ~]ls -l /dev/ | grep cdrom
    lrwxrwxrwx    1 root     root            9 Oct 13 17:09 cdrom -> /dev/scd0
    lrwxrwxrwx    1 root     root            9 Oct 13 17:09 cdrom1 -> /dev/scd1
    [pbharris@bugs ~]ls -l /dev/ | grep scd0 
    lrwxrwxrwx    1 root     root            9 Oct 13 17:09 cdrom -> /dev/scd0
    lrwxrwxrwx    1 root     root            9 Oct 30 21:42 dvd -> /dev/scd0
    brw-------    1 pbharris disk      11,   0 Apr 11  2002 scd0
    [pbharris@bugs ~]
    btw - have you tried simply poping in a CD and hitting the play button? music CD don't get mounted like data CDs do.

  5. #5

    Re:kscd problem suse8.1

    I've tried putting the cd in and hitting play.Nothing.I'm on my way to try the command you just gave me.

  6. #6

    Re:kscd problem suse8.1

    ls - l/dev/cdrom/ it says no such file or directory

  7. #7

    Re:kscd problem suse8.1

    hello,
    i think you may have missed the space between the -l and the /dev/ i.e. ls -l /dev/cdrom

  8. #8

    Re:kscd problem suse8.1

    First line is l root root (date) /dev/cdrom->hdc
    The spacing isn't correct.Thats just what it says.When I type dev/cdrom after the first line I get 1al disk 22 (date) Am I giving the right info?

  9. #9

    Re:kscd problem suse8.1

    hello,
    yes that looks right, what does not look right that is the kscd program accessing /dev/cdrom/hdc - it should be accessing /dev/cdrom or /dev/hdc - but there is no /dev/cdrom/hdc.

    open kscd - hit the button with the hammer and screwdriver on it, a config window will pop up - make sude the box labeled CD-ROM Device has /dev/cdrom as an entry.

  10. #10

    Re:kscd problem suse8.1

    I have it set for /dev/cdrom. It says there's no cd in or I don't have permission to use it.I went to administration then to user,group and I'm listed for using the cdrom.

Similar Threads

  1. ..now using SUSE8
    By coltrane in forum Linux - General Topics
    Replies: 2
    Last Post: 05-11-2002, 05:40 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •