Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
How to tell version of GTK+
Results 1 to 10 of 10

Thread: How to tell version of GTK+

  1. #1
    Associate
    Join Date
    Apr 2002
    Posts
    39

    How to tell version of GTK+

    I'm going to try to install gaim and I see it requires version 1.2.5 of the Gimp toolkit (GTK+). I would like to confirm my installed version, but not sure how (I only know, in fact, that gimp is available, not GTK+).

    Thanks much

    ~ Phaete

  2. #2

    Re:How to tell version of GTK+

    hello,
    for rpms do a rpm -q gtk+ for debain try a dpkg -l | grep gtk

  3. #3
    Associate
    Join Date
    Apr 2002
    Posts
    39

    Re:How to tell version of GTK+

    Thanks .... and good yucks on the '10 kinds of people' quote.

    Indeed, rpm -q gtk+ indicated nothing installed, but I did get a version of glib returned. Also, I tried the gaim install and it reported no GTK+ found.

    So, now that I ran ./configure WITHOUT a proper version of GTK+ installed, can I just download and install GTK+, then re-run .configure, or must I remove whatever was distributed by the first ./configure run??

    ~ Phaete

  4. #4

    Re:How to tell version of GTK+

    hello,
    yea - just to re-run .configure - it will overwite what ever make was there - but it will be no problem.

  5. #5
    Associate
    Join Date
    Apr 2002
    Posts
    39

    Geez!!:How to tell version of GTK+

    OK - now I'm really confused. According to the text below (returned at the end of the gaim ./configure attempt), I have version 1.2.10-205 of gtk installed, yet gaim won't configure because it claims glib to be version 1.2.5:

    checking for glib-config... no
    checking for GLIB - version >= 1.2.5... no
    *** The glib-config script installed by GLIB could not be found
    *** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
    *** your path, or set the GLIB_CONFIG environment variable to the
    *** full path to glib-config.
    configure: error:
    *** GLib is required to build Gaim; please make sure you have the GLib
    *** development headers installed. The latest version of GLib is
    *** always available at http://www.gtk.org/.
    phaete:/home/dan/gaim/gaim-0.59.3 # rpm -q gtk
    gtk-1.2.10-284
    phaete:/home/dan/gaim/gaim-0.59.3 # rpm -q glib
    glib-1.2.10-205
    phaete:/home/dan/gaim/gaim-0.59.3 #

    Any idea wassup?

  6. #6

    Re:How to tell version of GTK+

    hello, are the glib and glib2 devel packages installed?

  7. #7
    Associate
    Join Date
    Apr 2002
    Posts
    39

    Re:How to tell version of GTK+

    I assume they are based on the system response to rpm -q glib as noted above as being version 2.1.10.205. If that response DOESN'T imply a proper install of glib, then it is possible I do NOT have glib installed.

    I DID download the 1.2.9 versions of glib and gtk from the gtk.org site and ran the ./configure and make of both. I did this as root (su in terminal window), but I wonder if the install info. about 'If GLIB was installed in PREFIX, make sure PREFIX/bin is in your path ....' may be my problem.

    I'm not very experienced at installing new app.'s in Linux and am sure I'm doing something wrong. Just not sure how to figure out just what

    Thanks for the help

  8. #8

    Re:How to tell version of GTK+

    hello,
    is there a reason you are installing from source? you can but don't need to.

  9. #9
    Associate
    Join Date
    Apr 2002
    Posts
    39

    Re:How to tell version of GTK+

    No - no reason installing from source ... except, of course, naivete! This is the way I have installed all Linux app.'s (other than the default SuSE YaST2 method). I noticed there was a 'binary' download at gtk.org for glib and gtk+ ... is this an easier way? Or are you thinking there is a 'rpm' install or something?

    Regardless, do I NOT have appropriate versions of glib and gtk+ installed as indicated by the version 2.1.10.xxx return to the rpm -q glib, etc. command?

  10. #10

    Re:How to tell version of GTK+

    heres the deal, you have the libaries but not the include files, libraries are needed to run the programs already made, include are needed to make

    install the gtk and glib devel packages called gtk-version-dev or gtk-dev or something like that. they should be on your distro cd

    good luck

Similar Threads

  1. New Version
    By friskydrifter in forum Linux Distros
    Replies: 5
    Last Post: 07-01-2004, 02:47 AM
  2. which version
    By Badkarma in forum Linux - General Topics
    Replies: 8
    Last Post: 03-18-2004, 02:46 AM
  3. what version?
    By pinehead in forum Linux - General Topics
    Replies: 3
    Last Post: 03-02-2004, 12:32 AM
  4. which version to use
    By sentme_mail in forum Linux - General Topics
    Replies: 11
    Last Post: 02-01-2004, 07:52 AM
  5. new Freeciv version out
    By in forum Linux - Software, Applications & Programming
    Replies: 5
    Last Post: 07-16-2002, 09:05 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •