Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19

Warning: Function ereg() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 4

Warning: Function split() is deprecated in ..../includes/class_postbit.php(345) : eval()'d code on line 19
swat doesn't start
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: swat doesn't start

  1. #1

    swat doesn't start

    I have enabled swat in services and inet.d but when I type http://linux-box:901 in a browser window I get Connection was refused when attempting to connect to linux-box:901.

    My Samba shares work to the windows boxes and I can ping linux-box but swat won't start.

    Where's the Murphy setting to get this going?




  2. #2
    Guest

    Re:swat doesn't start

    what distro are you running? I know on the older distros you had to go into control-panel and just change an item to get swat working. Personnaly I would edit the smb.conf file by hand. If you use swat, it will overwrite the conf file and take out info that might probe usefull to you in the future. Just a suggestion.

  3. #3

    Re:swat doesn't start

    Oh I'm running SuSE 7.3. SWAT used to work; in fact I used it to get Samba going but I changed something manually and it quit and I cannot figure out what I changed' A nuisance more than anything

  4. #4

    Re:swat doesn't start

    Hello,
    Are you running the web browser from the same computer running SWAT? I would be guessing that the port is being bloacked by a firewall or that port was closed.

    btw - welcome to linux junior.

  5. #5

    Re:swat doesn't start

    Thanxalot for the replies.

    I have tried browsers on the same box and also browsers on other winders boxes with the same results. I have 4 PC's connected to a 5 port switch and the uplink port to D-Link gateway hooked to DSL modem for intenet connection sharing.

    Is the port blocked by the gateway or is Linux blocking the port? I don't have a firewall enabled on the Linux box.

  6. #6

    Re:swat doesn't start

    okay - lets restart inetd do a /etc/initd.d/inetd restart i think is the command, can look a /etc/inetd.conf to make sure it is in there...

  7. #7

    Re:swat doesn't start

    I did the inetd restart but the message was the same -- connection refused.

    I started looking at the hosts, hosts.allow and hosts.deny files and after changing them I have swat going. Thanx to pbharris for pointing me in the right direction.

    1 question though -- I have dynamic IP addresses and hosts has an entry like
    192.168.0.22 linux-box. Must i monitor my IP address and change hosts when it changes? It seems that defeats the purpose of dynamic IP addresses.

  8. #8

    Re:swat doesn't start

    hello,
    i am not good with dhcp stuff but i dobut it would matter at all.

    , but i fail to see why it would fail to start up...

    you are running this from inetd - what does the entry look like? anything like this:

    http://us1.samba.org/samba/docs/man/swat.8.html

    btw - does http://locahost:901 give ya anything?

    and oh yea - you may wish to post in servers and networking, there are some bright people there who are better with this stuff than me.

  9. #9

    Re:swat doesn't start

    Hi group--

    I did not phrase my question very well. DHCP works just fine. I found that http://127.0.0.1:901 worked just fine for swat but http://linux-box:901 and http://192.168.0.10 generated a connection refused error. I never did try the http://localhost:901. It appears that was due to hosts.deny set to http-rman: ALL except local and host file not containing the 192.168.0.10 linux-box entry.

    Since I am using DHCP, what if on the next boot my IP changes to 192.168.0.222? I am assuming I will have to manually change the IP address in the hosts file to get swat to come up again.

    thanxalot for the reply.

  10. #10
    Moderator
    Good Guru
    Schotty's Avatar
    Join Date
    Jul 2001
    Location
    Milwaukee, WI
    Posts
    5,760

    Re:swat doesn't start

    /etc/hosts needs to be updated then.

    Here is a snippet of mine
    Code:
    # Do not remove the following line, or various programs
    # that require network functionality will fail.
    127.0.0.1       localhost system11.amerivoice.com system11
    
    206.190.6.2     System_2
    206.190.6.3     System_3
    206.190.6.4     System_4
    206.190.6.5     System_5
    206.190.6.6     System_6
    206.190.6.7     System_7
    206.190.6.8     System_8
    206.190.6.9     System_9
    206.190.6.10    System_10
    206.190.6.11    System_11
    Note that the first line is me -- the llopback, and each hostname for me. Then each line is another PC on the LAN. Also note that I am system11. System 11 is also redifined as its accesible IP. Do that too.

    so
    Code:
    127.0.0.1  localhost linux-box.lan.com      
    192.168.10     linux-box
    or something. Make sure you have your loopback line

Similar Threads

  1. X-server suddenly doesn't start up anymore
    By AljoshaNL in forum Linux - General Topics
    Replies: 5
    Last Post: 11-17-2005, 04:40 PM
  2. SWAT
    By cherokee in forum Linux - Hardware, Networking & Security
    Replies: 4
    Last Post: 05-13-2004, 02:29 AM
  3. My Slackware's X doesn't start...
    By shebang in forum Linux - Software, Applications & Programming
    Replies: 29
    Last Post: 02-16-2004, 12:48 AM
  4. Why doesn't konqueror start?
    By ursidae in forum Linux - Software, Applications & Programming
    Replies: 0
    Last Post: 11-16-2002, 11:37 PM
  5. SWAT in RH 7.3
    By xgtr in forum Linux - Hardware, Networking & Security
    Replies: 2
    Last Post: 06-01-2002, 06:04 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •